1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Error sending Mails (#4.3.0) qq trouble in home directory

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by ElmarL, Nov 15, 2009.

  1. ElmarL

    ElmarL Guest

    0
     
    I upgraded my PLESK Installation to 9.2.3 yesterday and activated the built-in graylisting (greylisting).

    Everything works fine, except sending mails.

    The problem is, that mailusers from local domains are treated as if they were foreign domains by graylisting.

    They get the error "(#4.3.0) qq trouble in home directory" when trying to send an email the first time.
    5 Minutes later the E-Mail goes through without problems.

    So my question ist, how can i change the behaviour of greylisting, so that SMTP-Auth-authenticated attempts to send a mail are not processed by greylisting??

    Any help ist appreciated...
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Regarding error '(#4.3.0) qq trouble in home directory' I can say that it is correct behaviour of GreyListing feature: the GL handler is returned TEMPFAIL error code(4xx) but explanation text is wrong.
    This problem was discussed by developers and no quick solution because some redesign before-queue handlers processor required. There are no such functionality in handlers specification. As i understand Outlook Client must to place such message into outgoing queue and send later(after GL interval was exceeded).

    Regarding your question about SMTP-Auth-authenticated attempts I have submitted request to developers. I will update this post as soon as I receive answer from devs.
    Don't hesitate to remind me in PM if I forget :)
     
  3. JaroslavV

    JaroslavV New Pleskian

    19
     
    Joined:
    Oct 7, 2009
    Messages:
    2
    Likes Received:
    0
    stejná chyba ..
     
  4. JaroslavV

    JaroslavV New Pleskian

    19
     
    Joined:
    Oct 7, 2009
    Messages:
    2
    Likes Received:
    0
    same error
     
  5. Marco Lücke

    Marco Lücke Guest

    0
     
    Same

    Hello,
    i have the same problem.
    Every outgoing email will go into the greylist. if you send an email to the recipient a second time, everything is fine.
    Can you please fix that.
    Greets
    Marco
     
  6. Marco Lücke

    Marco Lücke Guest

    0
     
    Hello,
    we have the same problem.
    Outgoing mails will be stopped in the postexit and after 5 minutes they will be sent.
    recipients which are already blocked for 1 time will not be blocked again.
    if you look into the greylist you can see the blockd outoing mails.
    We have Plesk 9.2.3 wit Greylist Manager.
    Greets
    Marco
     
  7. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    It is necessary to understand that mail from the authorised user will not be exposed to check as GL handler and any another (in an ideal) before-queue handler (SPF, drweb, kav). It is made for reduction of useless server overloading because client is authorised already.
    In all other cases absence of delay indicate about operation of one of rules black/white pages or mismatch IP of the address to the domain name given on HELO or received from ' From field: ' SMTP sessions.
     
  8. Marco Lücke

    Marco Lücke Guest

    0
     
    ??

    Hello Igor,
    thanxs for the reply but i don´t understand what you want me to tell.
    Checking outgoing mails in the greylist is a bug, isn´t it. GL should only chekc incoming mails.
    Greets
    Marco
     
  9. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Marco,

    I will update this thread when I receive any additional information from developers.
     
  10. Marco Lücke

    Marco Lücke Guest

    0
     
    Any new news?

    Hello,
    are there any further improvements?
    Some days have been passed by, nothing happened.
    Greets
    Marco
     
  11. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Developers have informed that there is no any greylisting handler for before-remote. It can occurs if mails were sent with before-queue for any reasons. They have informed that can't say now why it can occurs and deep investigation directly on server is required. They have suggested contact Support Team.
     
  12. Marco Lücke

    Marco Lücke Guest

    0
     
    Any new news

    Hello Igor,
    any new news about the problem, because it still exists, even on upgrading to 9.3 of plesk.
    Greets
    Marco
     
  13. daffy779

    daffy779 Guest

    0
     
    Same problem with plesk 9.3.0

    Any solutions from developpers?
     
  14. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    If you mean "qq trouble in home directory" message that it is correct behaviour of GreyListing feature: the GL handler is returned TEMPFAIL error code(4xx) but explanation text is wrong.
     
  15. CooL LeO

    CooL LeO New Pleskian

    10
    30%
    Joined:
    Jul 12, 2012
    Messages:
    5
    Likes Received:
    0
    Plesk 10 still the same error

    I randomly still experience this error. I have installed new plesk 10 and getting this randomly on different mailboxes.
    This is coming only on windows system using Outlook.
     
  16. iantresman

    iantresman Basic Pleskian

    17
    35%
    Joined:
    Oct 14, 2011
    Messages:
    82
    Likes Received:
    0
    I solved this problem by deleting the mailbox, and recreating it (obviously remembering to copy all the settings first).
     
Loading...