1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

[ERROR] Unable to install Plesk.

Discussion in 'Plesk Automation' started by KristianM, Aug 12, 2012.

Thread Status:
Not open for further replies.
  1. KristianM

    KristianM Regular Pleskian

    22
    40%
    Joined:
    Jul 17, 2011
    Messages:
    227
    Likes Received:
    10
    Location:
    Augsburg, Germany
    Hi,

    getting the following error while installing PPA:
    It's a fully up to date CentOS 5.8 x64:
    Regards,
    Kristian
     
  2. KristianM

    KristianM Regular Pleskian

    22
    40%
    Joined:
    Jul 17, 2011
    Messages:
    227
    Likes Received:
    10
    Location:
    Augsburg, Germany
    Hi again,

    after removing bind-libs and bind9 manually, Install was successfully finished.

    Regards,
    Kristian
     
  3. Andrey Dobrenko

    Andrey Dobrenko Regular Pleskian

    26
     
    Joined:
    Jun 26, 2007
    Messages:
    256
    Likes Received:
    0
    Hi KristianM,

    Recently, Centos 5.8 have released a minor update and we need to re-sync our public mirrors for Centos 5. Thanks for your feedback!

    Best Regards,
    Andrey
     
  4. KristianM

    KristianM Regular Pleskian

    22
    40%
    Joined:
    Jul 17, 2011
    Messages:
    227
    Likes Received:
    10
    Location:
    Augsburg, Germany
    Hi,

    will this happen anytime in the near future?
    I guess this issue is breaking our PPA installation, so that we can't install any licenses.

    Regards,
    Kristian
     
  5. Andrey Dobrenko

    Andrey Dobrenko Regular Pleskian

    26
     
    Joined:
    Jun 26, 2007
    Messages:
    256
    Likes Received:
    0
    Hi KristianM,

    Plesk uses own package resolver on Centos/Redhat 5. When OS vendor releases any update, we sync our repositories and as a rule, we do it immediately because Plesk has a lot of installations and Centos is popular. The same will be for PPA. Moreover, it doesn't require any upgrade procedure. The issue about Licensing is not related to installation packages. I've asked to send me logs but i didn't recieve it from you.

    Thanks!

    P.S. For Centos 6.0 and later, YUM is used by default to install Plesk packages.

    Best Regards,
    Andrey
     
  6. KristianM

    KristianM Regular Pleskian

    22
    40%
    Joined:
    Jul 17, 2011
    Messages:
    227
    Likes Received:
    10
    Location:
    Augsburg, Germany
    Hi,

    well the issue still persistend yesterday.
    Install failed because of bind-libs/bind.

    Logs were sent yesterday to ppa@parallels.com at 13.08.2012 18:02 CEST.

    Regards,
    Kristian
     
  7. KristianM

    KristianM Regular Pleskian

    22
    40%
    Joined:
    Jul 17, 2011
    Messages:
    227
    Likes Received:
    10
    Location:
    Augsburg, Germany
    Hi,

    just as a note, as I can see people uploading logs to the forums.
    The Logs contain the password one uses in clear-text. I'm not sure if it is desirable to actually have people uploading the log files having their admin password shown in clear-text. This is why I asked where to send the log files to and I actually removed the cleartext-password from all log files.

    Regards,
    Kristian
     
  8. Andrey Dobrenko

    Andrey Dobrenko Regular Pleskian

    26
     
    Joined:
    Jun 26, 2007
    Messages:
    256
    Likes Received:
    0
    Kristian,

    Thanks for your feedback! I checked log files. Just one question: Did you log to Panel after installation? Could you please give me access to server to investigate and figure out the reason of problem.

    Best Regards,
    Andrey
     
  9. KristianM

    KristianM Regular Pleskian

    22
    40%
    Joined:
    Jul 17, 2011
    Messages:
    227
    Likes Received:
    10
    Location:
    Augsburg, Germany
    Hi,

    I've just sent the creditals via PM.
    Yes I did login and when going to License Manager I am unable to install the Lic.

    Regards,
    Kristian
     
  10. Andrey Dobrenko

    Andrey Dobrenko Regular Pleskian

    26
     
    Joined:
    Jun 26, 2007
    Messages:
    256
    Likes Received:
    0
    Hi KristianM,

    The reason of problem is that you changed system time zone but didn't restart mysql server. In this case, we have

    1) System time
    # date
    Wed Aug 15 01:30:04 PDT 2012

    2) MySQL timezone
    # mysql -u admin -p`cat /etc/psa/.psa.shadow` psa -e "SELECT NOW()"
    +---------------------+
    | NOW() |
    +---------------------+
    | 2012-08-15 10:30:00 |
    +---------------------+

    As you can see, there is a difference in three hours. So, after restarting mysql server and re-run instalaltion, the problem is fixed. Please check!

    Best Regards,
    Andrey
     
  11. KristianM

    KristianM Regular Pleskian

    22
    40%
    Joined:
    Jul 17, 2011
    Messages:
    227
    Likes Received:
    10
    Location:
    Augsburg, Germany
    Hi,

    thanks, so far everything is working. :)

    Can you actually tell me where to find information about the Public API?
    I can't find any documentation?

    Regards
    Kristian
     
  12. KristianM

    KristianM Regular Pleskian

    22
    40%
    Joined:
    Jul 17, 2011
    Messages:
    227
    Likes Received:
    10
    Location:
    Augsburg, Germany
    Hi,

    as I was on the road the past couple of days I only got to testing PPA today
    and I'm facing more license issues?

    While creating a reseller or Client I get:
    "Error There is no active license for Parallels Operations Automation installed."

    Within the License Manger I get shown that the License is valid?

    Any more hints?

    Regards
    Kristian
     
  13. Andrey Dobrenko

    Andrey Dobrenko Regular Pleskian

    26
     
    Joined:
    Jun 26, 2007
    Messages:
    256
    Likes Received:
    0
    Hi KristianM,

    I've re-installed license key to PPA that we sent you before and NOW i could create accounts. Did you get any errors during installation of the main license key? Maybe you can provide exact steps to reproduce this issue. Thanks!

    Best Regards,
    Andrey
     
  14. KristianM

    KristianM Regular Pleskian

    22
    40%
    Joined:
    Jul 17, 2011
    Messages:
    227
    Likes Received:
    10
    Location:
    Augsburg, Germany
    Hey Andrey,

    I did not receive any errors.
    All I did is to extract the Licenses provided on my local client.
    Then I installed the PPA License as the "Main-License" and added a couple of the PSA Licenses as "additional License".

    Regards,
    Kristian
     
  15. scottlpool2003

    scottlpool2003 Basic Pleskian

    12
    35%
    Joined:
    Aug 7, 2012
    Messages:
    29
    Likes Received:
    0
    I seem to be having the same problem and have checked the system time which appears to be correct.

    I've tried yum update:
    No Packages marked for Update

    Checked I have the latest version of CentOS:
    [root@server77-68-58-218 ~]# cat /etc/issue
    CentOS release 5.8 (Final)
    Kernel \r on an \m


    This is the error output:

    ERROR: Unable to install the "plesk-core-11.0.9-cos5.build110120608.16.x86_64" package.

    The following could cause the installation failure:
    1) plesk-core-11.0.9-cos5.build110120608.16.x86_64: No suitable solutions were found
    for the "bind-utils" dependency.

    2) bind-utils-30:9.3.6-20.P1.el5_8.1.x86_64: No suitable solutions were found
    for the "bind-libs = 30:9.3.6-20.P1.el5_8.1" dependency.

    3) Unable to downgrade 'bind-libs' package to version 30:9.3.6-20.P1.el5_8.1:
    version 30:9.3.6-20.P1.el5_8.2 is currently installed.

    There were also other problems encountered. For details,
    refer to the log file: /tmp/autoinstaller3.log.


    Log file:


    [root@server77-68-58-218 ~]# /tmp/autoinstaller3.log
    /tmp/autoinstaller3.log: line 1: Environment: command not found
    /tmp/autoinstaller3.log: line 2: Warning:: command not found
    /tmp/autoinstaller3.log: line 2: is: command not found
    /tmp/autoinstaller3.log: line 3: Supported: command not found
    /tmp/autoinstaller3.log: line 6: syntax error near unexpected token `('
    /tmp/autoinstaller3.log: line 6: `Parallels Products Installer 3.6.0 (built on 2010-04-07 15:06 svn rev. 290701) started at (timezone GMT) Wed Aug 8 12:06:01 2012'
     
  16. Andrey Dobrenko

    Andrey Dobrenko Regular Pleskian

    26
     
    Joined:
    Jun 26, 2007
    Messages:
    256
    Likes Received:
    0
    Guys,

    Synchronization of packages is scheduled on Aug 24. Moreover, we are going to release update for Public Preview soon and this problem will be fixed automatically.

    To fix problem, you need to remove bind-libs and bind9 manually, then, run installation again.

    Best Regards,
    Andrey
     
    Last edited: Aug 23, 2012
Thread Status:
Not open for further replies.
Loading...