1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

ERROR: Upgrade Plesk 7.1.6 to Plesk 7.5.1

Discussion in 'Plesk for Linux - 8.x and Older' started by waa2k, Jan 2, 2005.

  1. waa2k

    waa2k Guest

    0
     
    It had Plesk 7.1.6 and it executes the autoinstalador of plesk via the Control Panel to update to the 7.5.1 and it did not work:

    It leaves east error in my panel:
    Unable to create Session object: Unable to set up default locale: default locale does not exist or undefined. 0: /usr/local/psa/admin/auto_prepend/auth.php3:2 psaerror(string "Unable to create Session object: Unable to set up default locale: default locale does not exist or undefined.")

    I have tried to install according to the recommendations but I have not been successful, please I am thankful that they can review the error that leaves to me. next I copy the taken actions and log (he is urgent please) thanks.

    lower the installer who happened to me as Link and soon executes

    #./psa_installer_v2.0.0_build75041129.17_os_RedHat_el3_i686

    Autoinstaller exited.

    You can refer to file
    /tmp/psa_installer_v2.0.0_build75041129.17_os_RedHat_el3_i686.log
    where autoinstaller has logged its actions.


    #tail -n100 /tmp/psa_installer_v2.0.0_build75041129.17_os_RedHat_el3_i686.log

    Retrieving Plesk files
    ---

    Preparing for packages installation...
    ----- begin of output -----
    Installing /PSA_7.5.1/rpm_RedHat_el3/base/psa-api-common-7.5.1-rhel3.build75041216.14.i586.rpm
    Installing /PSA_7.5.1/rpm_RedHat_el3/base/psa-api-cli-7.5.1-rhel3.build75041216.14.i586.rpm
    Installing /PSA_7.5.1/rpm_RedHat_el3/opt/api/psa-api-rpc-1.3.2-3.1.i586.rpm
    Installing /PSA_7.5.1/rpm_RedHat_el3/opt/api/psa-agent-1.3.2-3.1.i586.rpm
    file /usr/local/psa/bin/anonftp.sh from install of psa-api-cli-7.5.1-rhel3.build75041216.14 conflicts with file from package psa-7.1.6-rhel3.build71041118.17
    file /usr/local/psa/bin/certificate.sh from install of psa-api-cli-7.5.1-rhel3.build75041216.14 conflicts with file from package psa-7.1.6-rhel3.build71041118.17
    file /usr/local/psa/bin/cfsetting.sh from install of psa-api-cli-7.5.1-rhel3.build75041216.14 conflicts with file from package psa-7.1.6-rhel3.build71041118.17
    file /usr/local/psa/bin/client.sh from install of psa-api-cli-7.5.1-rhel3.build75041216.14 conflicts with file from package psa-7.1.6-rhel3.build71041118.17
    file /usr/local/psa/bin/client_pref.sh from install of psa-api-cli-7.5.1-rhel3.build75041216.14 conflicts with file from package psa-7.1.6-rhel3.build71041118.17
    file /usr/local/psa/bin/cu_plesk_component.sh from install of psa-api-cli-7.5.1-rhel3.build75041216.14 conflicts with file from package psa-7.1.6-rhel3.build71041118.17
    file /usr/local/psa/bin/cu_plesk_get_menu.sh from install of psa-api-cli-7.5.1-rhel3.build75041216.14 conflicts with file from package psa-7.1.6-rhel3.build71041118.17
    file /usr/local/psa/bin/database.sh from install of psa-api-cli-7.5.1-rhel3.build75041216.14 conflicts with file from package psa-7.1.6-rhel3.build71041118.17
    file /usr/local/psa/bin/dns.sh from install of psa-api-cli-7.5.1-rhel3.build75041216.14 conflicts with file from package psa-7.1.6-rhel3.build71041118.17
    file /usr/local/psa/bin/domain.sh from install of psa-api-cli-7.5.1-rhel3.build75041216.14 conflicts with file from package psa-7.1.6-rhel3.build71041118.17
    file /usr/local/psa/bin/domain_pref.sh from install of psa-api-cli-7.5.1-rhel3.build75041216.14 conflicts with file from package psa-7.1.6-rhel3.build71041118.17
    file /usr/local/psa/bin/init_conf.sh from install of psa-api-cli-7.5.1-rhel3.build75041216.14 conflicts with file from package psa-7.1.6-rhel3.build71041118.17
    file /usr/local/psa/bin/ipmanage.sh from install of psa-api-cli-7.5.1-rhel3.build75041216.14 conflicts with file from package psa-7.1.6-rhel3.build71041118.17
    file /usr/local/psa/bin/mail.sh from install of psa-api-cli-7.5.1-rhel3.build75041216.14 conflicts with file from package psa-7.1.6-rhel3.build71041118.17
    file /usr/local/psa/bin/maillist.sh from install of psa-api-cli-7.5.1-rhel3.build75041216.14 conflicts with file from package psa-7.1.6-rhel3.build71041118.17
    file /usr/local/psa/bin/protdir.sh from install of psa-api-cli-7.5.1-rhel3.build75041216.14 conflicts with file from package psa-7.1.6-rhel3.build71041118.17
    file /usr/local/psa/bin/server_pref.sh from install of psa-api-cli-7.5.1-rhel3.build75041216.14 conflicts with file from package psa-7.1.6-rhel3.build71041118.17
    file /usr/local/psa/bin/spamassassin.sh from install of psa-api-cli-7.5.1-rhel3.build75041216.14 conflicts with file from package psa-7.1.6-rhel3.build71041118.17
    file /usr/local/psa/bin/subdomain.sh from install of psa-api-cli-7.5.1-rhel3.build75041216.14 conflicts with file from package psa-7.1.6-rhel3.build71041118.17
    file /usr/local/psa/bin/traffic.sh from install of psa-api-cli-7.5.1-rhel3.build75041216.14 conflicts with file from package psa-7.1.6-rhel3.build71041118.17
    file /usr/local/psa/bin/webuser.sh from install of psa-api-cli-7.5.1-rhel3.build75041216.14 conflicts with file from package psa-7.1.6-rhel3.build71041118.17

    ----- end of output -----
    packages failed to install: Not all required packages were installed.
    ===> Autoinstaller: stopped logging


    After that it tries to install by means of the RPM's

    # rpm -Uvh *
    error: Failed dependencies:
    psa < 7.2.0 is needed by (installed) psa-agent-1.3.2-2_psa7.1
    psa = 7.1.6 is needed by (installed) psa-bu-7.1.6-rhel3.build71041118.17

    # rpm -Uvh psa-7.5.1-rhel3.build75041216.14.i586.rpm
    error: Failed dependencies:
    psa-api-cli >= 7.5.1 is needed by psa-7.5.1-rhel3.build75041216.14
    psa-api-common >= 7.5.1 is needed by psa-7.5.1-rhel3.build75041216.14
    psa < 7.2.0 is needed by (installed) psa-agent-1.3.2-2_psa7.1
    psa = 7.1.6 is needed by (installed) psa-bu-7.1.6-rhel3.build71041118.17

    Also it tries stopping psa:
    # /etc/rc.d/init.d/psa stopall

    And profit not to even solve (the panel this with error and I cannot even migrate of version of the Plesk), I hope that somebody already has had this experience and can help me, thanks.


    Atte.

    Willy Acuña A.
    willy@yarkan.com.pe
    Móvil (511)+ 97923512
    Telf. (511)+ 381-8565
    Lima 25, Lima - Perú
     
  2. Bobby

    Bobby Guest

    0
     
    Hi,

    looks like those *api* (Plesk Agent) rpms are your showblocker.

    Try and install these packages manually:

    Code:
    rpm -Uhv --force --nodeps /PSA_7.5.1/rpm_RedHat_el3/base/psa-api-common-7.5.1-rhel3.build75041216.14.i586.rpm
    rpm -Uhv --force --nodeps /PSA_7.5.1/rpm_RedHat_el3/base/psa-api-cli-7.5.1-rhel3.build75041216.14.i586.rpm
    rpm -Uhv --force --nodeps /PSA_7.5.1/rpm_RedHat_el3/opt/api/psa-api-rpc-1.3.2-3.1.i586.rpm
    rpm -Uhv --force --nodeps /PSA_7.5.1/rpm_RedHat_el3/opt/api/psa-agent-1.3.2-3.1.i586.rpm
    Then try autoupdater again.

    Regards,

    Bobby
     
  3. waa2k

    waa2k Guest

    0
     
    Friends, already I managed to install via SSH the Plesk 7,5,1 thanks to Bobby.

    ...

    Installing /PSA_7.5.1/rpm_RedHat_el3/opt/migration/psa-migration-manager-7.5.1-r
    hel3.build75041216.14.i586.rpm

    ----- end of output -----

    packages installed successfully.

    ===> Autoinstaller: stopped logging at Mon Jan 3 13:58:44 2005

    Soon it executes to see the installed thing:

    [root@keey root]# rpm -qa | grep psa
    psacct-6.3.2-27
    drweb-4.32.2-rh2_psa
    psa-key-7.1-rhel3.build71041118.17
    psa-locale-base-en-US-7.5.1-rhel3.build75041216.14
    psa-courier-imap-add-7.5.1-rhel3.build75041216.14
    psa-api-common-7.5.1-rhel3.build75041216.14
    psa-proftpd-1.2.10-rhel3.build75041216.14
    perl-HTML-Tree-3.16-60psa
    psa-spamassassin-7.5.1-rhel3.build75041216.14
    psa-api-rpc-protocol-1.3.2-3.1
    psa-locale-base-en-7.1.6-rhel3.build71041118.17
    psa-7.1.6-rhel3.build71041118.17
    psa-pre-keyupdate-7.5.1-rhel3.build75041216.14
    psa-key-7.5-rhel3.build75041216.14
    psa-qmail-1.03-rhel3.build75041216.14
    psa-proftpd-xinetd-1.2.10-rhel3.build75041216.14
    psa-api-cli-7.5.1-rhel3.build75041216.14
    psa-agent-1.3.2-3.1
    psa-7.5.1-rhel3.build75041216.14
    mod_webapp-4.1.29-40psa.rhel3
    frontpage-5.0-70psa.rhel3
    perl-Font-AFM-1.18-60psa
    perl-HTML-Format-1.23-50psa
    perl-MLDBM-2.01-60psa
    psa-bu-7.5.1-rhel3.build75041216.14
    psa-api-rpc-doc-1.3.2-3.1
    psa-logrotate-3.7-rhel3.build75041216.14
    psa-api-rpc-1.3.2-3.1
    psa-tomcat-configurator-7.5.1-rhel3.build75041216.14
    perl-FreezeThaw-0.43-60psa
    perl-MLDBM-Sync-0.30-60psa
    psa-qmail-rblsmtpd-0.70-rhel3.build75041216.14
    psa-migration-manager-7.5.1-rhel3.build75041216.14

    and he appears psa in two versions: this good? or I must remove the old one
    - psa-7.1.6-rhel3.build71041118.17
    - psa-7.5.1-rhel3.build75041216.14

    - psa-key-7.1-rhel3.build71041118.17
    - psa-key-7.5-rhel3.build75041216.14

    And it leaves the following error when I enter the panel https://mi_dominio_ejemplo:8443/

    Unable to create Session object: Unable to set up default locale: default locale does not exist or undefined. 0: /usr/local/psa/admin/auto_prepend/auth.php3:2 psaerror(string "Unable to create Session object: Unable to set up default locale: default locale does not exist or undefined.")


    It seems that already I settle, single that the PSA does not let to me enter the panel by the error that leaves to me; I must do something more? I have not installed any new key of the Plesk, in the Web of Plesk mentioned that he was automatic, I hope not to be mistaken, I wait for its contributions again, I hope to solve to urgent east problem, thanks.

    PS: it would please to know me if to him step somewhat similar to somebody and that she did?

    Warm greetings,

    Atte.

    Willy Acuña A.
    willy@yarkan.com.pe
    Móvil (511)+ 97923512
    Telf. (511)+ 381-8565
    Lima 25, Lima - Perú
     
  4. Bobby

    Bobby Guest

    0
     
    Hi,

    I would recommend the following:

    Code:
    rpm -e psa-7.1.6-rhel3.build71041118.17
    rpm -e psa-key-7.1-rhel3.build71041118.17
    And then ...

    Code:
    rpm -Uhv --force /PSA_7.5.1/rpm_RedHat_el3/base/*.rpm
    Regards,

    Bobby
     
  5. waa2k

    waa2k Guest

    0
     
    Bobby thanks for your suggestions have served much to me, already all this working.

    Saludos cordiales,

    Atte.

    Willy Acuña A.
    willy@yarkan.com.pe
    Móvil (511)+ 97923512
    Telf. (511)+ 381-8565
    Lima 25, Lima - Perú
     
  6. Gabor

    Gabor Guest

    0
     
    When you do this will it remove the complete psa database?

    I mean i have a productive server (90 domains) and have the same problem. I am afraid that if i do this i will break the psa server and all my domains and clients will be gone.

    Could you tell me if you have done this on a productive server?

    thanks for your reply
     
  7. Cranky

    Cranky Guest

    0
     
    Make a backup of the database just in case ... it shouldn't cause any harm to the database but a backup takes seconds to make.
     
  8. waa2k

    waa2k Guest

    0
     
    Hello.

    If he is a server in production with 11 dominions and everything has happened with total normality.

    Saludos cordiales,

    Atte.

    Willy Acuña A.
    willy@yarkan.com.pe
    Móvil (511)+ 97923512
    Telf. (511)+ 381-8565
    Lima 25, Lima - Perú
     
  9. Gabor

    Gabor Guest

    0
     
    Thanks for you reply,

    But now when i do this i get this error

    10:psa-logrotate ########################################### [ 67%]
    11:eek:sCommerce ########################################### [ 73%]
    12:Mambo ########################################### [ 80%]
    13:psa-api-common ########################################### [ 87%]
    ===> Reading /etc/tomcat4/tomcat4.conf ...
    ===> Updating /etc/psa/psa.conf...

    Trying to define super-server internet daemon type... xinetd
    Trying to check if xinetd daemon is running... done
    ===> Reading /etc/psa/psa.conf ...

    Trying to stop MySQL server... done
    Making some checks before upgrading

    Now BIND server shutting down...

    Trying to stop BIND server... done
    Trying to start BIND server... done

    BIND server starts Ok.

    Trying to start MySQL server... done
    Trying to establish test connection... connected
    Trying to stop MySQL server... done
    VERSION MISMATCH:
    PLESK DATABASE VERSION: 075
    PLESK INSTALLATION VERSION: 071

    ERROR while trying to check version match
    Check the error reason(see log file: /tmp/psa_7.5.1_FedoraCore_2_build75041216.15_upgrade.log), fix and try again

    Aborting...

    error: %pre(psa-7.5.1-fc2.build75041216.15) scriptlet failed, exit status 1
    error: install: %pre scriptlet failed (2), skipping psa-7.5.1-fc2.build75041216.15

    14:psa-api-cli ########################################### [ 93%]

    everything else is okay... but still the same problem as noticed above.
     
  10. jvanv8

    jvanv8 Guest

    0
     
    I have the same mismatching database problem... did you solve it? I was acutally trying to get 8.0.0
    My output:
    Code:
    Get Plesk product packages.
    Get system update packages.
    Start packages installation
    Install package psa
     Trying to define super-server internet daemon type... xinetd
     Trying to check if xinetd daemon is running... done
    
     Trying to stop MySQL server... done
     Trying to start MySQL server... done
     Trying to establish test connection... connected
     Making some checks before upgrading
    
     Now BIND server shutting down...
    
     Trying to stop BIND server... done
     Trying to start BIND server... done
    
     BIND server starts Ok.
    
    VERSION MISMATCH:
    PLESK DATABASE VERSION: 075
    PLESK INSTALLATION VERSION: 071
    
    ERROR while trying to check version match
    Check the error reason(see log file: /tmp/psa_8.0.0_RedHat_el3_build80060331.13_upgrade.log), fix and try again
    
    Aborting...
    
    error: %pre(psa-8.0.0-rhel3.build80060331.13) scriptlet failed, exit status 1
    error:   install: %pre scriptlet failed (2), skipping psa-8.0.0-rhel3.build80060331.13
    Error while execute command rpm -U /root/psa/PSA_8.0.0/dist-rpm-RedHat-el3-i386/base/psa-8.0.0-rhel3.build80060331.13.i586.rpm 
    ERROR: error while executing RPM
    ERROR: Installation failed
    
     
Loading...