1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

error upgrading plesk 8.0 fc2

Discussion in 'Plesk for Linux - 8.x and Older' started by webjfg, Mar 29, 2006.

  1. webjfg

    webjfg Basic Pleskian

    24
    40%
    Joined:
    Jun 8, 2005
    Messages:
    39
    Likes Received:
    0
    i receive this error when i try to update to 8.0

    Start packages installation
    Install package psa-agent, psa, psa-api-rpc, psa-locale-base-en-US, psa-api, psa-autoinstaller, psa-libpam-plesk, psa-migration-manager, cs-gs, psa-manual-custom-skin-guide, psa-backup-manager, psa-watchdog, psa-firewall, psa-spamassassin
    error: Failed dependencies:
    spamassassin >= 3.0.0 is needed by psa-spamassassin-8.0.0-fc2.build80060329.02
    perl(Mail::SpamAssassin) is needed by psa-spamassassin-8.0.0-fc2.build80060329.02
    perl(Mail::SpamAssassin::ArchiveIterator) is needed by psa-spamassassin-8.0.0-fc2.build80060329.02
    perl(Mail::SpamAssassin::Message) is needed by psa-spamassassin-8.0.0-fc2.build80060329.02
    perl(Mail::SpamAssassin::perMsgLearner) is needed by psa-spamassassin-8.0.0-fc2.build80060329.02
    Error while execute command rpm -U /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/opt/api/psa-agent-1.4.0-80060329.02.noarch.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/base/psa-8.0.0-fc2.build80060329.02.i586.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/opt/api/psa-api-rpc-8.0.0-fc2.build80060329.11.noarch.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/base/psa-locale-base-en-US-8.0.0-fc2.build80060329.02.noarch.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/base/psa-api-8.0.0-fc2.build80060329.11.noarch.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/opt/updater/psa-autoinstaller-3.0.1-build060327.18.i586.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/base/psa-libpam-plesk-8.0.0-fc2.build80060329.02.i586.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/opt/migration/psa-migration-manager-8.0.0-fc2.build80060329.11.i586.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/opt/modules/csgs/cs-gs-2.0.0-fc2.build80060329.02.i586.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/opt/docs/psa-manual-custom-skin-guide-8.0.0-fc2.build80060329.02.noarch.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/opt/backup/psa-backup-manager-8.0.0-fc2.build80060329.11.i586.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/opt/modules/watchdog/psa-watchdog-2.0.0-fc2.build80060329.02.i586.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/opt/modules/firewall/psa-firewall-1.0.1-fc2.build80060329.02.i586.rpm /root/psa/PSA_8.0.0/dist-rpm-FedoraCore-2-i386/opt/mail/psa-spamassassin-8.0.0-fc2.build80060329.02.i586.rpm
    ERROR: error while executing RPM
    ERROR: Installation failed

    upgrade from 7.5.4, fedora core 2
     
  2. webjfg

    webjfg Basic Pleskian

    24
    40%
    Joined:
    Jun 8, 2005
    Messages:
    39
    Likes Received:
    0
    i have finaly upgrade succesfuly!!
    i have uninstall spamassassin and psa-spamassassin, re-install it with the auto updater for 7.5.4, re do the upgrade to 8.0 and it work!!!

    JF
     
  3. nunor

    nunor Guest

    0
     
    I`m receiving exactly the same error on FC2. Can you please explain how to uninstall spamassassin and psa-spamassassin?

    Thanks
     
  4. webjfg

    webjfg Basic Pleskian

    24
    40%
    Joined:
    Jun 8, 2005
    Messages:
    39
    Likes Received:
    0
    log as root
    rpm -e spamassissin
    rpm -e psa-spamassassin

    after that log to your control panel, du update on plesk 7.5.4 and re-install the spamassassin support


    webjfg
     
  5. Forza

    Forza Guest

    0
     
    when uninstalling the spamassassin i get this error:

    Code:
    [root@u15198692 root]# rpm -e spamassassin
    error: Failed dependencies:
            perl(Mail::SpamAssassin) is needed by (installed) psa-spamassassin-7.5.4-fc2.build75060118.18
            perl(Mail::SpamAssassin::ArchiveIterator) is needed by (installed) psa-spamassassin-7.5.4-fc2.build75060118.18
            perl(Mail::SpamAssassin::Message) is needed by (installed) psa-spamassassin-7.5.4-fc2.build75060118.18
            perl(Mail::SpamAssassin::PerMsgLearner) is needed by (installed) psa-spamassassin-7.5.4-fc2.build75060118.18
            spamassassin >= 2.60 is needed by (installed) psa-spamassassin-7.5.4-fc2.build75060118.18
    
    any idea on what to do?
     
  6. troymc

    troymc Guest

    0
     
    You need to remove psa-spamassassin at the same time or remove it first
     
  7. Forza

    Forza Guest

    0
     
    thanks that worked.

    however, the 8.0 updater still dont do anything. and the email doesnt work either.

    I tried the 7.5. spamassassin reinstall which works but i didnt get the status report (to a gmail account) so the email serivce on the server is still down. After doing that i try updating thr 8.0 but nothing happens.

    removed spamassassin again and then update to 8.0 also don't work.

    any suggestions?
     
  8. omegauser

    omegauser Guest

    0
     
    I have the same problem.........
     
  9. troymc

    troymc Guest

    0
     
    Have you tried to upgrade through the shell instead of the Plesk admin? Run the autoinstaller using
    /usr/local/psa/admin/sbin/autoinstaller
    It will guide you through the update. I have the same problem of the Plesk admin updater hanging on my test box. Luckily my live box doesn't have this issue. It you can't update through the shell using the autoinstaller, you may have to manually do the upgrade by downloading the rpms and installing them yourself.
     
  10. omegauser

    omegauser Guest

    0
     
    Hi, my email does not work..........I just dont know what to uninstal or install
     
  11. troymc

    troymc Guest

    0
     
    I'm not sure what you mean. If you use the shell autoinstaller you won't get any emails. It will just guide you through the update. You will choose what updates to install during the update. Are you are still running 7.5.4 and trying to upgrade to 8.0?
     
  12. omegauser

    omegauser Guest

    0
     
    Yes, When I tried to do the upgrade to 8.0 my email went down, many people is facing this issue,
     
  13. troymc

    troymc Guest

    0
     
    Is this on a live box? Your email is completely down? Have you tried to install using the rpms?
     
  14. omegauser

    omegauser Guest

    0
     
    Is a complete LIVE box, I am frustated, dont know what to do.... I havent tried to run the autoinstall in the command line, I dont want to reinstal plesk or something by mistake and loose all the data.

    Any suggestions?
     
  15. troymc

    troymc Guest

    0
     
    The command line autoinstaller is what the Plesk admin autoinstaller uses to update. It will update just the same. If you want to get your email working again you can probably just reinstall the 7.5.4 psa-qmail rpm. Do you have some sort of backup? If so just do a backup and then run the autoinstaller.
     
  16. omegauser

    omegauser Guest

    0
     
    Do you have the exact command line for reinstall psa 7.5.4??? Do I really need a backup? something will be deleted? emails?

    I just want to be sure, If a really need a backup, could you please tell me where is all the data or the mailnames and webmail so I can downloadit.

    I really appreciate your help, I desperate here,,,,,
     
  17. troymc

    troymc Guest

    0
     
    When you login to the Plesk admin does it tell you that it is 7.5.4 or 8.0? I was just asking about the backup because you can never be too safe. It is ALWAYS a good idea to have a backup before upgrading or doing any kind of changing to the system. In your /root directory there should be a directory psa and in that there should be PSA_7.5.4. That is where all the rpms will be. You need to see what your system is running before doing anything though. What does "rpm -qa | grep psa" give you?
     
  18. troymc

    troymc Guest

    0
     
    Also, what happens when you do a "service qmail restart" from the command line?
     
  19. omegauser

    omegauser Guest

    0
     
    I think all my errors are here>

    Command> telnet localhost 25
    Trying 127.0.0.1...
    Connected to localhost.
    Escape character is '^]'.
    relaylock: Error: HTTPD_INCLUDE_D not defined
    relaylock: Error: HTTPD_INCLUDE_D not defined
    Connection closed by foreign host.

    Any ideas?
     
  20. troymc

    troymc Guest

    0
     
    ?? Do you have direct access to the machine? If so you don't need to telnet to anything. If you are remote you should use ssh instead of telnet. Are you logging in directly to the machine running plesk?
     
Loading...