1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

ERROR UPGRADING Plesk 8.1.0 to 8.1.1

Discussion in 'Plesk for Linux - 8.x and Older' started by Maxcielle, Jul 6, 2007.

  1. Maxcielle

    Maxcielle Guest

    0
     
    AutoInstallerManager::show_packages() failed: AutoInstallerManager::_autoInstallerCall() failed: autoinstaller failed: Empty error message from utility.

    0: /usr/local/psa/admin/plib/common_func.php3:155
    psaerror(string 'AutoInstallerManager::show_packages() failed: AutoInstallerManager::_autoInstallerCall() failed: autoinstaller failed: Empty error message from utility.')
    1: /usr/local/psa/admin/htdocs/server/autoinstaller_install.php:50
     
  2. Guizmo

    Guizmo Guest

    0
     
    I also have an ERROR for UPGRADING Plesk 8.1.0 to 8.1.1 but for a different reason :

    /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/base/psa-api-8.0.1-fc4.
    build80061205.15.noarch.rpm
    > ERROR: error while executing RPM

    If more information is needed, here is the complete log :

    > Download file versions.inf3: 100% done
    > Download file PSA_8.0.1/plesk-8.0.1-fc4-x86_64.inf3: 88%..100% done
    > Checking for system installed packages...done.
    > Check for components installation status
    > Reading system installed packages...done.
    > Download file build-8.0.1-fc4-x86_64.hdr.gz:
    11%..25%..32%..40%..54%..61%..75%..82%..90%..100% done
    > Download file update-8.0.1-fc4-x86_64.hdr.gz: 35%..75%..100% done
    > Resolve components
    > There are some also needed components will installed too:
    'psa-autoinstaller'
    > Get Plesk product packages.
    > Download file base/psa-api-8.0.1-fc4.build80061205.15.noarch.rpm:
    38%..94%..100% done
    > Download file base/psa-hotfix9-8.0.1-fc4.build80061203.19.x86_64.rpm:
    83%..100% done
    > Download file base/psa-proftpd-1.3.0-fc4.build80061203.19.x86_64.rpm:
    22%..81%..100% done
    > Download file
    opt/java/psa-tomcat-configurator-8.0.1-fc4.build80060615.20.noarch.rpm:
    53%..100% done
    > Download file
    opt/mail/perl-Text-Iconv-1.2-24psa.fc4.build80060613.20.noarch.rpm: 100%
    done
    > Download file
    opt/mail/psa-spamassassin-8.0.1-fc4.build80060613.20.x86_64.rpm:
    10%..100% done
    > Download file
    opt/backup/psa-backup-manager-8.0.1-fc4.build80061205.15.x86_64.rpm:
    57%..100% done
    > Download file
    opt/api/psa-api-rpc-8.0.1-fc4.build80061205.15.noarch.rpm: 38%..100%
    done
    > Download file
    opt/migration/psa-migration-manager-8.0.1-fc4.build80061205.15.x86_64.rp
    m: 16%..40%..69%..100% done
    > Get system update packages.
    > Download file tomcat5-5.0.30-8jpp.noarch.rpm: 15%..49%..90%..100%
    done
    > Download file tomcat5-admin-webapps-5.0.30-8jpp.noarch.rpm:
    13%..62%..100% done
    > Download file tomcat5-webapps-5.0.30-8jpp.noarch.rpm:
    18%..42%..67%..90%..100% done
    > Download file mod_jk-1.2.6-3jpp_4fc.x86_64.rpm: 100% done
    > Download file spamassassin-3.0.6-1.fc4.x86_64.rpm: 18%..86%..100%
    done
    > Download file ant-1.6.2-3jpp_8fc.x86_64.rpm: 28%..55%..86%..100% done
    > Download file jakarta-commons-beanutils-1.7.0-2jpp.noarch.rpm:
    17%..100% done
    > Download file jakarta-commons-collections-3.1-2jpp.noarch.rpm: 100%
    done
    > Download file jakarta-commons-dbcp-1.2.1-3jpp_1fc.noarch.rpm: 100%
    done
    > Download file jakarta-commons-digester-1.7-1jpp.noarch.rpm: 17%..100%
    done
    > Download file jakarta-commons-el-1.0-4jpp.noarch.rpm: 54%..100% done
    > Download file jakarta-commons-fileupload-1.0-3jpp_1fc.noarch.rpm: 100%
    done
    > Download file jakarta-commons-launcher-0.9-3jpp_1fc.noarch.rpm: 100%
    done
    > Download file jakarta-commons-logging-1.0.4-2jpp_4fc.x86_64.rpm: 100%
    done
    > Download file jakarta-commons-modeler-1.1-4jpp.noarch.rpm: 100% done
    > Download file jakarta-commons-pool-1.2-2jpp_1fc.noarch.rpm: 64%..100%
    done
    > Download file java-1.4.2-sun-1.4.2.07-1jpp.i586.rpm:
    11%..21%..32%..42%..53%..60%..70%..82%..93%..100% done
    > Download file jpackage-utils-1.6.3-1jpp_1rh.noarch.rpm: 100% done
    > Download file
    java-1.4.2-gcj-compat-1.4.2.0-40jpp_31rh.FC4.2.x86_64.rpm: 100% done
    > Download file mx4j-2.1.0-1jpp_7fc.x86_64.rpm: 11%..36%..67%..100%
    done
    > Download file puretls-0.9-0.b5.1jpp.noarch.rpm: 100% done
    > Download file regexp-1.3-2jpp.noarch.rpm: 14%..100% done
    > Download file tomcat5-jasper-5.0.30-8jpp.noarch.rpm: 46%..100% done
    > Download file tomcat5-servlet-2.4-api-5.0.30-8jpp.noarch.rpm:
    40%..100% done
    > Download file tyrex-1.0.1-3jpp.noarch.rpm: 83%..100% done
    > Download file xerces-j2-2.7.1-1jpp.noarch.rpm: 20%..79%..100% done
    > Download file xml-commons-apis-1.3.02-2jpp.noarch.rpm: 58%..100% done
    > Download file struts-1.2.7-2jpp.noarch.rpm: 39%..100% done
    > Download file jakarta-taglibs-standard-1.1.1-4jpp_1fc.noarch.rpm: 100%
    done
    > Download file xalan-j2-2.7.0-1jpp.noarch.rpm: 22%..52%..92%..100%
    done
    > Download file gjdoc-0.7.7-0.FC4.x86_64.rpm: 13%..51%..100% done
    > Download file gnu-crypto-2.0.1-1jpp_5fc.noarch.rpm:
    21%..42%..99%..100% done
    > Download file gnu-crypto-jce-jdk1.4-2.0.1-1jpp_5fc.noarch.rpm: 100%
    done
    > Download file gnu-crypto-sasl-jdk1.4-2.0.1-1jpp_5fc.noarch.rpm:
    13%..100% done
    > Download file jessie-1.0.0-8.noarch.rpm: 45%..100% done
    > Download file bcel-5.1-5jpp.noarch.rpm: 19%..100% done
    > Download file junit-3.8.1-3jpp_4fc.noarch.rpm: 100% done
    > Download file log4j-1.2.12-1jpp.noarch.rpm: 100% done
    > Download file xml-commons-1.3.02-2jpp.noarch.rpm: 100% done
    > Download file xml-commons-resolver-1.1-3jpp.noarch.rpm: 100% done
    > Download file cryptix-3.2.0-5jpp.noarch.rpm: 74%..100% done
    > Download file cryptix-asn1-20011119-5jpp.noarch.rpm: 93%..100% done
    > Download file jakarta-commons-validator-1.1.4-1jpp.noarch.rpm: 100%
    done
    > Download file oro-2.0.8-2jpp.noarch.rpm: 100% done
    > Download file java-1.4.2-sun-devel-1.4.2.07-1jpp.i586.rpm:
    18%..38%..57%..77%..95%..100% done
    > Download file javamail-1.3.2-1jpp.noarch.rpm: 48%..100% done
    > Download file jaf-1.0.2-4jpp.noarch.rpm: 100% done
    > Start packages installation
    > Install package psa-backup-manager, psa-api-rpc,
    psa-migration-manager, psa-api
    > Error while execute command rpm -U
    /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/opt/backup/psa-backup-m
    anager-8.0.1-fc4.build80061205.15.x86_64.rpm
    /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/opt/api/psa-api-rpc-8.0
    .1-fc4.build80061205.15.noarch.rpm
    /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/opt/migration/psa-migra
    tion-manager-8.0.1-fc4.build80061205.15.x86_64.rpm
    /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/base/psa-api-8.0.1-fc4.
    build80061205.15.noarch.rpm
    > ERROR: error while executing RPM
     
  3. grubber

    grubber Guest

    0
     
  4. Guizmo

    Guizmo Guest

    0
     
    Yep, 1&1 only deals with hardware issues, not software. When you have Plesk problems, they ask you to deal with Swsoft.

    Problem is Swsoft doesn't answer us... their forum is a good answer of their support quality...
     
  5. Server Surgeon

    Server Surgeon Guest

    0
     
    You should login to your server as root and run this command by hand:

    rpm -U
    /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/opt/backup/psa-backup-m
    anager-8.0.1-fc4.build80061205.15.x86_64.rpm
    /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/opt/api/psa-api-rpc-8.0
    .1-fc4.build80061205.15.noarch.rpm
    /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/opt/migration/psa-migra
    tion-manager-8.0.1-fc4.build80061205.15.x86_64.rpm
    /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/base/psa-api-8.0.1-fc4.
    build80061205.15.noarch.rpm

    make note of the output (it will include the error). Try to resolve on your own, if not, post the output from that command here and someone will probably state how to get beyond it. It's probably something very simple.


     
  6. Guizmo

    Guizmo Guest

    0
     
    Well, here it is :

    [root@s15236244 ~]# rpm -U
    /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/opt/backup/psa-backup-m
    anager-8.0.1-fc4.build80061205.15.x86_64.rpm
    /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/opt/api/psa-api-rpc-8.0
    .1-fc4.build80061205.15.noarch.rpm
    /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/opt/migration/psa-migra
    tion-manager-8.0.1-fc4.build80061205.15.x86_64.rpm
    rpm: no packages given for install
    [root@s15236244 ~]# /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/opt/backup/psa-backup-m
    -bash: /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/opt/backup/psa-backup-m: No such file or directory
    /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/base/psa-api-8.0.1-fc4.
    [root@s15236244 ~]# anager-8.0.1-fc4.build80061205.15.x86_64.rpm
    -bash: anager-8.0.1-fc4.build80061205.15.x86_64.rpm: command not found
    [root@s15236244 ~]# /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/opt/api/psa-api-rpc-8.0
    -bash: /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/opt/api/psa-api-rpc-8.0: No such file or directory
    [root@s15236244 ~]# .1-fc4.build80061205.15.noarch.rpm
    -bash: .1-fc4.build80061205.15.noarch.rpm: command not found
    [root@s15236244 ~]# /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/opt/migration/psa-migra
    -bash: /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/opt/migration/psa-migra: No such file or directory
    [root@s15236244 ~]# tion-manager-8.0.1-fc4.build80061205.15.x86_64.rpm
    -bash: tion-manager-8.0.1-fc4.build80061205.15.x86_64.rpm: command not found
    [root@s15236244 ~]# /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/base/psa-api-8.0.1-fc4.
    -bash: /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/base/psa-api-8.0.1-fc4.: No such file or directory
     
  7. Server Surgeon

    Server Surgeon Guest

    0
     
    That was supposed to be run as a one line command. Anyhow it looks like (even if it were run as a one line command) it would have failed because the Plesk installation files are missing.

    Did you remove these or instruct Plesk to remove them?
     
  8. Guizmo

    Guizmo Guest

    0
     
    Absolutly not, it's the Plesk as delivered by 1&1, brand new :) as i just susbscribed to their service.

    The only thing done is Plesk updater has been used for upgrading from 8.0 to 8.1.0
     
  9. Guizmo

    Guizmo Guest

    0
     
    in one line command :

    Last login: Wed Jul 11 10:04:57 2007 from nor75-14-81-57-126-165.fbx.proxad.net
    [root@s15236244 ~]# rpm -U /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/opt/backup/psa-backup-manager-8.0.1-fc4.build80061205.15.x86_64.rpm /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/opt/api/psa-api-rpc-8.0.1-fc4.build80061205.15.noarch.rpm /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/opt/migration/psa-migration-manager-8.0.1-fc4.build80061205.15.x86_64.rpm
    /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/base/psa-api-8.0.1-fc4.build80061205.15.noarch.rpmerror: Failed dependencies:
    psa = 8.0.1 is needed by psa-backup-manager-8.0.1-fc4.build80061205.15.x86_64
    psa = 8.0.1 is needed by psa-api-rpc-8.0.1-fc4.build80061205.15.noarch
    psa-api = 8.0.1-fc4.build80061205.15 is needed by psa-api-rpc-8.0.1-fc4.build80061205.15.noarch
    psa-api = 8.0.1-fc4.build80061205.15 is needed by psa-migration-manager-8.0.1-fc4.build80061205.15.x86_64
    psa = 8.0.1 is needed by psa-migration-manager-8.0.1-fc4.build80061205.15.x86_64
    psa-backup-manager = 8.1.0 is needed by (installed) psa-backup-manager-vz-8.1.0-fc4.build81061212.11.x86_64
    [root@s15236244 ~]# /root/psa/PSA_8.0.1/dist-rpm-FedoraCore-4-x86_64/base/psa-api-8.0.1-fc4.build80061205.15.noarch.rpm
     
Loading...