1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

error upload php

Discussion in 'Plesk for Linux - 8.x and Older' started by dfutura, Oct 11, 2005.

  1. dfutura

    dfutura Basic Pleskian

    23
    57%
    Joined:
    May 10, 2004
    Messages:
    30
    Likes Received:
    0
    I trying to upload a file with php. I f the file is 2 Mb it works, but if the exceed 2 Mb it donr work.

    I have change in /usr/local/psa/admin/conf/php.ini ->
    upload_max_filesize = 5147483647
    post_max_size = 5147483647

    and restart apache but nothing. Any suggestion?

    Regards.
     
  2. eWebtricity

    eWebtricity Guest

    0
     
    You might check the

    memory_limit = 8M ; Maximum amount of memory a script may consume (8MB)

    and my php.ini uses MB instead of bytes or kilobytes on the file size limits ie: instead of 5147483647 how about 5M

    you might also try specifying

    ; Temporary directory for HTTP uploaded files (will use system default if not
    ; specified).
    ;upload_tmp_dir =

    depending on what options you used to install PHP originally might be affecting your file uploads as well. Post a link to your phpinfo() or PM it.
     
  3. dfutura

    dfutura Basic Pleskian

    23
    57%
    Joined:
    May 10, 2004
    Messages:
    30
    Likes Received:
    0
    hi,

    I think am changing the php.ini that no correspond. I have put in php.ini upload_max_filesize 5M. But in phpinfo() is 2M.

    The php.ini I have changes is located here:
    /usr/local/psa/admin/conf

    This changes is only for a domain, what file i have to modify.
     
  4. dfutura

    dfutura Basic Pleskian

    23
    57%
    Joined:
    May 10, 2004
    Messages:
    30
    Likes Received:
    0
    I have change vhost.conf for this domin and it works:

    <Directory /home/httpd/vhosts/domain.com/httpdocs>
    php_admin_flag register_globals on
    php_admin_flag upload_max_filesize 5M
    </Directory>
     
Loading...