1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Error when switching to AtMail.

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by JamesBCollins, Jan 25, 2010.

  1. JamesBCollins

    JamesBCollins Guest

    0
     
    Hi all,

    I am getting an error when changing the default webmail client for a domain. All are currently set to Horde, but when i choose AtMail i get the error Error: Unable to update domain data: Failed setting of domain parameters: Cannot change Webmail on domain: webmail.

    Anybody know what this means? I have run all of the latest updates for plesk but it tells me i am still on AtMail 1.02.
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Well known problem. Look at this thread. Maybe it will help.
     
  3. JamesBCollins

    JamesBCollins Guest

    0
     
    I did look at that thread earlier and they said the fix is to run the updates and install latest version of Horde. Problem is i have all updates installed aparently (so plesk says) so not too sure how else i can update.
     
  4. JamesBCollins

    JamesBCollins Guest

    0
     
    I have looked at that thread but it seems to be slightly different.

    I can create new domains fine, its just when i switch to using atmail.

    I have also run the updates and plesk is telling me i am all up to date.

    Anything else i can try?
     
  5. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Try to remove and install webmail back with /usr/local/psa/admin/bin/webmailmng (--help option for details).
     
  6. JamesBCollins

    JamesBCollins Guest

    0
     
    I have managed to remove atmail using /usr/local/psa/admin/bin/webmailmng --remove --name=atmail

    But when i use /usr/local/psa/admin/bin/webmailmng --install --name=atmail

    I get Unable to get options for atmail webmail??
     
  7. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Do you have atmail installed there? I have checked it and works fine for me:

     
  8. JamesBCollins

    JamesBCollins Guest

    0
     
    It showed up in the options in plesk as being installed. When i ran the --remove it then was not showing up in plesk but when i do the --install it just says unable to get options for atmail webmail.

    When i run rpm -qa | grep atmail it shows psa-atmail-1.03-2.el5.art
     
  9. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Ok. Just try to reinstall it with removing
    And installing with /usr/local/psa/admin/sbin/autoinstaller back.
     
  10. JamesBCollins

    JamesBCollins Guest

    0
     
    [root@s15333496 /]# rpm -e psa-atmail
    Unable to get options for atmail webmail
    error: %preun(psa-atmail-1.03-2.el5.art.noarch) scriptlet failed, exit status 25 5
     
  11. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,572
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Try to add --noscripts option.
     
  12. JamesBCollins

    JamesBCollins Guest

    0
     
    Ok i have run rpm -e psa-atmail --noscripts which run ok.

    Then i have run /usr/local/psa/admin/sbin/autoinstaller which updated .fr language packs and thats it. It's not picking up atmail as an update
     
  13. JamesBCollins

    JamesBCollins Guest

    0
     
    Sorry, ignore my last post, it installed ok. I can now choose AtMail as a webmail client and it sets ok but when i go to the website i get the following error.

    Database Connection Error
    DB Error: connect failed

    * Verify the SQL database is running
    * Check the SQL server is listening to the specified socket, IP address
    * Check the global configuration file (/var/www/atmail/libs/Atmail/Config.php) for the correct database details
    * Verify the database server is running correctly
    * Verify the MySQL /etc/my.cnf file has the correct settings for the number of database connections
     
Loading...