1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Expand 1.0.2 error passing Server OS

Discussion in 'Plesk Expand 2.0 and Legacy General Discussion' started by mbAndy, Dec 6, 2004.

  1. mbAndy

    mbAndy Guest

    0
     
    Anybody used the API to select a server os by passing the os name in? Getting an error, but the XML seems to follow the documentation. This is XML Im passing in (formatted for easier reading) and below is the error:
    Code:
    <?xml version="1.0" encoding="UTF-8"?>
                    <packet version="0.0.0.110">
                        <add_use_template>
    			<gen_info>
    				<pname>Uktest Account</pname>
    				<email>fffrrrrrrf@asdf.com</email>
    				<passwd>funfun</passwd>
    				<cname></cname>
    				<login>kchrist</login>
    				<phone>502-555-2525</phone>
    				<fax></fax>
    				<address>133 My Street</address>
    				<city>Louisville</city>
    				<state>KY</state>
    				<pcode>95558</pcode>
    				<country>US</country>
    			</gen_info>
    			<tmpl_id>2</tmpl_id>
    			<server_os>RedHatel3</server_os>
    		    </add_use_template>
    		</packet>
    
    Error:

    Cannot parse packet - invalid XML or DOM error. Error at file 'stream', line 6, column 73: Element 'server_os' is not valid for content model: '((gen_info,limits,tmpl_id),(server_id|((server_auto,server_keyword),server_os)))'

    Works fine if I pass server_id in <server_id>2</server_id> instead of server_os at the same level.

    Ive also tried several os options. This one seems to be valid at least.


    Thanks,
    Andy
     
Loading...