1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Expand Sync Errors after CMail upgrade

Discussion in 'Plesk Expand 2.2 Troubleshooting Issues' started by atomic, Jul 21, 2008.

  1. atomic

    atomic New Pleskian

    22
    57%
    Joined:
    Nov 12, 2008
    Messages:
    17
    Likes Received:
    0
    After replacing our central email server with a new/upgraded server, I think I've resolved most of the issues except one. Expand is reporting the action "Synchronization of mail traffic & disk usage stats for Centralized Mail" failed with the following:

    <errcode>4000</errcode>
    <errtext>[PleskAgent - GENERAL] Operation failed. Unable to update disk usage manager. Error: Some fields are empty or contain an improper value. ('mailboxes' = '-150282240')</errtext>

    Here's the message out of the problem report:

    <packet version="1.4.2.0"><domain><set><result><status>error</status><errcode>1023</errcode><errtext>Unable to update disk usage manager. Error: Some fields are empty or contain an improper value. ('mailboxes' = '-158220288')</errtext><filter-id>37</filter-id><id>37</id></result></set></domain></packet>

    I've tried reloading the domain I think is in question, I've even removed the entire CMail server out of Expand and re-assigned it without any luck.

    The problem is I can't tell if this is an issue with a specific domain, or the fact that the new server has 1TB drives instead of the 160GB drives the old server had. We probably also did the migration the hard way, since I'd read of some problems using the Migration Tool, here's how we did our migration:

    - tar up and transfer the following:
    /var/qmail/mailnames
    /var/qmail/control
    /etc/drweb
    /etc/psa
    /usr/local/psa/admin/htdocs/domains/databases/phpMyAdmin/libraries/config.default.php

    - backup all databases
    - restore everything on the new server
    - manually swap IP Addresses and reboot

    Everything worked quite well, except for this Sync issue with Expand.

    If anyone has any ideas or suggestions on how to clear up the sync issues or even where it's generating those numbers.

    Thanks,
    Atomic
     
  2. ryoku

    ryoku Guest

    0
     
    Try this query to the database on plesk cmailhost:
    select domain_id, mailboxes from disk_usage where mailboxes>'4294967290';

    If the list is not empty then define domain names.
    select id, name from domains where id = 'id of domain with more than disk_usage 4294967290'.

    Also you can do next:
    Archive problem report and attach it to the message. This will help programmers understand the problem.
     
  3. atomic

    atomic New Pleskian

    22
    57%
    Joined:
    Nov 12, 2008
    Messages:
    17
    Likes Received:
    0
    There was 1 domain returned, which I thought was the one in question, but now I'm still not sure how to resolve the error. I've tried reloading the domain in Expand and double checked that the client and domain both have unlimited disk usage in both CMail and Expand.

    That's why it's confusing, everything is set so they can have as much email as they'd like, but something is still reporting that it's an invalid number. Does Plesk/Expand have a cap on how much disk space one domain can use? If I set a limit to something larger than they're using, then set it back to unlimited, would that help?

    Thanks for any insight.

    Atomic
     
Loading...