1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

failed upgrade to 7.5.4

Discussion in 'Plesk for Linux - 8.x and Older' started by rspurlock, Aug 9, 2006.

  1. rspurlock

    rspurlock Guest

    0
     
    Upgrade procedure.. was: failed upgrade to 7.5.4

    Hello all, I have a failed upgrade to Plesk 7.5.4 fro 7.5.3. So I'm going to go command line and do it that way. But here's the question:

    Do I upgrade my CentOS to 3.6 before I run the upgrade? Or should it be done afterwards? Basiclly I want both, but since there is an install for 7.5.4 for both CentOS 3.3 and 3.6, how do I get to the end point with both installed?

    TIA

    Rob





    {previous post}

    Hello all,

    I just attempted an upgrade on one of our servers from 7.5.3 to 7.5.4 while we attempt to get caught up to v8.

    The upgrade (using autoupdater) failed the first time with this messages:

    Installing /PSA_7.5.4/rpm_CentOS_3.3/opt/docs/psa-manual-custom-skin-guide-7.5.4-centos3.3.build75050824.12.noarch.rpm
    error: Failed dependencies:
    psa-api-common = 7.5.3 is needed by (installed) psa-api-rpc-7.5.3-centos3.3.build75050509.09

    ----- end of output -----
    ===> Autoinstaller: stopped logging at Thu Aug 10 00:53:15 2006


    So I removed the psa-api-rpc rpm then tried again. Now Plesk won't even start. Here's the excerpt from the log:

    Unable to resolve hostname or establish network access to
    local host: psk03-ded.lnhosting.com. You should fix this problem prior to installing
    Plesk. After you are done, run the installation again.

    error: %pre(psa-7.5.4-centos3.3.build75050824.12) scriptlet failed, exit status 1
    error: install: %pre scriptlet failed (2), skipping psa-7.5.4-centos3.3.build75050824.12
    Trying to stop Admin server... done
    Trying to replace files and set up right permissions... cp: cannot create regular file `/usr/local/psa/admin/htdocs/skins/plesk.christmas/css/left/custom.css': No such file or directory
    chown: failed to get attributes of `/usr/local/psa/admin/htdocs/skins/plesk.christmas/css/left/custom.css': No such file or directory

    ERROR while trying to chown root:0 /usr/local/psa/admin/htdocs/skins/plesk.christmas/css/left/custom.css
    Check the error reason(see log file: /tmp/psa-hotfix75060118.21.log), fix and try again

    Aborting...

    error: %post(psa-hotfix5-7.5.4-centos3.3.build75060118.21) scriptlet failed, exit status 1
    Trying to replace files and set up right permissions... cp: cannot create regular file `/usr/local/psa/admin/htdocs/skins/plesk.christmas/images/top_body_bg.jpg': No such file or directory
    chown: failed to get attributes of `/usr/local/psa/admin/htdocs/skins/plesk.christmas/images/top_body_bg.jpg': No such file or directory

    ERROR while trying to chown root:0 /usr/local/psa/admin/htdocs/skins/plesk.christmas/images/top_body_bg.jpg
    Check the error reason(see log file: /tmp/psa-hotfix75060322.08.log), fix and try again

    Aborting...

    error: %post(psa-hotfix6-7.5.4-centos3.3.build75060322.08) scriptlet failed, exit status 1
    Trying to replace files and set up right permissions... Trying to fix mailman path in psa.conf... done
    done
    Trying to replace files and set up right permissions... done

    ----- end of output -----
    ===> Autoinstaller: stopped logging at Thu Aug 10 01:15:50 2006


    Help?
     
Loading...