1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Failure_to_exec_mailman_wrapper._WANTED_gid_110,_GOT_gid_100.__(Reconfigure_to_take_1

Discussion in 'Plesk for Linux - 8.x and Older' started by etan, Sep 22, 2005.

  1. etan

    etan Guest

    0
     
    As you can see by the topic i am having a problem with mailman

    I migrated my box from 7.1.7 to 7.5.4 and it seems that none of my mailing lists are working.

    When an email is sent to a list the error i get back in qmail is this

    Failure_to_exec_mailman_wrapper._WANTED_gid_110,_GOT_gid_100.__(Reconfigure_to_take_100?)/preline:_fatal:_unable_to_copy_input:_broken_pipe/


    Any ideas how to fix this would be appreciated.

    I have used the check_perms script and everything is fine.

    Thanks in advance
     
  2. wtrask

    wtrask Guest

    0
     
    I am having the same problem on 7.5.4 CentOS 4 except mine is expecting GID 101 I tried compling from source specifying that GID but that did not work either.:confused:
     
  3. etan

    etan Guest

    0
     
    From what i can see, this problem has been around for a long time, i dont understand why sw-soft have not addressed this problem and sorted out a fix.

    This is rediculous, not to mention customers mailinglist's being down, which they rely heavily on for the promotion of there businesses.


    :eek:
     
  4. wtrask

    wtrask Guest

    0
     
    Well I have tried most of the day and evening to get this too work. After trying to compile milman from source specifying the 101 GID I have forced a reinstall of psa-qmail since the offending GID 101 was popuser making sure to delete the user and change the group to 110 but to no avail. Something is not updating and keeping the 101 GID. qmail is not running with GID 110 which the mailman rpm expects. But I am still getting the same error. This is a fresh install from scratch. It looks like I am going to have to move the domains with mailing lists back to the old server until I can figure this out. :mad:
     
  5. reikiman

    reikiman Guest

    0
     
    I've got a newly setup server, and a hard requirement for me is to be able to run mailman mailing lists as I'm migrating an existing server to this one and it has two mailing lists that must migrate.

    According to the Mailman FAQ,
    http://www.python.org/cgi-bin/faqw-mm.py?req=show&file=faq06.016.htp
    the fix for this is to recompile mailman using the --with-mail-gid option.

    But with this preconfigured setup, I'm not clear what to do to recompile mailman. I've setup mailman before from source, but in this case mailman is installed with a strange setup.
     
  6. wtrask

    wtrask Guest

    0
     
    I have tried that I compiled from source and it did not fix the problem. I beleive this is becaise something is not getting overwritten that is set to the wrong GID but I can not find it. Make sure popuser is installed with GID 110. If I could do it again I would make the popuser group before installing Qmail. I appears qmail installs the popuser user as user 110 but is just taking a user mumber in the 100 range. If it is already there as group 110 it will use it.
     
  7. reikiman

    reikiman Guest

    0
     
    Next thing is I'd found the file /var/qmail/users/assign and this documentation of it:
    http://www.lifewithqmail.org/lwq.html#qmail-users

    It controls the UID/GID of the process that delivers email. As it was installed, the GID's are 101 and I edited the file to make them 110. Then I restarted both qmail and mailman, and it hasn't made any difference.

    My server came configured with plesk, and so I didn't have a choice of how to do the install.
     
  8. wtrask

    wtrask Guest

    0
     
    If your server came preloaded with Plesk and it dont work I would mke them fix it.
     
  9. reikiman

    reikiman Guest

    0
     
    Well, maybe I should try and get the hosting provider to fix it ... however ... this morning I had an inspiration, and came up with a brute-force fix.

    See my blog posting here
     
  10. reikiman

    reikiman Guest

    0
     
    Oh, and one other thought.

    I'm brand new to using plesk ... Is there a way to file a bug with swsoft? Or does my hosting provider have to do so?

    Does swsoft staff read these boards?
     
  11. wtrask

    wtrask Guest

    0
     
    If you did not by Plesk you will have to have them do it. They own the Licence not you.
     
  12. etan

    etan Guest

    0
     
    I still have no resolution.

    Anyone else ?
     
  13. etan

    etan Guest

    0
     
  14. etan

    etan Guest

    0
     
    It appears this has now been documented by Sw-soft.

    However $PRODUCT_ROOT_D/admin/sbin/mchk
    Segment fault's so i cant complete the process,




    Mailman can't send messages to subscribers with error: "Failure_to_exec_mailman_wrapper. WANTED_gid_110,_GOT_gid_101. (Reconfigure_to_take_101?)/did_0+0+1/"
    Product versions this article applies to:

    * Plesk for UNIX (questions are not related to version)

    The latest update: Oct,06 2005
    Access: public Article ID #942


    1. Make sure that GID of user 'popuser' equals to 110 in /etc/passwd
    and /etc/group. If it is not, change it to 110. The lines in the files
    must be:

    /etc/passwd:
    popuser:x:110:110:pOP3 service user:/:/bin/false

    /etc/group:
    popuser:x:110:

    2. Run the commands:

    # $PRODUCT_ROOT_D/admin/sbin/mchk

    with option you need.

    3. Stop Qmail, disable SMTP xinetd service and run:

    # find $QMAIL_ROOT_D -gid OLD_POPUSER_GID | xargs chgrp popuser


    4. Enable SMTP xinetd and start Qmail.

    Note: Replace $QMAIL_ROOT_D and $PRODUCT_ROOT_D with values from /etc/psa/psa.conf.
     
  15. DCNet_James

    DCNet_James Guest

    0
     
    I started a seperate thread for this same issue. Why SW-Soft cannot fix a simple problem is beyond me. I've migrated 40+ domains to this server and now I discover this issue.

    FreeBSD 4.11 running Plesk7.5.4 and I get the core dump on mail check utility as well.

    J
     
  16. iDamir

    iDamir Guest

    0
     
  17. DCNet_James

    DCNet_James Guest

    0
     
  18. DCNet_James

    DCNet_James Guest

    0
     
    Finally someone from SW-Soft w/o a lame answer and looks to be like someone else's fix that they came up with I read in a blog somewhere. But here ya go:

    Dear James,

    I am very sorry for this situation. I do apologize.
    There is a solution which does not require running mchk:

    1. Of course, GID of user 'popuser' must be 110 in /etc/passwd and /etc/group

    2. Please create a file mm_wrapper.c with the following content:

    #include <errno.h>
    #include <sys/types.h>
    #include <unistd.h>
    #include <stdio.h>
    int main(int argc, char** argv, char** env) {
    if (setregid(110, 110) != 0) {
    printf("Set right UID/GID for popuser in /etc/passd,/etc/group\n ");
    return -1;
    }
    (void) execve("/usr/local/psa/qmail/bin/mm_wrapper-real", argv, env);
    /* Should not get here */
    }


    3. Run these commands:

    # mv /usr/local/psa/qmail/bin/mm_wrapper
    /usr/local/psa/qmail/bin/mm_wrapper-real
    # gcc mm_wrapper.c -o /usr/local/psa/qmail/bin/mm_wrapper
    # chmod 6755 /usr/local/psa/qmail/bin/mm_wrapper

    As for mchk, I will ask devs to provide you with the working utility.

    Thank you,

    --
    Vitaly Semkin
    Technical Support Engineer
    SWsoft, Inc.
     
  19. DCNet_James

    DCNet_James Guest

    0
     
    So the last post I made works. For FreeBSD novices (if there are any out there) here is the exact process:

    1. As ROOT for all of this, backup your password file cp /etc/master.passwd /etc/master.passwd.saved

    2. Edit your /etc/master.passwd file for user popuser and replace the group ID with 110 and should look like this prior to the fix (was group 100 in my case):
    popuser:*:110:100::0:0:pOP3 service user:/:/sbin/nologin
    fixed:
    popuser:*:110:110::0:0:pOP3 service user:/:/sbin/nologin

    3. Run the following command:
    /usr/sbin/pwd_mkdb -p /etc/master.passwd

    4. Edit your /etc/group file and change it to the following:
    popuser:*:110:

    5. Now make a file /tmp/mm_wrapper.c using VI or pico -w or whatever your fav editor is...
    File contents:
    #include <errno.h>
    #include <sys/types.h>
    #include <unistd.h>
    #include <stdio.h>
    int main(int argc, char** argv, char** env) {
    if (setregid(110, 110) != 0) {
    printf("Set right UID/GID for popuser in /etc/passd,/etc/group\n ");
    return -1;
    }
    (void) execve("/usr/local/psa/qmail/bin/mm_wrapper-real", argv, env);
    /* Should not get here */
    }

    6. Stop PSA (just in case): /usr/local/psa/rc.d/psa stop

    7. Run this command: mv /usr/local/psa/qmail/bin/mm_wrapper /usr/local/psa/qmail/bin/mm_wrapper-real

    8. Run this command: gcc /tmp/mm_wrapper.c -o /usr/local/psa/qmail/bin/mm_wrapper

    9. Run this command: chmod 6755 /usr/local/psa/qmail/bin/mm_wrapper

    10. I would make sure that the ownership of new file is like follows:
    rwsr-sr-x 1 root qmail 4736 Oct 13 13:46 mm_wrapper
    or
    rwsr-sr-x 1 root popuser 4736 Oct 13 13:46 mm_wrapper

    Mine is the first and works fine...

    11. Start PSA: /usr/local/psa/rc.d/psa start
    12. Tail your maillog while you send an email to one of your lists and see if the error repeats. It shouldn't.

    Again I've only tested this fix on FreeBSD 4.11 and 5.4 systems running PSA 7.5.4 with the latest patches installed. As for the mchk utility I'm told a fix is in the works.

    Thanks,
    James
     
  20. etan

    etan Guest

    0
     
    The utility for for this problem has now been fixed and swsoft has released a patch to download

    however

    I get to this point here

    find /usr/local/psa/qmail -gid 100 | xargs chgrp popuser

    find: -gid: unknown option

    AWESOME WORK


    Freebsd 5.3
     
Loading...