1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

FTP Backups - Don't work when scheduled.

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by sourcez, Aug 1, 2009.

  1. sourcez

    sourcez Guest

    0
     
    This is a weird problem as I don't have it on any of my other servers!

    I do backups through the plesk control panel and when I click Back Up it'll transfer it to my FTP repository just fine, but when I set up a scheduled backup it simply puts the files in the local machine without transferring it.

    Another problem is that the server doesn't see these as 'local' backups and so it ignores the '5 backups max' storage limit and stores them all...which eats up server space fast.

    Any ideas why the scheduled tasks fail while the one-time backup works?
     
  2. TRANCEMANIAC

    TRANCEMANIAC Guest

    0
     
    Same problem when backup with ftp-repository when scheduled

    Hi all,

    i have the same problem on my system.

    Manual backup with ftp-responsitory works,
    scheduled ftp-responsitory backups not.

    After the scheduled backup the backup is local saved right,
    but on the ftp-repository the backupfile has 0 bytes
    and the local file is not deleted.

    This brings the local diskusage fast to the limit.

    I have set a extra partition to the /var/lib/psa/dumps/ so that only the backups not working,
    when the diskusage is maximum for the partition.

    OS: Ubuntu Server 8.04 LTS

    Has enyone a idear?

    Thanks,

    TRANCEY
     
  3. sourcez

    sourcez Guest

    0
     
    Pretty much the problem - at least I'm not the only one!

    Doesn't matter what size the backup is - it never works.

    Oddly, I didn't get any error messages until Sat, Aug 1, 2009 at 5:30 PM when I received 30 messages for the previous month at the same time. Every message contains a migration result file saying:

    Website domain changed for safety.
     
  4. TRANCEMANIAC

    TRANCEMANIAC Guest

    0
     
    Parallels your help is needed

    Problem is not solved until now.

    My discspace is running out. :(

    I have attached the some screenshots of the Control Panel.

    Please have a look.

    Once again, the scheduled ftp backup is not working.

    When i make a manual ftp-backup it works fine, so there must be a bug in the management of backup with scheduling?

    If it's helpfull...

    My server has two network interfaces. eth0 = external ip (89.xx.xxx.xx), eth1 = internal ip (10.xx.xx.xxx)
    The ftp-backup goes to an internal backup-server over eth1 (10.xx.xx.xxx).


    Parallels please help.


    Many thanks,

    TRANCEY
     

    Attached Files:

  5. TRANCEMANIAC

    TRANCEMANIAC Guest

    0
     
    Forgot something...

    Sorry, i have forgotten something more.

    The scheduled backups are not dying and hangs on as "zombies" in the system.
    And they are very hungry...

    They stay on top with 98-100% systemload. :(

    Every day a have to use the chainsaw (kill -15 PID) to kill the zombies manually.


    TRANCEY
     
  6. TRANCEMANIAC

    TRANCEMANIAC Guest

    0
     
    I opend a ticket...

    Parallels is working on my open ticket...

    One of the supporters connected to my server and had a look aground.

    The problem is the "passiv" ftp-mode on the backup-server.
    This is not working when you try to make scheduled backups.

    The supporter will submit my ticket to the developers for fixing that issue.

    So i wait for response and a bugfix. :)

    Greetings,
    TRANCEY
     
  7. TRANCEMANIAC

    TRANCEMANIAC Guest

    0
     
    Workaround

    The scheduler is not using the option "--ftp-passive-mode".
    On manual backup is the option send to the perl-script and works fine.

    At the moment you can only bring the personal FTP repository server in "active mode"
    to make scheduled backups with FTP repository.

    The problem is reported to the development team with high priority and will be fixed in future update of the Plesk Panel.

    Greetings,
    TRANCEY
     
  8. MathiasA

    MathiasA New Pleskian

    20
     
    Joined:
    Oct 18, 2009
    Messages:
    5
    Likes Received:
    0
    Since we will be waiting a long time. FTP Backup indeed create, restore Plesk no. Schomberg had consumed so many tickets. Deleting FTP backups not possible to load the FTP backups to the local repository is not possible. Improperly implemented FTP client in Plesk. Although Plesk used to create the specified dates. To restore or delete the pleskadmin is used. Access denied.

    Best regards
    M. Andreck
     
  9. Jorge del R

    Jorge del R Guest

    0
     
    I have similar problem than yours. Not restore is possible.
    Now the "ftp network error" is not given but I cannot restore my system at all.
    Hour and hours the "wait. loading" screen but nothing more happens.
    This is my post: http://forum.parallels.com/showthread.php?t=98279
    I'm really in despair. And I don't know what to do more.
    Any help please?
    Is this an Plesk error?
     
  10. vangelb

    vangelb Guest

    0
     
    I have the problem that plesk is doing 2 schedule backups instead of 1. For exapmple I gave to backup a reseller at 01:00 am and I see 2 backups. One at 12.28 pm and another one at 01.13 pm. This is happening on both plesk servers I have. Any thought?
     
  11. Lupker

    Lupker New Pleskian

    16
    35%
    Joined:
    Jan 12, 2011
    Messages:
    11
    Likes Received:
    0
    Crontab script to remove backupmng dump files after backups

    Hi folks,

    Old thread, but I would like to contribute anyway. I am running this script to empty the dump map in Plesk to make sure no old backup files are being kept on my server. Although backups where placed correctly on my FTP, sometimes the temp files are still present on my server. As you've said: my diskspace was full after a few days.

    I've set this up here (CentOS 5) : /usr/local/psa/admin/bin/backup_dumps_delete

    Here is the script:

    #!/bin/sh backup_dumps_delete#
    # Delete backup more than 90 days old.
    #
    backupDir="/var/lib/psa/dumps"
    #
    daysToKeep=0

    echo "Checking for files older than $daysToKeep days in $backupDir"
    listOfFiles=`find $backupDir -mtime +$daysToKeep`
    if [ ! -z $listOfFiles ]
    then
    echo "Found [$listOfFiles]"
    else
    echo "None found."
    fi
    for toDelete in $listOfFiles
    do
    echo "Deleting $toDelete"
    rm -rf $toDelete
    done
    echo "Done.
     
  12. abdi

    abdi Platinum Pleskian

    31
    18%
    Joined:
    May 14, 2006
    Messages:
    2,913
    Likes Received:
    60
    Thanks for sharing that information Lupker.
     
Loading...