1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

FTP Problem with large file

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by gianni.infodata, Jun 9, 2009.

  1. gianni.infodata

    gianni.infodata Guest

    0
     
    Hi all,
    I've a Plesk 9.0.1, and I've a problem with ftp server. When I try to upload a big file 10-15 MB, after 10-15 sec the ftp connection go timeout. How can I resolve this problem? I try to reboot the server many times, but the problem stay alive. Thanks ALL!
     
  2. Denis Sirochenko

    Denis Sirochenko Guest

    0
     
    Hello,

    Have you tried to increase ftp session time, as described in the corresponding Knowledge Base article:

    My clients got disconnected from FTP by timeout. How do I change the ftp session times?
    http://kb.odin.com/en/173

    May be the upload takes just more than 10-15 sec to complete.

    Regards,
    Denis.
     
  3. Nataliya Zagr

    Nataliya Zagr Regular Pleskian

    21
    87%
    Joined:
    Apr 14, 2009
    Messages:
    242
    Likes Received:
    0
    Hello,

    You can configure different timeouts in the main ProFTPd configuration file. When logged into the shell as a root open $FTPD_CONF/proftpd.conf file and sets times what you need in the server config or <Global> area, for example:

    TimeoutNoTransfer 900
    TimeoutStalled 600
    TimeoutIdle 1200

    Please, check the following articles for more information:

    http://kb.odin.com/en/173
    http://kb.odin.com/en/1533
     
  4. GianniN

    GianniN Guest

    0
     
    The problem is the Plesk firewall, if I disable the ftp connections works right.
     
Loading...