1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

FTP Problems

Discussion in 'Plesk for Linux - 8.x and Older' started by whryzak, Jun 5, 2006.

  1. whryzak

    whryzak Guest

    0
     
    I have local a Windows PC and a Unix PC with Suse 10 and Plesk 8 1-user and on the Web a Suse 10 with 30 userPlesk8.
    FTP between local PC and also between Windows and Web Suse works, but not from local Linux to remote Linux:

    Local Windows (LEAPFTP) to local Suse : OK
    Local Suse (IglooFTP) to Windows : OK
    Local Suse (IglooFTP) to another local Suse: OK

    Local Windows (LEAPFTP) to Web Suse: OK
    Local Suse (with all programs) to Web Suse: Errors:

    Connection works, and Password is accepted, but directory of remote Unix is not shown, and following errors come:
    Entering passive Mode
    Timeout (socket connect)
    Unable to connect socket
    Unable to connect to data socket
    Unable to bind data socket
    Unable to get host reply
    List command failed

    When I disable the firewall on local unix its the same

    Some suggestions ?
     
  2. deeperimage

    deeperimage Guest

    0
     
    have you tried in non-passive mode? disable passive mode in your FTP client and try again.
     
  3. freaky@

    freaky@ Regular Pleskian

    26
     
    Joined:
    May 2, 2006
    Messages:
    104
    Likes Received:
    0
    Indeed had the same problem (disable passive, which in most clients now-a-days is enabled by default (why-o-why?!)).

    The problem is probably with the stateful firewall. It knows a standard FTP connection, and knows to open port 20 for data transfer. This isn't the case when you use passive mode. Atleast, I think that's the problem. Haven't opened port 20 in the firewall and it works fine when using normal mode (no-passive).
     
  4. freaky@

    freaky@ Regular Pleskian

    26
     
    Joined:
    May 2, 2006
    Messages:
    104
    Likes Received:
    0
    In order to answer this (was looking back on my own postings) all we had to do was load the FTP iptables helper (usually modprobe ip_conntrack_ftp). Probably would like that setup in the firewall script of your distribution.
     
Loading...