1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

FTP Time Outs

Discussion in 'Plesk for Linux - 8.x and Older' started by HekkeySE, Aug 25, 2005.

  1. HekkeySE

    HekkeySE Guest

    0
     
    I''ve searched the forum but couldn't find a answer for our problem.

    We did a new install of Plesk and everything worked perfectly except the FTP. When a client connects with SmartFTP, CuteFTP or even Internet Explorer, the FTP server comes with a time out problem. Only WS_FTP works perfectly.

    Does anybody know a solution to this problem?
     
  2. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Strange. Can you localize any specific config differences between the ftp client software (active vs passive, auth method, etc)??

    Newer versions of IE (like with WinXP SP2) do act strange in any case. Don't get me started on an MS rant...

    I've used Cute and WS on many Plesk (6.0 to 7.5.3, soon to test 7.5.4) and non-Plesk servers, the only time I ever had problems was related to the ftp client configs.
     
  3. HekkeySE

    HekkeySE Guest

    0
     
    No. The client settings are always standard. But other hosts will do it perfectly with the FTP client(s) except this server.

    FTP Log:

    Resolving host name "83.149.*.*"
    Connecting to 83.149.*.* Port: 21
    Connected to 83.149.*.*.
    220 ProFTPD 1.2.10 Server (ProFTPD) [83.149.*.*]
    USER *
    331 Password required for *.
    PASS (hidden)
    230 User * logged in.
    SYST
    215 UNIX Type: L8
    FEAT
    211-Features:
    MDTM
    REST STREAM
    SIZE
    211 End
    PWD
    257 "/" is current directory.
    TYPE I
    200 Type set to I
    PASV
    227 Entering Passive Mode (83.149.*.*,144,147).
    Opening data connection to 83.149.*.*Port: 37011
    LIST -aL
    Timeout (20s).
    Active Help: http://www.smartftp.com/support/kb/index.php/45
    Client closed the connection.
     
  4. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Check your /etc/proftpd.conf file and see if you have the following settings:

    1. Before the <Global> section:
    UseReverseDNS off

    2. In the <Global> section:
    IdentLookups off

    3. What values to you have for the following:
    TimeoutLogin
    TimeoutIdle
    TimeoutNoTransfer
    TimeoutStalled
     
  5. vision

    vision Guest

    0
     
    I have the exact same problem as the original poster.

    Here is my attempt to login:

    SmartFTP v1.5.990.4
    Resolving host name "www.hostname.com"
    Connecting to 216.69.1.1 Port: 21
    Connected to www.hostname.com.
    220 ProFTPD 1.2.10 Server (ProFTPD) [216.69.1.1]
    USER spduser
    331 Password required for spduser.
    PASS (hidden)
    230 User spduser logged in.
    SYST
    215 UNIX Type: L8
    FEAT
    211-Features:
    MDTM
    REST STREAM
    SIZE
    211 End
    PWD
    257 "/" is current directory.
    CWD /
    250 CWD command successful
    PWD
    257 "/" is current directory.
    TYPE I
    200 Type set to I
    PASV
    227 Entering Passive Mode (216,69,1,1,128,22).
    Opening data connection to 216.69.1.1 Port: 32790
    LIST -aL
    A connection attempt failed because the connected party did not properly respond...
    Timeout (30s).
    Active Help: http://www.smartftp.com/support/kb/index.php/74
    Client closed the connection.
    Automatic failover of data connection mode from "Passive Mode (PASV)" to "Active Mode (PORT)".


    The problem is not new, when the server was installed a couple of weeks ago (my first Plesk machine) it has happened.

    If I use the FTP DOS program in Windows it works fine, but if I use smartftp it times out.

    I added UseReverseDNS off before the global section (it already exists after, futher down in the file).

    I added IdentLookups off in the global section.

    The config file contains no values for any of these:

    TimeoutLogin
    TimeoutIdle
    TimeoutNoTransfer
    TimeoutStalled


    The ftp server does not totally timeout when using web publishing software (that uses FTP), it does have a 20 second delay every time it make a connection.

    Really annoying.
     
  6. manarak

    manarak Guest

    0
     
    I do have the exact same problem as the previous poster, including the 20 sec problem.

    I can connect fine with smartFTP, but one of my clients always gets a timeout, regardless of the FTP program he's using, and from where he connects (several places).

    I would be very glad if this problem could be solved.
     
  7. manarak

    manarak Guest

    0
     
    any news?
     
  8. rvdmeer

    rvdmeer Guest

    0
     
    I had the same problem and fixed this by setting up an Passive Port in the proftpd config.

    /etc/proftpd.conf

    # Passive mode added manually by RvdMeer
    PassivePorts 3456 3456

    Then restart and dont forget the modify firewall settings.
     
  9. vision

    vision Guest

    0
     
    Nice! It fixed my problems, I read on the FTP Software support forum some info and I was able to get the FTP server to operate in standard (non-passive mode).

    With your suggested addition to the config file, and then creating a rule on the Plesk server to allow incoming traffic to port 3456 (tcp) I now have a fully operational FTP server with no delays and works in all clients.

    Thanks much for the input rvdmeer!
     
  10. manarak

    manarak Guest

    0
     
    Are there any significant security risks doing this?
     
  11. rvdmeer

    rvdmeer Guest

    0
     
    I dont think so...

    From: http://slacksite.com/other/ftp.html
     
Loading...