1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Getting an email from Cron Daemon each hour

Discussion in 'Plesk for Linux - 8.x and Older' started by gdimarco, Jun 23, 2006.

  1. gdimarco

    gdimarco Guest

    0
     
    Since yesterday I started getting this email each hour.

    Any ideas on how to fix it?

    OS: Fedora Core 4
    Plesk 8

    From: Cron Daemon [mailto:root@Ipcnetworks.com]
    Sent: Friday, June 23, 2006 8:31 AM
    To: root@Ipcnetworks.com
    Subject: Cron <root@localhost> run-parts /etc/cron.hourly

    /etc/cron.hourly/sendmail:

    sendmail: illegal option -- q
    sendmail: usage: sendmail [ -t ] [ -fsender ] [ -Fname ] [ -bp ] [ -bs ] [ arg ... ]
     
  2. tuberb

    tuberb Guest

    0
     
    I am having the same issue. Is there a fix for this, or Is there anything wrong with disabling this script; i.e. - what is the sendmail -q command intended to do, how should the command be properly issued, and what are the consequences of it not working as intended?

    Thanks,

    Barry
     
  3. jspilon

    jspilon Guest

    0
     
    plesk uses qmail,not send mail you don't need that script...
     
  4. jamesyeeoc

    jamesyeeoc Guest

    0
     
    True, but the real question is: since this just started, did they recently do some update/upgrade which inserted that script into their crontab? If so, then what is the cause?

    For any who are curious, Plesk does use Qmail, which provides a 'sendmail' wrapper so things like php scripts can still call the 'sendmail' program, but in reality is running Qmail. The -q option for sendmail would try and force the mail queue to attempt immediate delivery of queued messages.

    I'm curious to see what update may be responsible for suddenly inserting a crontab entry...
     
  5. OutKa5t

    OutKa5t Guest

    0
     
    I would also like an explanation of this hourly mail.cron and a fix if its not needed.

    Has anyone made any progress with this?
     
  6. Mateo1041

    Mateo1041 Guest

    0
     
    Add me to the list. Can't figure this one out. Can I just disable the hourly cron task?
     
  7. owen

    owen Guest

    0
     
    Hi Folks,

    I think that I may have the solution for this. My /etc/cron.hourly directory was empty and I was still getting this behaviour. It appears that there's a separate sendmail config file in /etc/sysconfig as described here http://www.centos.org/docs/2/rhl-rg-en-7.2/s1-boot-init-shutdown-sysconfig.html. I've set the QUEUE variable to be empty, so I think that should take care of this issue.

    og
     
  8. amit290

    amit290 Basic Pleskian

    24
    23%
    Joined:
    Dec 9, 2006
    Messages:
    56
    Likes Received:
    0
    Anyone found another solution to this? I'm on Plesk 8.1.1, fedora os4. Still getting these emails every hour. Above solution has not worked.
     
  9. amit290

    amit290 Basic Pleskian

    24
    23%
    Joined:
    Dec 9, 2006
    Messages:
    56
    Likes Received:
    0
    Anyone got ideas?

    Is it ok to remove this cron job? what does it do exactly?
     
  10. Mateo1041

    Mateo1041 Guest

    0
     
    FYI, I ended up disabling and have been fine since.
     
  11. Slavko

    Slavko Guest

    0
     
    Solved

    By default cron jobs sends a email to the user account executing the cronjob. If this is not needed put the following command At the end of the cron job line .

    >/dev/null 2>&1

    Look at (6. Disable Email):
    http://www.adminschoice.com/docs/crontab.htm
     
  12. nwilcox

    nwilcox Guest

    0
     
    may I ask how to disable it? Is this something that can be done in plesk?
     
  13. amit290

    amit290 Basic Pleskian

    24
    23%
    Joined:
    Dec 9, 2006
    Messages:
    56
    Likes Received:
    0
    I never found a way of disabling them, but when I moved from a Fedora 4 system to a CentOS they stopped. Dont know if that helps someone out there to figure out why its happening.
     
  14. Mahdii

    Mahdii Guest

    0
     
    This is the solution, not sure why you are still posting asking for help! Thanks Slavko!

    FYI, if you don't know how to do this:

    1. Download Putty (http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html)
    2. Connect via SSH to your server
    3. Type: crontab -e
    4. Add the command to dump the result instead of email it (1,16,31,46 * * * * /usr/local/psa/admin/sbin/backupmng >/dev/null 2>&1)
    5. Repeat for each line that doesn't need an email notification

    Thanks again Slavko!


    Cheers
     
Loading...