1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Help accidentally uninstalled Plesk!

Discussion in 'Plesk for Linux - 8.x and Older' started by Travis Rowland, Mar 14, 2009.

  1. Travis Rowland

    Travis Rowland Guest

    0
     
    I am running CentOS 4.x and I was having some PHP issues and stupid me typed: yum remove php

    Of course you know what happened then, yum proceeded to uninstall dependent packages, one which was the entire plesk server admin.

    I was running plesk 8.6 and I would like to install plesk 9, so I downloaded the autoinstaller and tried to run it, this is the error I get when I try to install 9.0.0.1

    Code:
    ===============================================================================
    
    There are 5 packages required for product to function properly, which
    were not found in your system.
    
    There are 1 packages that need to be upgraded
    in order to install the product.
    
    
    
    N) Install packages;
    S) Show a list of packages; L) Back to primary components list;
    Q) Cancel installing; 
    Select action [N]: 
    Downloading the file PSA_9.0.1/dist-rpm-CentOS-4.2-i386/base/psa-9.0.1-cos4.build90090127.18.i586.rpm: skipped because of md5 checksum match.
    Downloading the file PSA_9.0.1/dist-rpm-CentOS-4.2-i386/base/psa-api-9.0.1-cos4.build90090127.18.noarch.rpm: skipped because of md5 checksum match.
    Downloading the file PSA_9.0.1/dist-rpm-CentOS-4.2-i386/base/psa-awstats-configurator-1.0.0-cos4.build90090127.18.noarch.rpm: skipped because of md5 checksum match.
    Downloading the file PSA_9.0.1/dist-rpm-CentOS-4.2-i386/base/psa-libpam-plesk-9.0.1-cos4.build90090127.18.i586.rpm: skipped because of md5 checksum match.
    Downloading the file PSA_9.0.1/dist-rpm-CentOS-4.2-i386/base/psa-proftpd-1.3.1-cos4.build90090127.18.i586.rpm: skipped because of md5 checksum match.
    Downloading the file PSA_9.0.1/dist-rpm-CentOS-4.2-i386/base/psa-proftpd-xinetd-1.3.1-cos4.build90090127.18.i586.rpm: skipped because of md5 checksum match.
    Downloading the file PSA_9.0.1/dist-rpm-CentOS-4.2-i386/base/psa-updates-9.0.1-cos4.build90090127.18.noarch.rpm: skipped because of md5 checksum match.
    Downloading the file PSA_9.0.1/dist-rpm-CentOS-4.2-i386/opt/updater/psa-autoinstaller-3.4.1-090120.13.i386.rpm: skipped because of md5 checksum match.
    Downloading the file PSA_9.0.1/update-rpm-CentOS-4.2-i386/postgresql-7.4.19-1.el4_6.1.i386.rpm: skipped because of md5 checksum match.
    Downloading the file PSA_9.0.1/update-rpm-CentOS-4.2-i386/postgresql-server-7.4.19-1.el4_6.1.i386.rpm: skipped because of md5 checksum match.
    Downloading the file PSA_9.0.1/dist-rpm-CentOS-4.2-i386/opt/api/psa-api-rpc-9.0.1-cos4.build90090127.18.noarch.rpm: skipped because of md5 checksum match.
    Downloading the file PSA_9.0.1/dist-rpm-CentOS-4.2-i386/opt/maildrivers/courier-imap-3.0.8-cos4.build90090127.18.i586.rpm: skipped because of md5 checksum match.
    Downloading the file PSA_9.0.1/dist-rpm-CentOS-4.2-i386/opt/maildrivers/psa-mail-driver-common-9.0.1-cos4.build90090127.18.i586.rpm: skipped because of md5 checksum match.
    Downloading the file PSA_9.0.1/dist-rpm-CentOS-4.2-i386/opt/maildrivers/psa-mail-qc-driver-1.0.0-cos4.build90090127.18.i586.rpm: skipped because of md5 checksum match.
    Downloading the file PSA_9.0.1/dist-rpm-CentOS-4.2-i386/opt/mailman/psa-mailman-configurator-9.0.1-cos4.build90090127.18.i586.rpm: skipped because of md5 checksum match.
    Downloading the file PSA_9.0.1/dist-rpm-CentOS-4.2-i386/opt/drweb/drweb-base-4.33-rh5_psa.i586.rpm: skipped because of md5 checksum match.
    Downloading the file PSA_9.0.1/dist-rpm-CentOS-4.2-i386/opt/drweb/drweb-daemon-4.33-rh5_psa.i586.rpm: skipped because of md5 checksum match.
    Downloading the file PSA_9.0.1/dist-rpm-CentOS-4.2-i386/opt/drweb/drweb-updater-4.33-rh4_psa.i586.rpm: skipped because of md5 checksum match.
    Downloading the file PSA_9.0.1/dist-rpm-CentOS-4.2-i386/opt/drweb/psa-drweb-configurator-9.0.1-cos4.build90090127.18.i586.rpm: skipped because of md5 checksum match.
    Downloading the file PSA_9.0.1/update-rpm-CentOS-4.2-i386/coreutils-5.2.1-31.8.el4_7.centos.1.i386.rpm: skipped because of md5 checksum match.
    Downloading the file PSA_9.0.1/thirdparty-rpm-CentOS-4.2-i386/../dist-rpm-CentOS-4.2-i386/contrib/spf2-1.2.5-0.274900.i386.rpm: skipped because of md5 checksum match.
    Starting installation of packages
    Installing the package coreutils-5.2.1-31.8.el4_7.centos.1.i386 (u 0xb2db298 source=0xa8a6198 P:275 R:27)
    error: unpacking of archive failed on file /bin/ls: cpio: rename failed - Operation not permitted
    ERROR: An error occurred during installation of packages.
    Attention! Your software might be inoperable.
    Please, contact product technical support.
    [root@sv1 plesk9]# 
    
    This is the error I get when I try to install 9.0.0

    Code:
    
    Installation types for the product:
    
     1. (*) Typical
           Install typically used components. Recommended for general use.
    
     2. ( ) Full
           Install all components.
    
     3. ( ) Custom
           Custom components selection. Recommended only for experienced users.
    
    
    N) Continue installation with selected type; P) Go the previous page; Q) Cancel installing;
    L) Overview or change components marked for the installation
    To select an installation type or switch product, type the respective number;
    Select action [N]: 
    Retrieving information about the installed packages... 
    Downloading the file PSA_9.0.0/dist-rpm-CentOS-4.2-i386/build-9.0.0-cos4.2-i386.hdr.gz: 10%..20%..30%..40%..50%..60%..70%..80%..90%..100% done.
    Downloading the file PSA_9.0.0/update-rpm-CentOS-4.2-i386/update-9.0.0-cos4.2-i386.hdr.gz: 10%..20%..30%..40%..50%..60%..70%..80%..90%..100% done.
    Downloading the file PSA_9.0.0/thirdparty-rpm-CentOS-4.2-i386/thirdparty-9.0.0-cos4.2-i386.hdr.gz: 10%..20%..30%..40%..50%..60%..70%..80%..90%..100% done.
    Determining the packages that need to be installed.
    Warning: packages conflict by files detected: package psa-courier-imap-add-8.6.0-cos4.build86080930.08.i586
      conflict with package psa-mail-pc-driver-1.0.0-cos4.build90081222.11.i586
      both have file /usr/lib/courier-imap/authlib/authpsa with different md5 sum.
    Warning: packages conflict by files detected: package psa-courier-imap-add-8.6.0-cos4.build86080930.08.i586
      conflict with package psa-mail-qc-driver-1.0.0-cos4.build90081222.11.i586
      both have file /usr/lib/courier-imap/authlib/authpsa with different md5 sum.
    ERROR: Unable to install the "psa-9.0.0-cos4.build90081117.17.i586" package.
    
    The following could cause the installation failure:
    Packages "psa-locale-base-en-US-9.0.0-08111414.noarch" and "psa-locale-base-en-US-9.0.1-09012214.noarch" cannot be installed at the same time
    because of the conflict on the file "/usr/local/psa/admin/htdocs/locales/default"
    
    
    
    Not all packages were installed.
    Please, contact product technical support.
    [root@sv1 plesk8]# 
    
    This is the error I get when I try to install 8.6.0

    Code:
    ===============================================================================
    
    Installation types for the product:
    
     1. (*) Typical
           Install typically used components. Recommended for general use.
    
     2. ( ) Full
           Install all components.
    
     3. ( ) Custom
           Custom components selection. Recommended only for experienced users.
    
    
    N) Continue installation with selected type; P) Go the previous page; Q) Cancel installing;
    L) Overview or change components marked for the installation
    To select an installation type or switch product, type the respective number;
    Select action [N]: 
    Retrieving information about the installed packages... 
    Downloading the file PSA_8.6.0/dist-rpm-CentOS-4.2-i386/build-8.6.0-cos4.2-i386.hdr.gz: 10%..20%..30%..40%..50%..60%..70%..80%..90%..100% done.
    Downloading the file PSA_8.6.0/update-rpm-CentOS-4.2-i386/update-8.6.0-cos4.2-i386.hdr.gz: 10%..20%..30%..40%..50%..60%..70%..80%..90%..100% done.
    Downloading the file PSA_8.6.0/thirdparty-rpm-CentOS-4.2-i386/thirdparty-8.6.0-cos4.2-i386.hdr.gz: 14%..24%..33%..43%..52%..62%..72%..81%..91%..100% done.
    Determining the packages that need to be installed.
    ERROR: Unable to install the "psa-8.6.0-cos4.build86080722.02.i586" package.
    
    The following could cause the installation failure:
    Packages "psa-locale-base-en-US-8.6.0-cos4.build86080722.02.noarch" and "psa-locale-base-en-US-9.0.1-09012214.noarch" cannot be installed at the same time
    because of the conflict on the file "/usr/local/psa/admin/htdocs/locales/default"
    
    
    
    Not all packages were installed.
    Please, contact product technical support.
    [root@sv1 plesk8]# 
    
    
    I can't do a mysql dump because I don't know the root mysql password, does anyone know how I can find that out?

    I am pulling my hair out here and going insane, AHHHHHHHHHHHHHHHHHHHHHHH!!!

    They installed Plesk on the root node, can someone also help me setup virtuozzo (already installed) I think I am supposed to be running plesk in a VE and not on the hardware node on a server that has virtuozzo, can someone please confirm? Please help me this is killing me, thank you so much in advance!
     
  2. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    Are you running with SELinux enabled, or are you running low on disk space?
     
Loading...