1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Help: DotNetNuke install problem

Discussion in 'Plesk for Windows - 8.x and Older' started by DesMantez, Nov 13, 2008.

  1. DesMantez

    DesMantez Guest

    0
     
    Configuring DNN I got error:

    Security Exception
    Description: The application attempted to perform an operation not allowed by the security policy. To grant this application the required permission please contact your system administrator or change the application's trust level in the configuration file.

    Exception Details: System.Security.SecurityException: Request for the permission of type 'System.Web.AspNetHostingPermission, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.



    What could be the problem? Site has its own integrated application pool (the permissions are OK). Also I noticed when I change application pool for site to Classic .NET AppPool it works....
     
  2. dvashishtha

    dvashishtha Guest

    0
     
    It looks like your application need "Full Trust" in .net to be allowed.
    You need to enable 'Full Trust' in web.config of your domain But if your provider doesn't allow 'Full Trust' in .net, you may need to re-compile your application in "Medium Trust".
     
  3. DesMantez

    DesMantez Guest

    0
     
    Thx for reply but in IIS for my domain .NET Trust Level is set to Full....
    I'm confused.... what could be the problem?
     
  4. dvashishtha

    dvashishtha Guest

    0
     
    You can check if there is web.config file in your website/application's folder.
     
  5. DesMantez

    DesMantez Guest

    0
     
    web.config exists...
     
  6. joao.pereira

    joao.pereira Guest

    0
     
    Hi mate,

    I'm having exactly the same problem, but only with DotNetNuke v4.9.

    The 4.8 version works perfectly, but under Host Settings I can see that AspNetHostingPermission is not available either!


    Have you found a workaround to this?

    Does anyone know how to allow this permission on Server 2008 with IIS 7 and Plesk?


    Thanks!

    Cheers!
     
  7. prince

    prince Regular Pleskian

    24
    53%
    Joined:
    Aug 16, 2006
    Messages:
    166
    Likes Received:
    0
    Please grant modify permissions for IWPD user(application pool user) to the directory to which you install DNN. If it's in root directory; grant modify permissions to "httpdocs" folder.
     
  8. sigma sig

    sigma sig Guest

    0
     
    I have set up the IIS and the virtual Directory; I have created the database and user, as mention in http://www.adefwebserver.com/DotNet...entEnvironment/DNNDevelopmentWindowsVista.htm
    But when I run http://localhost/DotNetNukeHELP on web browser it is giving error HTTP Error 500.19 - Internal Server Error The requested page cannot be accessed because the related configuration data for the page is invalid.

    And when I try to edit the web.config file according to the way installation guide says to do and click on save it is giving error Operation could not be completed. Access is denied .

    Please help me

    Thanks
     
  9. prince

    prince Regular Pleskian

    24
    53%
    Joined:
    Aug 16, 2006
    Messages:
    166
    Likes Received:
    0
    your issue points to a permissions problem. Make sure that the asp.net user has modify permissions on the root directory.

    Also you should be using the domainname instead of "localhost"
     
Loading...