1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

High CPU load after upgrading to 9.2.1

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by evydaemon, Apr 29, 2009.

  1. evydaemon

    evydaemon Guest

    0
     
    I have a major problem with authpsa processes consuming a lot of cpu load.
    Since the update to the new version it's extremely slow in the Plesk control panel and overall with web services...
    Anyway, all services are up and running for now.

    Update was finished without error messages.

    I rebooted the server twice now:

    #> top

    Cpu(s): 2.3%us, 45.0%sy, 0.0%ni, 46.4%id, 6.2%wa, 0.0%hi, 0.1%si, 0.0%st
    Mem: 2062284k total, 873684k used, 1188600k free, 129216k buffers
    Swap: 3047416k total, 0k used, 3047416k free, 293052k cached

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    3152 root 20 0 20384 1268 1072 D 11 0.1 2:48.81 authpsa
    4023 root 20 0 20384 1264 1068 D 11 0.1 2:05.09 authpsa
    4398 root 20 0 20384 1268 1068 R 11 0.1 1:49.24 authpsa
    5098 root 20 0 20384 1264 1068 D 11 0.1 1:21.73 authpsa
    6373 root 20 0 20384 1268 1068 D 11 0.1 0:29.31 authpsa
    3740 root 20 0 20384 1268 1072 D 10 0.1 2:24.95 authpsa
    4586 root 20 0 20384 1264 1068 D 10 0.1 1:38.78 authpsa
    4731 root 20 0 20384 1264 1068 D 10 0.1 1:35.40 authpsa
    4732 root 20 0 20384 1272 1068 D 10 0.1 1:33.98 authpsa
    4988 root 20 0 20384 1268 1072 D 10 0.1 1:26.27 authpsa
    3149 root 20 0 20384 1272 1068 D 10 0.1 2:49.35 authpsa
    3689 root 20 0 20384 1272 1068 D 10 0.1 2:31.16 authpsa
    4709 root 20 0 20384 1268 1068 D 10 0.1 1:36.51 authpsa
    6736 root 20 0 20384 1268 1068 D 10 0.1 0:16.16 authpsa
    3150 root 20 0 20384 1268 1068 R 10 0.1 2:47.39 authpsa
    3151 root 20 0 20384 1264 1068 D 10 0.1 2:48.53 authpsa
    3153 root 20 0 20384 1268 1072 D 10 0.1 2:49.44 authpsa
    3154 root 20 0 20384 1272 1072 D 10 0.1 2:49.04 authpsa
    3688 root 20 0 20384 1268 1068 D 10 0.1 2:30.08 authpsa
    3890 root 20 0 20384 1264 1068 D 10 0.1 2:14.61 authpsa
    4022 root 20 0 20384 1264 1068 D 10 0.1 2:06.32 authpsa
    4024 root 20 0 20384 1268 1068 D 10 0.1 2:04.90 authpsa
    5518 root 20 0 20384 1268 1068 D 10 0.1 1:00.52 authpsa
    5633 root 20 0 20384 1268 1068 D 10 0.1 0:55.94 authpsa
    5885 root 20 0 20384 1264 1068 D 10 0.1 0:45.64 authpsa
    6540 root 20 0 20384 1264 1068 D 10 0.1 0:25.87 authpsa
    3686 root 20 0 20384 1268 1068 D 9 0.1 2:30.61 authpsa
    3714 root 20 0 20384 1268 1072 D 9 0.1 2:27.43 authpsa
    4025 root 20 0 20384 1268 1068 D 9 0.1 2:05.25 authpsa
    4453 root 20 0 20384 1272 1068 D 9 0.1 1:45.59 authpsa
    4454 root 20 0 20384 1264 1068 D 9 0.1 1:45.20 authpsa
    4455 root 20 0 20384 1268 1068 R 9 0.1 1:44.95 authpsa
    4456 root 20 0 20384 1264 1068 D 9 0.1 1:44.32 authpsa
     
  2. hasher

    hasher Guest

    0
     
    What OS? Try to switch off selinux/apparmor.
     
  3. Manuel Mitteregger

    Manuel Mitteregger Basic Pleskian

    24
    73%
    Joined:
    Apr 8, 2009
    Messages:
    29
    Likes Received:
    0
    Location:
    DACH
    Hi there,

    same problem up here (see my thread)
    Mail login is not working anymore on my machine.

    Any suggestions?
     
  4. Manuel Mitteregger

    Manuel Mitteregger Basic Pleskian

    24
    73%
    Joined:
    Apr 8, 2009
    Messages:
    29
    Likes Received:
    0
    Location:
    DACH
  5. Frank Hoffmann

    Frank Hoffmann Guest

    0
     
    >> What OS? Try to switch off selinux/apparmor.

    Same problem here ... server load is over 80 now, and update "hung" for 10 minutes, then continued.
    The autoupdates tells me "selinux" is shut off.
    But what is "apparmor." and how do I shut it down before an upgrade?

    --->>>

    07:39:33 up 1 day, 19:51, 2 users, load average: 83.46, 72.02, 49.31
    USER TTY FROM LOGIN@ IDLE JCPU PCPU WHAT
    root pts/0 c199077.adsl.han 06:54 40:06 19.38s 5.17s ./parallels_installer_v3.4.1_build090204.18_os_CentOS_5_i386
    root pts/1 c199077.adsl.han 07:14 0.00s 0.01s 0.00s w
     
  6. evydaemon

    evydaemon Guest

    0
     
    update:
    Mail POP3 works if qmail service is stopped.
    authpsa and relaylock processes don't appear if qmail is stopped via the panel.
     
  7. evydaemon

    evydaemon Guest

    0
     
    fedora core 8 x64

    fedora core 8 x64
     
  8. evydaemon

    evydaemon Guest

    0
     
    Ok. Now there's an option under Home -> Settings -> Server-wide mail preferences called:

    #Relaying:
    authorization is required: POP3 lock time __Min.

    if this is unchecked everything works fine. (of course SMTP authentication has to be activated to get mail from the server (same login as pop))
    if checked and SMTP Service is running everything stops working after a while (relaylock processes flooding)

    .. i tried to locate apparmor but it seems it's not installed. i looked in /etc/init.d and searched it with #>locate
     
  9. Frank Hoffmann

    Frank Hoffmann Guest

    0
     
    u p d a t e :

    upgrade finnshed finally -- server load went down to 1 or 2 AFTER the upgrade had finnished. Ten minutes after that upgrade I rebooted the server .. and boing! Now, after server ccomes back up the server load is at 70, then 80, now 103 and growing ... waiting for the crash. I see nothing but "relaylock" and "authpsa" prcesses.

    This is a CentOS 5.3 server -- and it was a fresh Plesk 9.0.1 install that was now upgraded to 9.2.1.

    I cna only warn anybody to upgrade! .... Anyone has some input here?
     
  10. Manuel Mitteregger

    Manuel Mitteregger Basic Pleskian

    24
    73%
    Joined:
    Apr 8, 2009
    Messages:
    29
    Likes Received:
    0
    Location:
    DACH
    hello
    ´
    i found a good solution: change your mta with autoinstaller to postfix and it will working better then.
    you may try a change to qmail back then, and this will work too I think.

    plesk 9.2.1 is cool; no bugs until now, only 10 hours of getting crazy with the updates :)

    manuel
     
  11. Wonder why did they call it 9.2.1

    May be 9.2.1 looks stable? O_O

    Guys, allways try Parallels Plesk updates on non production servers. Don't trust Parallels Plesk, they do not beta test anything. Just wait for them to correct the errors.

    This was suposed to be the 9.1 version, but they named it 9.2.1 , may be because people was scared of using 9.0.1, to make more people to "test" its product... they named it that way, wich could look more stable.

    The thing is that, untill they do not make like 4 or 5 revisions (no matter what name they have), the product is NOT STABLE. So keep that in mind.

    Hope you guys can solve that problems you have right now.

    Paralllels, you have a great product, but , GOD!!!, TEST YOUR PRODUCTS before publishing them.
     
  12. hasher

    hasher Guest

    0
     
    Guys, DO NOT UPGRADE via apt-get/dpkg/yum/rpm/etc but via plesk autoinstaller! When we upgrade Plesk via package manager, it doesn't upgrade some packages, like a psa-mail-qc|pc-driver.
     
  13. Alexander Stamatis

    Alexander Stamatis Guest

    0
     
    Upgraded via yum.

    Everything worked perfectly ! Plesk upgrade took 3 mins without hangs etc.

    ------------

    Yeap plesk needs time to mature but with 9.2.1 we had nothing to loose compared to 9.0.1 :p
     
  14. evydaemon

    evydaemon Guest

    0
     
    done it with /usr/local/psa/admin/sbin/autoinstaller -> selected postfix
    everything works again.

    after that and a reboot i ran autoinstaller again and sucessfully uninstalled qmail.
     
  15. Antonio Sanchez

    Antonio Sanchez Basic Pleskian

    20
    57%
    Joined:
    May 7, 2009
    Messages:
    28
    Likes Received:
    0
    I have upgraded from 9.2.1 to 9.2.1.... (not an error) this morning using autoinstaller and the system boots ok.

    Aprox. 30 minutes later I have experienced Heavy Load.

    I had around 400 instances of 10-apam-XXXX/executable running. After a killall I got 1200 instances of relaylock.

    When the server reaches 800,00 load average at one minute I performed a reboot.

    After reboot I disabled grey listing spam features and the system comes to 4 to 5 load average over an hour. This is too high.

    I disabled the pop3 session timeout before SMTP and the system comes down to 0.3 load average that is normal values.

    Greeted for the solution.

    PLEASE PARALLELS TEAM... Take a look to the Forum Usually....
     
  16. ZopfWare

    ZopfWare Regular Pleskian

    25
    57%
    Joined:
    May 30, 2004
    Messages:
    215
    Likes Received:
    0
    Only fix I've found is to roll back via rpm -Uhv with --force option to the 9.0.1 qmail files (both common driver and the qc)

    Seems to be working as flawed as that version was, however no runaway authpsa and relyloick problems.
     
  17. mparadis

    mparadis Regular Pleskian

    26
    23%
    Joined:
    Sep 18, 2003
    Messages:
    176
    Likes Received:
    0
    It's getting worse all the time with parallels lately. Anyone have any sense of how quickly a fix is going to be made available? People can't even get at their email.
     
  18. mparadis

    mparadis Regular Pleskian

    26
    23%
    Joined:
    Sep 18, 2003
    Messages:
    176
    Likes Received:
    0
    Again, censoring posts.
     
  19. mparadis

    mparadis Regular Pleskian

    26
    23%
    Joined:
    Sep 18, 2003
    Messages:
    176
    Likes Received:
    0
    Under relay options, POP3 auth turned off keeps the load way down but what problems might this bring on?
     
  20. ZopfWare

    ZopfWare Regular Pleskian

    25
    57%
    Joined:
    May 30, 2004
    Messages:
    215
    Likes Received:
    0
    Has anyone tried my suggestion of rolling back to the 9.0.1 qmail rpms?? It worked for me and I'm no longer experiencing high load and I HAVEN'T had to disable any of the security features for my email.
     
Loading...