1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Horde :: Fatal Error

Discussion in 'Plesk 9.x for Windows Issue, Fixes, How-To' started by Dan Brennan, Jul 22, 2009.

  1. Dan Brennan

    Dan Brennan Guest

    0
     
    Hi

    We were using our webmail facilities fine this morning, then about an hour later we got this message

    A fatal error has occurred
    DB Error: no database selected
    Details have been logged for the administrator.

    We havent modified anything.

    After looking at the logs we can see this
    Jul 22 09:48:32 HORDE [notice] [imp] Login success for support@decodestudios.net [213.130.153.148] to {localhost:110} [on line 154 of "C:\inetpub\vhosts\webmail\horde\imp\redirect.php"]
    Jul 22 11:06:19 HORDE [emergency] [horde] DB Error: no database selected: ** ** Array [on line 1637 of "C:\inetpub\vhosts\webmail\horde\lib\Horde\DataTree\sql.php"]

    As you can see it was working fine the 9:48 but at 11:06 it had stopped working


    Anyone any ideas?

    Thanks
    Dan
     
  2. Nataliya Zagr

    Nataliya Zagr Regular Pleskian

    21
    87%
    Joined:
    Apr 14, 2009
    Messages:
    242
    Likes Received:
    0
    Hello,

    Such error occurs when horde can not connect to database storage. In Parallels Plesk Panel (PP) integration horde uses client mysql server.

    Please, check the following article to troubleshoot the issue:

    http://kb.odin.com/en/1356
     
  3. Dan Brennan

    Dan Brennan Guest

    0
     
    Hi

    I realise it is a database problem but firstly its the default install of horde so is running from an sqlite database i believe.

    Is there anyway of resetting horde to use mysql instead?

    Dan
     
  4. ibeme

    ibeme Guest

    0
     
    Hi, we're experiencing the same problem. Did you manage to resolve this issue at all?

    We also use the default SQLite database and have not had any issues until recently.

    Regards
    Rob
     
  5. Dan Brennan

    Dan Brennan Guest

    0
     
    Hi Rob

    No we never managed to solve it we ended up upgrading our MailEnable software to the proffesional edition so we could use there built in webmail software, if you do manage to solve would be usefull to know.

    Regards
    Dan
     
  6. ibeme

    ibeme Guest

    0
     
    Hi Dan,

    I managed to solve the issue by giving plesk user psaserv write permission C:\Windows\Temp.

    This is where it writes it's session data, and it was unable to do this because it did not have appropriate permissions.

    I'm guessing these permissions were changed at some stage without realising it.

    Despite what the log said, it wasn't a database issue at all.

    Hope this information helps.

    Regards,
    Rob
     
  7. islamis

    islamis Guest

    0
     
    I could not connecto Horde for nearly 3 months, I am not sure there is a problem in my computer but looks like no problem. I thought that there is a problem with HORDE itself, no login no connection.
     
Loading...