1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Horde webmail won't let users past prompt

Discussion in 'Plesk for Windows - 8.x and Older' started by hostofthewest, Feb 27, 2006.

  1. hostofthewest

    hostofthewest Guest

    0
     
    Hi all,

    Our users, and myself for that matter, are unable to get past a login prompt to webmail. The user goes to http://webmail.domainname.com and inputs username@domainname.com with the appropriate password. The login prompt is displayed again and again.

    The account was migrated (backup and restore) from another Windows Plesk server. I'm not finding any relevant error logs and I have run defpackagemng.exe to correct the webmail virtual directory. As far as I can see everything looks correct.

    Does anyone know of the solution to this problem?

    Thank you,
    -Bill
     
  2. hostofthewest

    hostofthewest Guest

    0
     
    I have since realized that I shouldn't be seeing a login prompt from IIS but should see the login prompt from Horde instead.

    Unchecked Integrated authentication and now of course I just get a 401 not authorized page.
     
  3. jbuts

    jbuts Guest

    0
     
    To solve this issue try to do the following command:
    "%plesk_bin%\defpackagemng.exe" --fix --type=webmail

    Hope that helps a bit.
     
  4. hostofthewest

    hostofthewest Guest

    0
     
    Yep, I've done that command a few times now also. No dice.

    Thank you,
    -Bill
     
  5. hostofthewest

    hostofthewest Guest

    0
     
    Here's a few more details and the solution that worked for me to get this working again.

    Basically the IIS anonymous user account wasn't able to authenticate with IIS to display the Horde webmail page. I was getting a 401.1 error on any webmail site.

    The webmail virtual directory was setup correctly.

    Running "%plesk_bin%\defpackagemng.exe" --fix --type=webmail didn't fix anything this time as it was a permissions issue and this executable doesn't appear to do anything with permissions.

    What fixed the problem was to modify the default application pool to run under the local system in the identity tab under the properties of the pool. No, it's not the most secure thing to do but until I figure out a better solution it's going to be this way.

    I hope this helps others who have run into this problem.

    Thank you,
    -Bill
     
Loading...