1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

hostname changed, but plesk keep redirecting me

Discussion in 'Plesk for Linux - 8.x and Older' started by EvolutionCrazy, Oct 2, 2005.

  1. EvolutionCrazy

    EvolutionCrazy Basic Pleskian

    23
    90%
    Joined:
    Jun 4, 2005
    Messages:
    65
    Likes Received:
    0
    i've changed the hostname of my server through the plesk admin interface...

    restart the server...

    everything now around the server is setted with the new hostname... except when i access to the plesk interface without specifing https.... (i just tipe http://sub.domain.tld)

    it redirect me to https://oldsub.domain.tld

    what i've to change to be able to access to the interface from the new hostname?
     
  2. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    Sometimes changing the hostname in Plesk is not quite enough. What OS are you using? Log in via SSH and run the command

    #hostname

    See if the new hostname is presented. You may have to make some changes to the OS.
     
  3. EvolutionCrazy

    EvolutionCrazy Basic Pleskian

    23
    90%
    Joined:
    Jun 4, 2005
    Messages:
    65
    Likes Received:
    0
    plesk takes care of

    #hostname

    the only thing i've noticed it hasn't changed is the /etc/hosts... that i've modified manually...

    however i do not understard why it redirect me to the old hostname if i access to plesk without specifing the secure protocol...

    http instead of https...
     
  4. Whistler

    Whistler Guest

    0
     
    Check your /path_to_psa/psa/admin/conf/httpsd.conf file for the following:

    Code:
    #ServerAdmin @adminemail@
    ServerName <server_name>
    DocumentRoot "/usr/local/psa/admin/htdocs"
    <Directory />
    #    SSLRequireSSL ## disabled for allowing http redirect to https by 400 Error (Bad Request see bug #25466)
        Options FollowSymLinks
        AllowOverride None
    </Directory>
    <Directory "/usr/local/psa/admin/htdocs">
        Options FollowSymLinks
        AllowOverride None
        Order allow,deny
        Allow from all
    </Directory>
    
    ## http redirect to https (Bad Request see bug #25466)
    ## it requires that SSLRequireSSL is turned off in other case 403 error is generated
    [b]ErrorDocument 400 [url]https://<your_old_server_name_here>:8443[/url][/b]
    
    If the line in bold refers your old servername thats why it's redirecting wrong - correct this :)
     
  5. EvolutionCrazy

    EvolutionCrazy Basic Pleskian

    23
    90%
    Joined:
    Jun 4, 2005
    Messages:
    65
    Likes Received:
    0
    fixed!

    thanks Whistler!!!

    the problem was exactly there!

    now it's working fine ;)

    thanks ;)
     
  6. dominiosenlinea

    dominiosenlinea Guest

    0
     
    Wanted to say thank you!

    I have been asking my server provider for answer and no luck, been several days ;)
     
Loading...