1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

How do i protect an ssl directory

Discussion in 'Plesk for Windows - 8.x and Older' started by ProggerPete, Sep 4, 2006.

  1. ProggerPete

    ProggerPete Guest

    0
     
    How do I protect a directory in the httpsdocs folder?

    It shows up in the shared ssl for my host.
     
  2. Skeeter

    Skeeter Guest

    0
     
    You shouldn`t place any custom files or folders in the httpsdocs folder. It is designed for technical reasons for Shared SSL implementation.

    You should place all the folders in your regular httpdocs folder. To force https usage for accessing this folder, you should go to Plesk -> Domains -> <domain> -> Web Directories. There you should create a web directory for the folder you wish to protect. After the web directory has been created, you should click the cog wheel icon to the right of the web directory. On the next screen check the "Require SSL" checkbox and click OK.

    Provided that you have protection enabled for this dircetory, you`ll have it accessible via SSL only and it`ll be password protected too.

    Please, check this link for details:

    http://download1.swsoft.com/Plesk/Plesk7.6/Windows/Docs/plesk-7.6-win-admins-guide/21459.htm
     
  3. ProggerPete

    ProggerPete Guest

    0
     
    Hi, thanks for the reply.

    I'm having trouble creating the web directory.

    The folder I want to protect is /admin/

    For name I put in 'test'
    For path I put int '/admin'

    When I try and create it tells me the path is an improper value.
     
  4. ProggerPete

    ProggerPete Guest

    0
     
  5. Skeeter

    Skeeter Guest

    0
     
    Looks like Protection doesn`t work for shared SSL.

    I will forward this to our developers, please, watch the updates for this feature.

    Ok, looks like there`s a workaround:

    you should go to Plesk -> Domains -> shardedssldomain.com (the master ssl domain) -> Web directories -> mydomain_com (the domain with the protected folder) -> admin -> Protection, and add protection here
     
  6. ProggerPete

    ProggerPete Guest

    0
     
    I don't have access to the sharedssldomain (I've just got a reseller account) so I guess I'm stuck.

    Oh well.
     
Loading...