1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

how to fix this???

Discussion in 'Plesk for Linux - 8.x and Older' started by modom, Feb 11, 2005.

  1. modom

    modom Guest

    0
     
    Hi,

    Am running CentOS with plesk 7.5.1 and get this error trying to use the updater in Plesk:

    Preparing for packages installation...
    ----- begin of output -----
    Installing perl-CGI-2.81-88.7.i386.rpm
    warning: /root/psa/PSA_7.5.2/RHel3_std.updates/perl-CGI-2.81-88.7.i386.rpm: V3 DSA signature: NOKEY, key ID db42a60e
    file /usr/share/man/man3/CGI.3pm.gz from install of perl-CGI-2.81-88.7 conflicts with file from package perl-5.8.5-9.rhel3.art
    file /usr/share/man/man3/CGI::Apache.3pm.gz from install of perl-CGI-2.81-88.7 conflicts with file from package perl-5.8.5-9.rhel3.art
    file /usr/share/man/man3/CGI::Carp.3pm.gz from install of perl-CGI-2.81-88.7 conflicts with file from package perl-5.8.5-9.rhel3.art
    file /usr/share/man/man3/CGI::Cookie.3pm.gz from install of perl-CGI-2.81-88.7 conflicts with file from package perl-5.8.5-9.rhel3.art
    file /usr/share/man/man3/CGI::Fast.3pm.gz from install of perl-CGI-2.81-88.7 conflicts with file from package perl-5.8.5-9.rhel3.art
    file /usr/share/man/man3/CGI::pretty.3pm.gz from install of perl-CGI-2.81-88.7 conflicts with file from package perl-5.8.5-9.rhel3.art
    file /usr/share/man/man3/CGI::push.3pm.gz from install of perl-CGI-2.81-88.7 conflicts with file from package perl-5.8.5-9.rhel3.art
    file /usr/share/man/man3/CGI::Switch.3pm.gz from install of perl-CGI-2.81-88.7 conflicts with file from package perl-5.8.5-9.rhel3.art
    file /usr/share/man/man3/CGI::Util.3pm.gz from install of perl-CGI-2.81-88.7 conflicts with file from package perl-5.8.5-9.rhel3.art

    ----- end of output -----
    ===> Autoinstaller: stopped logging at Fri Feb 11 14:24:22 2005

    I do not have perl-CGI on my server so how would I fix this?

    Thanks!
     
  2. modom

    modom Guest

    0
     
    I found out from another post on this same problem that Art's perl broke some dependencies. I really didn't realize that I had installed perl from Art's.

    Can I run this?
    yum remove perl-5.8.5-9.rhel3.art

    and then run the updater within plesk?

    Would this work?
     
  3. modom

    modom Guest

    0
     
    anyone know how to remove this perl and update plesk using the updater without breaking anything?
     
Loading...