1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

IIS and path at $_SERVER

Discussion in 'Plesk for Windows - 8.x and Older' started by palle, Dec 22, 2004.

  1. palle

    palle Guest

    0
     
    Hi. I tried to install an ecommerce solution on the server and it rejected it. I talked with the maker of the shop. and he said the path at $_SERVER under the IIS is not set correctly. How do I change it? I dont wanna ruin anything because there are also other clients running on that server and they running just fine. Has anybody an idea? thanks
     
  2. C_Webs

    C_Webs Guest

    0
     
    $_SERVER refers to an array variable in PHP. Might want to let us know which e-commerce app you are trying to get to work and the exact error message.

    Cheers,

    C_webs
     
  3. palle

    palle Guest

    0
     
    The application name is xt-commerce.com it is similar to osCommerce. That's why i decided me for it because osCommerce runs well on Plesk so i thought xtcommerce should too. xtCommerce is specialist for european market.

    the error which occurs says following:

    Warning: main(/Index.phpincludes/classes/boxes.php): failed to open stream: No such file or directory in C:\Inetpub\vhosts\xxxxxxx.com\httpdocs\xtc_installer\includes\application.php on line 36

    Fatal error: main(): Failed opening required '/Index.phpincludes/classes/boxes.php' (include_path='.;./includes;./pear') in C:\Inetpub\vhosts\xxxxxxx.com\httpdocs\xtc_installer\includes\application.php on line 36
     
  4. palle

    palle Guest

    0
     
    ok i solved the problem now. i installed it first on my local http server and then i copied it to the plesk server. changed the path variables and it works fine.
     
  5. dwdietz

    dwdietz Guest

    0
     
    Where and what did you have to change

    I am having problems with plesk and oscommerce on iis with windows 2003. the $_server could be aculprit since i was told the problem lies with the tep_redirect server calls.. Can you give me more details.

    thanks
     
  6. palle

    palle Guest

    0
     
    what is your exactly error message. well the point in my case was that the $_Server path was just necessary while installation. it requested the path to make the setting automatically. what i did was basicaly a manual installation. i have installed www.apachefriends.com at my local pc. there i run the installation process and copied afterwards everything to the plesk server.
     
  7. dwdietz

    dwdietz Guest

    0
     
    apache

    Thanks for the response.. Although i got the payment module working which was the critical pice, the admin/server_info.php is just returned blank.

    I would like to solve it but not sure what to look for. i was told by the payment gateway that its the server self call (or tep_redirect) that was failing.
     
Loading...