1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Incoming email bounces

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by 105547111, Dec 14, 2008.

  1. 105547111

    105547111 Silver Pleskian

    32
    30%
    Joined:
    Jul 13, 2006
    Messages:
    643
    Likes Received:
    2
    With spamassassin not working I swapped from qmail to postfix.

    First problem was I could not log in pop3 for email, but fixed as postfix there is no short mailnames.

    Anyway spamassassin is working again!

    But I sent a email from external address and it bounced. Any idea's? Some mail comes in okay.

    Thanks!
     
  2. xt881m

    xt881m Guest

    0
     
    What's the bounce message that you are getting?

    Also run an mchk and see what happens, /usr/local/psa/admin/bin/mchk --help
     
  3. 105547111

    105547111 Silver Pleskian

    32
    30%
    Joined:
    Jul 13, 2006
    Messages:
    643
    Likes Received:
    2
    unknown address error 554

    But the mailboxes work some email gets in. It's a postfix thing how can I enable relaying as 554 seems to be no relay allowed.

    Actually my ISP may be blocked as I logged into hotmail and came straight through...

    Update it's SPF but I applied the SPF patch. It seems to be failing looking up the DNS entry for the SPF record any ideas?
     
  4. 105547111

    105547111 Silver Pleskian

    32
    30%
    Joined:
    Jul 13, 2006
    Messages:
    643
    Likes Received:
    2
    I switched SPF to apply headers only don't block and I get emails again.

    Any domain that sends without SPF is getting blocked if I turn it on to deny if refuses to resolve. Does this mean my spf record needs to be updated if so allow what?
     
  5. Petrou Net

    Petrou Net Basic Pleskian

    23
    90%
    Joined:
    Jan 8, 2008
    Messages:
    58
    Likes Received:
    0
    My server also rejects e-mails with no spf records

    My server also rejects e-mails with no spf records (currently I'm using postfix but it happens with qmail too). Is there an spf patch? Where can I find it?
     
  6. 105547111

    105547111 Silver Pleskian

    32
    30%
    Joined:
    Jul 13, 2006
    Messages:
    643
    Likes Received:
    2
    Support told me it's to do with the record but did not elaborate. For now set it to headers only and see what we can dig up. SPF can run in two modes outgoing and incoming so it's incoming we have issue with.
     
  7. Petrou Net

    Petrou Net Basic Pleskian

    23
    90%
    Joined:
    Jan 8, 2008
    Messages:
    58
    Likes Received:
    0
    I found a patch in http://kb.odin.com/en/5847 , I applied it, but the issue isn't fixed. It seems that the incoming messages with no spf record are blocked, unless I set the spf setting to "only create received spf headers, never block". So I suppose we are having the same issue.
    I checked the mail log but it's not very helpful

    Dec 15 05:11:59 jupiter before-remote[21585]: Some error occured
    Dec 15 05:11:59 jupiter postfix/smtpd[21586]: lost connection after DATA from unknown[127.0.0.1]
    Dec 15 05:11:59 jupiter postfix/smtpd[21586]: disconnect from unknown[127.0.0.1]
    Dec 15 05:11:59 jupiter postfix/spawn[21584]: warning: command /usr/lib/plesk-9.0/postfix-queue exit status 255
     
  8. 105547111

    105547111 Silver Pleskian

    32
    30%
    Joined:
    Jul 13, 2006
    Messages:
    643
    Likes Received:
    2
    Yes exactly. Luckily I got a ticket open for spamassassin issues and the SPF so it's being looked at.

    More news once I have something.
     
  9. Petrou Net

    Petrou Net Basic Pleskian

    23
    90%
    Joined:
    Jan 8, 2008
    Messages:
    58
    Likes Received:
    0
    Thank you for the information.
    Please let me know if you have any news about it.
    Are you having issues only with spamassassin and spf?
    I discovered also some issues with attachments, I have opened another thread for it.

    I'm starting to think plesk 9 wasn't ready to be released, perhaps it needed some more testing.
    Clearly this version has e-mail issues.
     
  10. 105547111

    105547111 Silver Pleskian

    32
    30%
    Joined:
    Jul 13, 2006
    Messages:
    643
    Likes Received:
    2
    just spamassassin and SPF.

    Support confirmed they are bugs just waiting for hotfixes.

    The issue is SPF denies email from non SPF domains on any setting except write headers and do not block.

    With spamassassin it's to do with forwarded addresses. Unlike qmail with postfix even forwarded addresses are filtered by virus and spamassassin. Some users on qmail spamassassin does nothing I had this swapped to postfix. But the forwards are looked at by spamassassin and even baynes entries in the forwarded account! But they are not deleted and tags not added.

    Anyway they will get back to me on these but they are confirmed bugs. Also the SPF fix does NOT fix this issue.
     
  11. 105547111

    105547111 Silver Pleskian

    32
    30%
    Joined:
    Jul 13, 2006
    Messages:
    643
    Likes Received:
    2
    Apparently the spamassassin issue is now fixed but now awaiting the actual fix. The SPF issue is now a critical priority with developers awaiting a solution / fix.
     
  12. Petrou Net

    Petrou Net Basic Pleskian

    23
    90%
    Joined:
    Jan 8, 2008
    Messages:
    58
    Likes Received:
    0
    Great news, apparently a hotfix will be available soon
     
  13. x102020

    x102020 Guest

    0
     
    I'm still awaiting a fix on this also. Just thought I would post so I can at least subscribe to this thread.
     
  14. samuelbp

    samuelbp Guest

    0
     
    i'm awaiting for this fix too!!

    I want to subscribe also...
     
  15. Lindsay@

    Lindsay@ Guest

    0
     
    Yes my mail server has been funny since i updated as i thought 9.0.2 fixed the problem
     
Loading...