1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Install wordpress into domain ROOT

Discussion in 'Plesk for Linux - 8.x and Older' started by aaabyss, Mar 31, 2007.

  1. aaabyss

    aaabyss Guest

    0
     
    Install wordpress into domain ROOT - SOLVED

    How do I install wordpress into the domain ROOT with the plesk application vault?

    When I try to install it to / it gives an error saying it is 'incorrect' directory.

    All I have been able to install successfully is either to /WordPress (default) or any directory OTHER than the root.

    TIA
     
  2. nulleffect

    nulleffect Guest

    0
     
    Perhaps just manually copy the files from ./WordPress to /httpdocs and set the URL in the wp-admin?
     
  3. aaabyss

    aaabyss Guest

    0
     
    THANKS! ... DUHHH ... Can't believe I didn't think of that!

    I changed the WordPress address (URI): and the Blog address (URI): in the General Options to mydomain.com and then moved the whole contents of the /WordPress directory to /httpdocs. (root)

    Works fine ... but WHY in the world can't we INSTALL it there to begin with.

    Perhaps it's a bug?

    Anyway, whatever ...

    Thanks again nulleffect!

    TIA
     
  4. zero@

    zero@ Guest

    0
     
    I think you can install it in the Document Root, but perhaps the problem is with permissions? Maybe you can go into the httpdocs folder and make sure that the server can write to it.

    Another option is to install it in a subdirectory, and then create a vhost.conf file with the subdirectory set as the document root. Then reconfigure the virtualhost and restart apache.
     
  5. gluhring

    gluhring Guest

    0
     


    aaabyss,

    This looks like the answer I'm searching for. Can you be more specific in where you changed the addresses? I don't seem to have a General Options.

    Thanks

    Gregg
     
  6. aaabyss

    aaabyss Guest

    0
     
    I went inside of the WP admin to the Options / General / General Options section and changed the following:
    WordPress address (URI): http://mydomain.com
    Blog address (URI): http://mydomain.com
    And moved everything in the wordpress directory to the root directory via ftp.

    FINALLY works in root!

    HTH
     
  7. gluhring

    gluhring Guest

    0
     
    Excellent

    Thanks for the quick reply! I guess the secret really is to make the change in the dashboard first and THEN move the files to httpdocs.

    I moved the files first and then couldn't get in to the admin.

    Have a great day! mine is much better now!

    Gregg
     
  8. aaabyss

    aaabyss Guest

    0
     
    You're welcome and glad you got it going!

    We SHOULD NOT have to do all this though IMHO as plesk should ALLOW it to be installed as we want it to in the FIRST PLACE!

    HTH
     
Loading...