1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

Internal Error 2343

Discussion in 'Plesk for Windows - 8.x and Older' started by SupermanInNY, Jul 30, 2004.

  1. SupermanInNY

    SupermanInNY Guest

    0
     
    Hi,

    I've uninstalled 6.5.2 and now I'm in the process of installing version 7.

    I got through the install... almost!

    near the end of the install (or at least so it seems) I got an error:

    Installer Information: Internal Error 2343.

    Need help with this ASAP as this is a fun.. production server.

    -Alon.
     
  2. SupermanInNY

    SupermanInNY Guest

    0
     
    Why has this issue happen?

    Well..

    I wanted to have a clean slate for my install.
    Well.. as clean as can be.

    I renamed the ....Program Files/Swsoft/Plesk to Program Files/Swsoft/Plesk6.5.2

    and

    Inetpub to inetpub6.5.2

    It failed on the Inetpub.
    Still I didn't give up yet. .. and created a directory called inetpub.

    This time the install went with no problems.

    Mind you, the install when I didn't have the inetpub directory,. was providing its own path to Program Files/Swsoft/Plesk/home/.... whatever the installer wanted.
    That didn't work.
    My guess is that it has something to do with the IIS configs pointing to the specific directory of the inetpub (event though I've stopped the service and restarted it).

    Just giving you my insight on things.

    -Alon.
     
  3. jp_andino

    jp_andino Guest

    0
     
    Did you only get that number for the error, if you can put a description of the error that you got we could know a little more about what actually was the problem.
     
  4. jp_andino

    jp_andino Guest

    0
     
    Do you performed a Full Back Up of Plesk 6.5, using the Plesk back up utility besides copying the c:\swsoft and c:\intepub.
     
  5. SupermanInNY

    SupermanInNY Guest

    0
     
    1. Do you performed a Full Back Up of Plesk 6.5, using the Plesk back up utility besides copying the c:\swsoft and c:\intepub.


    I've done a full backup before I initiated the process.
    I've not done the restore as of yet.
    Just wanted to have the panel working for starters.
    I'm about to initiate the restore in few minutes,. will let you know how successful the process was.

    2. Did you only get that number for the error, if you can put a description of the error that you got we could know a little more about what actually was the problem.

    Yes. The only error that came up was the 2343 error.
    The error is just poping up as msgbox and then the installer performs a rollback of the install.
    My guess on this is that it is related to the IIS configuration which is set from the previous installe of the 6.5.2 and is pointing to the c:/initpub directory as oppose to the "I want you to use the Plesk propopsed directory".

    I do have few more question:

    What are the permissions/users that are and should be set for the C:/initpub directory?
    How do I enable SpamAssain and Application Vault?
    They are showing as disabled on the control panel (greyed out).


    -Alon.
     
  6. PaulC

    PaulC Regular Pleskian

    24
    57%
    Joined:
    Aug 5, 2001
    Messages:
    192
    Likes Received:
    0
    Have you checked the Application Event Log for more information on the error?
     
  7. SupermanInNY

    SupermanInNY Guest

    0
     
    No. I have not check the application log.
    The issue was resolved when I used the initpub directory instead of the suggested Plesk install.

    -Alon.
     
  8. jp_andino

    jp_andino Guest

    0
     
    If you want Application Vault and Spam Assassin, you need to have the Plesk Power Pack, Did your key has it?, It could be the reason that still gray out those icons
     
  9. shwonder

    shwonder Guest

    0
     
    2343 means "Specified path is empty."
    Installer search for directory, it doesn't exists and its value becomes empty.
    It is bug in the installer program. :( I hope, it will be fixed.

    AppVault and SpamAssassin - yes, you need key with the enabled features.
    Unfortunatelly, Spamassassin requires a lot of system resources. spamd doesn't work under Windows as good as it could. You can ask Google about it.
     
Loading...