1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

is it possible to downgrade a plesk install to 7.5.2?

Discussion in 'Plesk for Linux - 8.x and Older' started by ebinc, Nov 21, 2005.

  1. ebinc

    ebinc Guest

    0
     
    I have a couple of 4psa products that do not work anymore after the 7.5.3 to 7.5.4

    I get this now when I try to access

    The file /usr/local/psa/admin/htdocs/cserver/index.php has been encoded with the ionCube PHP Encoder and requires the free ioncube_loader_lin_5.0.so ionCube PHP Loader to be installed.

    I have the encoder installed already I think since it worked before I upgraded, how can I fix this? do I need to edit a line in the php.ini
    has anyone done this? please explain how, we can not use these products and do not have access to the latest versions anymore

    I wish I knew upgrading plesk would effect these products before we upgraded

    I posted on the 4psa forum but have yet to recieve a reply and I really need to fix this

    is it possible to downgrade a plesk install to 7.5.2?

    Thanks
    Ed
     
  2. poke

    poke Guest

    0
     
    4PSA has compiled all new scripts for plesk 7.5.4 and up. This was a major change due to the extra level of administration.

    Get the updates from 4psa.com or from whoever you purchased them from.
     
  3. hardweb

    hardweb Guest

    0
     
  4. ebinc

    ebinc Guest

    0
     
    I know the latest versions have the latest ioncube built in, but we do not have access to the latest versions

    why isn.t there just a 4psa ioncube 5.0 php patch for those of us who do not have access to the (latest 4psa product versions)

    you encode your programs and thats fair you write very good stuff and need to protect it I have no problem with that, I'm not looking for any feature upgrade I just want what I have NOw to work, your encoding should not interfer with what we purchased

    at the very least you should post a notice upgrading plesk may will render your 4psa products inoperable.

    anyone know whats best
    can I upgrade ioncube?
    downgrade plesk?
    does the plesk panel have its own php.ini
    I know it uses php 5.0 and our http server uses 4.3

    or is ther more combatility issues with the upgrade other then iocube noone better to answer that then you hardweb

    Thanks
    Ed
     
  5. ebinc

    ebinc Guest

    0
     
    I installed the ioncube_loader_lin_5.0.so

    IN

    /usr/local/psa/admin/htdocs/sguardian/ioncube/
    and
    /usr/local/psa/admin/htdocs/cserver/ioncube/

    also in /usr/lib/ioncube/


    I then edited the php.ini with this line
    /etc/php.ini

    zend_extension = /usr/lib/ioncube/Ioncube_loader_lin_5.0.so

    it appears cserver and sgaurdian call the loader from somwhere else
    can somone please can someone tell me where it makes the call for the loader?

    The file /usr/local/psa/admin/htdocs/cserver/index.php has been encoded with the ionCube PHP Encoder and requires the free ioncube_loader_lin_5.0.so ionCube PHP Loader to be installed.
    so I installed it but the programs still errors

    THanks
     
Loading...