1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Is Plesk 8 + CentOS 4.3 + PHP 5 possible?

Discussion in 'Plesk for Linux - 8.x and Older' started by codesmith, Jul 13, 2006.

  1. codesmith

    codesmith Guest

    0
     
    Hi,

    I'm trying to get our server provider to do the above installation and they're saying they can't do PHP5. Main reason is that

    "Apache 2.0 and Plesk 8 need the package php-domxml and it's not available for PHP5"

    Can anyone verify this or are there workarounds? I've been reading the other threads and can't tell if folks have this set up.

    Seems like Plesk 8 and PHP 5 should work:
    http://kb.swsoft.com/article_37_378_en.html

    Thanks.
     
  2. codesmith

    codesmith Guest

    0
     
    Woah - didn't Scott from ART say yes this was possible? I don't see the reply here anymore... it's not?
     
  3. jwdick

    jwdick Guest

    0
     
    I am running a new installation of Plesk 8.01 and PHP 5 on FC4.
    So I don't know how things would go on CentOS 4.3 but I do know that Plesk 8.01 and php 5 are working together.

    This was installed on a new server, not an upgrade. I hate upgrades.
     
  4. kenped

    kenped Guest

    0
     
    Jack I wish I had your server!! I have fc4 installed fresh then did the plesk but NO! :-( cant contact the https://ip:8443/ :-( I'm sad,,

    I envy you man!
     
  5. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    In FC4 php-domxml is known as php-xml, same applies for my php rpms.
     
  6. codesmith

    codesmith Guest

    0
     
    Scott - does that apply to CentOS 4.3 as well or just FC?
     
  7. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    Assuming they're my rpms, yes
     
  8. codesmith

    codesmith Guest

    0
     
    So my ISP was finally able to get Plesk 8.0.1, CentOS 4.3 and PHP 5.1.1 installed on our server. The only caveat is that they installed an RPM with PHP configured with --disable-dom option. I guess Plesk breaks (php-configurator?) if this option is turned on? Anyone know the details of this?

    Well it turns out I need the dom support. Any advice on how I would do this? I'm thinking of installing the ART php 5.04 package. If I add the ART channels and do a yum upgrade will it automatically downgrade to 5.04?

    Any advice appreciated.
     
  9. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    No, it will not be able to downgrade, assuming that those php 5.1.1 packages were installed as rpms. If its a source code install, then from an rpms perspective, it doesn't exist, and yes, it would install without much trouble.

    The dom package (formerly known as php-domxml) is contained in the php-xml rpm in both my php 5.0 and php 5.1 rpms.
     
  10. codesmith

    codesmith Guest

    0
     
    Thanks Scott. Yes PHP is installed as an RPM so no source code recompile options. This sounds scary but what if I removed the PHP rpm and then did a yum install for your RPM. Would that work? Would my existing Plesk install be ok?
     
  11. AlbertS

    AlbertS Guest

    0
     
    kick and a Q :)


    I have to install today or these week a new box for a customer...

    Now they want to have php5.x

    What would be the most easyest way to do this?


    Just a clean install with FC4... Taking the ART channels and run yum update... install plesk... done?

    Would it go that easy? Ofcourse some dep. **** and **** ;) but will it work?!

    And what would be different to CentOS 4.2 and updating that one..

    FC comes standard with php5?? :) :confused:
     
  12. AlbertS

    AlbertS Guest

    0
     
  13. abdicar

    abdicar New Pleskian

    22
    57%
    Joined:
    May 9, 2005
    Messages:
    17
    Likes Received:
    0
    Great! It works properly for me.
    Thank you man!:cool:
     
Loading...