1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Issue with Folder content using FTP

Discussion in 'Plesk for Windows - 8.x and Older' started by eleblanc, Nov 30, 2005.

  1. eleblanc

    eleblanc Guest

    0
     
    I'm having this issue on a specific box, some user are not being able to list folder contant using FTP. Those folder usually have alot of files 50+. If you use IE to ftp in the web root you will be unable to list the content of some folders (not all), If you use a FTP client for exemple like smart ftp or core ftp, it take 3-4 minute sometimes more to list the folder content, but it eventually does. If you use ftp dos command it works like a charm.

    So one plesk technicien suggested that i needed to have port 20 open (i have the plesk firewall enabled, that is the windows firewall). SO i try that with no luck. So i test and disable the firewall and tada, all works.

    I haven't got any solution from plesk yet so i'm asking here if anyone has any idea.?
     
  2. larsm

    larsm Guest

    0
     
    well we solved that and a couple of other problems by setting the ftp server to only use port 21 and disable the passive mode
    where it uses random ports
     
  3. eleblanc

    eleblanc Guest

    0
     
    Ok and how could i do that?
     
  4. larsm

    larsm Guest

    0
     
    depends on which ftp server u use
    but you should normally be able to login on the server behind plesk and open the server options and find the settings in there

    we use gene6 and no problems there it works like a charm
     
  5. eleblanc

    eleblanc Guest

    0
     
    I use IIS FTP, should i use serv-u or gene6

    So my question would be how to prevent IIS ftp to use port not allowed by default plesk rules.?
     
  6. larsm

    larsm Guest

    0
     
    Setting PASV Port Ranges

    Passive FTP mode uses a different port number for sending files back to the client than the default FTP port of 21, which is used to send commands and responses.

    You can't configure IIS to switch off passive FTP port support, but in IIS 6 you can configure the port range used, which makes it easier to select a port range and configure your firewall service to pass through the passive FTP traffic.

    There is no front end for the configuration, but it can be set by directly modifying the XML metabase for IIS. The PassivePortRange property within the /LM/MSFTPSVC path should be used to specify the range of ports for PASV support.

    further more there is a bug in iis ftp read below

    http://support.microsoft.com/kb/q163285/


    i would recomend the gene6f ftp server its easey and you can use it to accounts outside the plesk at the same time we have chosen to do so with our backup system wich then access all domains from a nnother server to back them up


    hope this will anwser your quesions ;o)
     
  7. eleblanc

    eleblanc Guest

    0
     
Loading...