1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Issue with SmarterMail & SmarterStats Setup

Discussion in 'Plesk for Windows - 8.x and Older' started by brandonp, Jan 12, 2007.

  1. brandonp

    brandonp Guest

    0
     
    I am in the process of setting up a new Windows Server with Plesk 8.1. I also purchased SmarterMail 4.0.2566 & SmarterStats 3.2.2539.

    I go to Server > Plesk Components Management and attempt to enter the Login, Port and Password information for both SmarterMail and SmarterStats. I get the Error for both packages:

    Code:
    Error: Some fields are empty or contain an improper value.
    When I go to the Events View I get the following message for each attempt:

    Code:
    The application-specific permission settings do not grant Local Launch permission for the 
    COM Server application with CLSID {6B7FF909-F525-4F67-AC61-B74ED9BEB9D8}
     to the user NT AUTHORITY\SYSTEM SID (S-1-5-18).
    This security permission can be modified using the Component Services administrative tool.
    What can I do to get both SmarterMail and SmarterStats to properly work?

    Brandon Petersen
     
  2. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    brandonp, could you please use SmarterMail 3.1.x while we will try to reproduce it?
     
  3. brandonp

    brandonp Guest

    0
     
    Going down a version

    I'll see if I can move down a version. Hopefully they're flexible in how everything is licensed. I know they have to generate an entirely different key for the 3.x version of SmarterMail.

    Please post anything you find about the Smarter Tools. I'd really like to use the newer functionality. There is a significant difference between the features in the new packages.

    Brandon Petersen
     
  4. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    seems there is a bug with plesk 8.1 and sm 4 integration. it will be fixed asap.
    we will keep you informed.
     
  5. brandonp

    brandonp Guest

    0
     
    I appreciate everything

    Thank you, I really appreciate your work on this.

    Brnaond Petersen
     
  6. brandonp

    brandonp Guest

    0
     
    Plans

    It looks like Plesk will have SmarterMail 4.x integration fixed in Q2 of 2007. I caught this in a post on another thread in the forums.

    http://forum.plesk.com/showthread.php?s=&threadid=39941

    I guess I'll go ahead and downgrade. But as soon as they get the support worked out, I'm going to look into upgrading, SmarterMail 4 has a lot that I'm wanting.

    Brandon Petersen
     
  7. foghead

    foghead Guest

    0
     
    That's very disappointing, and I do hope SWSoft can put some priority on this, because we really, really need the greylisting support in SM4.

    Sadly, Spam Assassin is useless and conflicts with my SM3.x install, so it's turned off, and who can afford Declude? So meanwhile the clients are drowning in spam.

    SM4 was our great hope, please get it working as soon as you can.
     
  8. brandonp

    brandonp Guest

    0
     
    Just Released

    They appear to be treating this as a high priority item. SmarterMail 4 was just released, I think it's reasonable to expect a little lag for the integration of a new version of SmarterMail.

    Of course, I hope it gets worked out soon.

    Brandon Petersen
     
  9. sergius

    sergius Golden Pleskian

    28
    57%
    Joined:
    Nov 6, 2005
    Messages:
    1,898
    Likes Received:
    0
    brandonp, sorry I'm wrong. Seems Plesk works properly with SmarterMail 4.
    Please be sure that service SmarterMail Web Service is started.
     
  10. foghead

    foghead Guest

    0
     
    Thanks for posting back Sergius, that's good news.
     
  11. horosho

    horosho New Pleskian

    22
    73%
    Joined:
    Apr 5, 2004
    Messages:
    21
    Likes Received:
    0
    Re: Re: Issue with SmarterMail & SmarterStats Setup

    Has anybody confirmed this? Is anybody running SmarterMail 4/Plesk 8.1?
    Thanks!
     
  12. brandonp

    brandonp Guest

    0
     
    SmarterMail 4 Works Great

    I can confirm this. SmarterMail 4 does work with Plesk 8.1. I reinstalled the SmarterMail package and everything worked great.

    This is a brand new server, I didn't have any existing domains or accounts on it, so it was easy.

    Not sure what caused my initial problem.

    Brandon Petersen
     
  13. PSFServers

    PSFServers Guest

    0
     
    Re: Re: Re: Issue with SmarterMail & SmarterStats Setup

    The SmarterMail API nas not changed between versions, and we have it working fine as well on multiple boxes.

    These are clean installs, and not upgrades.
     
  14. horosho

    horosho New Pleskian

    22
    73%
    Joined:
    Apr 5, 2004
    Messages:
    21
    Likes Received:
    0
    Thank you both! I'm going to upgrade and see what happens, I'll post here if I have problems!
     
  15. nettproffen

    nettproffen Guest

    0
     
    Hi -

    Do you run SmarterMail on own IP, or just the default?

    Bjørn.
     
  16. brandonp

    brandonp Guest

    0
     
    I use SmarterMail in a Shared Hosting situation, with several domains at the same IP Address. Each domain uses SmarterMail.

    Hope that helps,

    Brandon Petersen
     
  17. nettproffen

    nettproffen Guest

    0
     
    Yes - ok.

    I guess you use default IP (ServerIP) for SmarterMail. No other Ip?
    Are you running SMarterMail in IIS?

    Bjørn.
     
  18. brandonp

    brandonp Guest

    0
     
    Yes, SmarterMail uses the default IP for all the domains on the server.

    I am using SmarterMail on IIS.

    Brandon Petersen
     
  19. biscotti

    biscotti Guest

    0
     
    Brandon,

    I have a similar setup like yours with SmarterMail configured in IIS. I notice though that when a Plesk domain client is logged into the control panel and clicks on the WebMail icon from within Plesk, it tries to open webmail on port 9998. Are you having the same problem? If so, have you found a way to change the URL to not include that tcp port? Just going to webmail.domain.com in a browser works fine of course though.

    Scott
     
Loading...