1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Lines inserted in incoming email headers

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by davorg, Dec 23, 2008.

  1. davorg

    davorg Basic Pleskian

    24
     
    Joined:
    Aug 7, 2005
    Messages:
    33
    Likes Received:
    0
    I have a server running Centos 5.2 and I upgraded from Plesk 8.6.0 to 9.0.0 a couple of days ago. Since then I've had a big problem with my incoming email. Most (and not all, which is also very strange) of the incoming mails have a line inserted in their headers. For example, I see mail that looks like this:

    Received: (qmail 32766 invoked by uid 110); 23 Dec 2008 09:36:59 +0000
    Delivered-To: 4-dave@sowman.org
    Received: (qmail 32761 invoked from network); 23 Dec 2008 09:36:59 +0000
    
    Received: from unknown (HELO gabriel) (91.123.14.210)
    by tara.mag-sol.com with SMTP; 23 Dec 2008 09:36:57 +0000

    See the unprintable character on the fourth line. When the mail is viewed in vim it shows up as ^A^M.

    I think those lines are the ones that are added by preline,. But I don't think I'm calling preline anywhere in my mail processing chain.

    I'm pretty sure I have a standard plesk/qmail installation. I use procmail to filter my mail, but I've turned that whilst I'm investigating this. I've also turned off spamassassin in order to simplify the investigation. My .qmail file looks like this:

    | true
    | /usr/bin/deliverquota ./Maildir

    The only potential complexity here is that I have a number of other domains on this server and in many cases, they redirect mail to one central mailbox. So they have .qmail files which look like this:

    | true
    &dave@mag-sol.com

    I'm currently investigating whether their is any connection between the redirected mail and the added header lines, but currently I can't see any.

    Has anyone else seen this? Any advice would be much appreciated. Let me know if you need any more details.

    Cheers,

    Dave...

    p.s. I don't know if this helps or not, but it looks like the naming convention for email has changed too. Previously, each email had a name like

    1228936686.7226_0.tara.mag-sol.com:2,RS

    Now they look like:

    1230028621.M767561P4747V0000000000000307I0000E502.tara.mag-sol.com,S=10171:2,ST
     
  2. Brujo

    Brujo Regular Pleskian

    28
    57%
    Joined:
    Mar 4, 2006
    Messages:
    278
    Likes Received:
    2
    Location:
    Germany
  3. davorg

    davorg Basic Pleskian

    24
     
    Joined:
    Aug 7, 2005
    Messages:
    33
    Likes Received:
    0
    Great. That seems to have fixed it. Thanks for your help.

    Dave...
     
  4. Brujo

    Brujo Regular Pleskian

    28
    57%
    Joined:
    Mar 4, 2006
    Messages:
    278
    Likes Received:
    2
    Location:
    Germany
    hopefully this was your only issue with Plesk9

    Brujo
     
  5. davorg

    davorg Basic Pleskian

    24
     
    Joined:
    Aug 7, 2005
    Messages:
    33
    Likes Received:
    0
    It's certainly the only problem I've found so far. Everything else seems to be working well.

    Will that version of spf be pushed out in an update soon?

    Thanks for your help,

    Dave...
     
Loading...