1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Mail problem: courier conf points to "poppasswd" instead of passwd.db

Discussion in 'Plesk for Linux - 8.x and Older' started by vitof, Jan 7, 2010.

  1. vitof

    vitof Guest

    0
     
    Hi I've a Plesk 8.6.0,
    I read all of discussions about Qmail + Courier and so on.

    The problem is this: i can send emails but it's impossible to login via Pop3.
    The log result is:
    IMAP connect from @ [168.144.108.144]checkmailpasswd: FAILED: webmaster@mydomain - no such user from @ [168.144.108.144]ERR: LOGIN FAILED, ip=[168.144.108.144]
    ----

    Now the facts!

    In the file /etc/courier-imap/imapd
    ...
    MAILDIRPATH=Maildir
    AUTHMODULES="authpsa"
    MAILPASSWD="/var/qmail/users/poppasswd"

    in /etc/courier-imap/imapd
    ...
    POP3DHOSTNAME=localhost.localdomain
    AUTHMODULES="authpsa"
    MAILPASSWD="/var/qmail/users/poppasswd"

    The poppasswd IS EMPTY! While all of the email data (username, password and so on) configured via ControlPanel are stored correctly in
    /var/lib/plesk/mail/auth/passwd.db

    I tryed manual modification on pop3d and imapd conf file setting the path of passwd.db, restart the relative services but with no positive result :(

    How can I solve this problem?? Argh :(
    Vito
     
  2. lvaroR

    lvaroR Guest

    0
     
    I have a similar problem, but I don't find a solution.

    1) ---

    grep -R poppasswd /etc/courier-imap/
    /etc/courier-imap/imapd-ssl:MAILPASSWD="/var/qmail/users/poppasswd"
    /etc/courier-imap/pop3d-ssl.dist:MAILPASSWD="/var/qmail/users/poppasswd"
    /etc/courier-imap/imapd.dist:MAILPASSWD="/var/qmail/users/poppasswd"
    /etc/courier-imap/pop3d-ssl:MAILPASSWD="/var/qmail/users/poppasswd"
    /etc/courier-imap/pop3d.dist:MAILPASSWD="/var/qmail/users/poppasswd"
    /etc/courier-imap/pop3d:MAILPASSWD="/var/qmail/users/poppasswd"
    /etc/courier-imap/imapd:MAILPASSWD="/var/qmail/users/poppasswd"
    /etc/courier-imap/imapd-ssl.dist:MAILPASSWD="/var/qmail/users/poppasswd"

    2) ---

    ls -l /var/qmail/users/poppasswd
    ls: /var/qmail/users/poppasswd: No such file or directory

    3) ---

    ls -l /var/lib/plesk/mail/auth/passwd.db
    -rw------- 1 root root 19456 Sep 25 16:56 /var/lib/plesk/mail/auth/passwd.db

    4) ---

    telnet localhost 143
    Trying 127.0.0.1...
    Connected to localhost.localdomain (127.0.0.1).
    Escape character is '^]'.
    * OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE ACL ACL2=UNION STARTTLS] Courier-IMAP ready. Copyright 1998-2004 Double Precision, Inc. See COPYING for distribution information.
    01 login teste@transglobal.pt password
    Connection closed by foreign host.
     
Loading...