1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Mail rejected

Discussion in 'Plesk for Linux - 8.x and Older' started by CiViX, Dec 20, 2004.

  1. CiViX

    CiViX Guest

    0
     
    I have a couple of domains on my server that use an external mailserver, and therefore I have disabled mail on these domains. This worked fine before, but after I activated reject (using PLESK 7.5.1) on "mail to nonexistent users", the domains again try to accept mails for the domain and give me an errormessage instead of forwarding the mails to the external mailserver. If I switch back to bounce they behave correctly.

    This must be a bug? If mail is disabled for the domain, they should forward the mail to the external mailserver, not bounce/reject/accept or anything...?
     
  2. rtwick

    rtwick Basic Pleskian

    23
     
    Joined:
    Nov 1, 2002
    Messages:
    33
    Likes Received:
    0
    How did you disable mail on these servers?
    Did you setup the external mailserver as a backup mail server for the domains?

    To me it seems you have setup the external server as a backup mailserver and the plesk server as primary mailserver.
    The bounce feature on plesk, acts like receive all mails then try to deliver, if fail bounce. However, the new reject feature works like check for usr on the same box, if not reject.
    Now, when you setup plesk server to bounce, since it accepted the mail, sending MTA also sends the mail to the backup server. However, in the second case, since your primary server rejected it right at smtp level, sending server doesn't even try to cotact the secondary server and so no mail is delivered.

    I think the problem lies with the way its misconfigurated.
    If you do not want to receive mail for the domains at all at your plesk server, then you should remove the MX entries for these domains that point to the plesk server and make the external mail server as the primary server.

    HTH
    -R'twick
     
  3. CiViX

    CiViX Guest

    0
     
    I am not hosting either DNS or mail for the domains, so I have disabled Mail and DNS in PLESK. The smtp-server should therefore find the correct MX from the authoritative DNS-server, and deliver the mail there. But instead it acts as if it itself is MX for the domain and rejects the mail beacuse the user doesn't exist.

    I do not think I have misconfigured anything beacuse I am not hosting DNS/Mail for these domains. And because of this I can not understand why the server cares which setting I have for "Mail to nonexistent user". It seems that as soon as I use "reject" the server doesn't lookup correct MX from DNS anymore and just assumes it itself is the primary MX for the domain...

    I'm sorry if I am explaining myself badly, but I hope you understand the problem...
     
  4. rtwick

    rtwick Basic Pleskian

    23
     
    Joined:
    Nov 1, 2002
    Messages:
    33
    Likes Received:
    0
    Have you checked DNS settings for the domain under plesk and made sure there's no MX entry?
    from a linux shell run dig MX domain and see what address it is returning and from which DNS server it's getting this information and then rectify (or contact the admin to rectify) the MX pointer on that dns server.

    -R'twick
     
  5. marcbote

    marcbote Guest

    0
     
    Dear Civix:

    Be aware with the new function reject, these function verify if internal user exists and you don't wan't these, change to deliver message with the phrase "the user no....." and it will works again if all works before the upgrade.

    These new function it's fantastic but only works for internal users, and if you had enabled these for these 2 domains, the system verify the to: before accepting the mail, it's not important if you have or not a smtp-route or if the mail it's a valid rcpthost.

    Best Regards

    Marc Bote
     
Loading...