1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice

main site is now passowrd protected???

Discussion in 'Plesk for Windows - 8.x and Older' started by ssathre, Sep 10, 2005.

  1. ssathre

    ssathre Guest

    0
     
    Hello,

    I have plesk for windows 7.5.4 running on windows 2003 standard.

    I reset the ftp password for my site. Now i find that any time someone tries to access my website they are prompted to enter a username and password to gain access. I found out that when i enter my ftp username and password this allows me to view my site.

    Two other of our clients have had this same issue happen with their sites as well.

    1. Has anyone ran across this issue?

    2. Does anyone know how to get rid of the password protection?

    3. Better yet does anyone know how to fix this from happening in the future?

    Thanks in advance
     
  2. ssathre

    ssathre Guest

    0
     
    update:

    I found a similar post regarding this issue.

    1. tried renaming the site. This worked for about 2 hours then the site locked itself down again. mysteriously....

    2. Downloaded and installed the hot fix that is supposed to fix this issue. Rebooted the server. no luck.

    3. tried renaming the site and naming the site back again. didn't work.

    4. tried changing the password and user name again, no luck.

    Any help or insight on this matter would be greatly appreciated.

    thanks in advance!

    Steve
     
  3. ssathre

    ssathre Guest

    0
     
    TOPPED/

    Still having this issue with several domains. Tried every fix that I have searched for in this for in this forum. no luck.

    Any help, please???
     
  4. OlegB

    OlegB Guest

    0
     
  5. ssathre

    ssathre Guest

    0
     
    Actually,

    Tried that already... didn't work

    Is there something i missed in this process, i followed the instructions. in one of the threads it mentions a srvmng.exe command and reconfiguring the domains one by one but when i tried the command it said that no such file or command existed.

    Still lost and out of luck ,help please.


    thanks.
     
  6. littlefrog

    littlefrog Regular Pleskian

    25
     
    Joined:
    Jul 30, 2008
    Messages:
    176
    Likes Received:
    0
    Fix

    to fix you must have access to remote desktop

    1) Sign in
    2) Open IIS
    a) Click Start
    b) Control Panel
    c) Administration Tools
    d) Internet Information Services (IIS) Manager
    3) Right click on domain name from list
    4) Click Properties
    5) Click "Directory Security"
    6) Click Edit under Authentication and access control
    7) In the popup that opens click
    a) Browse
    b) Advanced
    c) Find Now
    8) In the list that loads the look for the user that you have in FTP but with the prefix IUSR_ so if the user is fred then in this list it will be IUSR_fred
    9) Double Click on user
    10) Click OK
    11) Click OK
    12) Click OK
    13) Done!

    Hope that helps when this process doesn't work I also sometimes in conjuction do doing this disable the domain and then re-enable it. And then if that doesn't work then i follow these steps.

    Message me if this helped you.

    TIA
     
  7. ssathre

    ssathre Guest

    0
     
    No luck... I am at a loss.

    I don't know what to try next. I have done everything short of deleting the domains and having the clients start over. Which is not a good option.

    Thanks for replying I was really hoping that you were on to something.

    Thanks,

    Steve
     
  8. littlefrog

    littlefrog Regular Pleskian

    25
     
    Joined:
    Jul 30, 2008
    Messages:
    176
    Likes Received:
    0
    well this happens to me all the time.

    In fact it happened to me again which made me think to check back here.

    The directory security option did not work for me the first time so i am trying to disable the domain and then re-enable it.

    This is after re-naming the user for FTP access.

    By any chance you didn't set up any virtual folders in IIS did you?

    If you try to FTP to the domain what error message do you get.

    I get "Home folder not accessable"

    Disabling the domain and then re-enabling it does not work either.

    The user / pass window still comes up.
    When I enter FTP info it comes up.

    Trying the directory security option again.
    Did not work.

    I then disabled anonymous access clicked apply and then enabled it again.

    I then entered in the password into the for right under the username and it now works.

    So try this.

    1) Sign in
    2) Open IIS
    a) Click Start
    b) Control Panel
    c) Administration Tools
    d) Internet Information Services (IIS) Manager
    3) Right click on domain name from list
    4) Click Properties
    5) Click "Directory Security"
    6) Click Edit under Authentication and access control
    7) Enter correct FTP password in the password box

    it will ask you to confirm the password.

    Another window may popup asking you about applying to other folders in that dir. Click yes.

    Let me know if that works.
     
  9. sallyanne

    sallyanne Guest

    0
     
    I have exactly the same problem, but when I try and install the hotfix, the installation fails and I receive the following error:

    Product: Plesk 7.5.4 for Microsoft Windows -- Error 1721. There is a problem with this Windows Installer package. A program required for this install to complete could not be run. Contact your support personnel or package vendor. Action: Intalling_MailEnable, location: C:\WINDOWS\Installer\Plesk\050711.14\MailEnableStandard.exe, command: /s

    Does anyone have any ideas on what I can do next?

    Thanks, Sallyanne.
     
  10. littlefrog

    littlefrog Regular Pleskian

    25
     
    Joined:
    Jul 30, 2008
    Messages:
    176
    Likes Received:
    0
    it didn't work for me either.

    Did you try the remote desktop options i suggested in IIS
     
  11. sallyanne

    sallyanne Guest

    0
     
    Yes, but this also did not help.
     
  12. PaulC

    PaulC Regular Pleskian

    24
    57%
    Joined:
    Aug 5, 2001
    Messages:
    192
    Likes Received:
    0
    Reset the FTP password to something different, this will resync them and should fix the problem.
     
  13. eara01

    eara01 Guest

    0
     
    I had (have) this same problem.

    The 2tonecafe solution worked for me...none of the other solutions did the job.
    I hope the hot fix prevents this problem from occurring on new domains created.
     
  14. ukhost4u

    ukhost4u New Pleskian

    22
    23%
    Joined:
    Feb 15, 2002
    Messages:
    8
    Likes Received:
    0
    This is an easy issue to fix when Plesk tells you how:

    Run this from Remote Desktop -> Command Prompt.

    C:\Program Files\SWsoft\Plesk\admin\bin>websrvmng --remove-vhost --vhost-name=<domain>

    and

    C:\Program Files\SWsoft\Plesk\admin\bin>websrvmng --install-vhost --vhost-name=<domain>

    This has fixed this issue for me 99% of the time.

    Paul Hughes
    UKHost4u.com
     
  15. littlefrog

    littlefrog Regular Pleskian

    25
     
    Joined:
    Jul 30, 2008
    Messages:
    176
    Likes Received:
    0
    Except for the fact that it wipes all data that was on the webiste this solution works...

    GRRRRR
     
  16. PaulC

    PaulC Regular Pleskian

    24
    57%
    Joined:
    Aug 5, 2001
    Messages:
    192
    Likes Received:
    0
    Have you guys tried resetting the FTP password via Plesk to something completely different as I suggested? This has fixed the problem for us every time.
     
  17. Antony

    Antony Guest

    0
     
    The correct way to repair such an error is:
    cd %plesk_bin%
    websrvmng --remove-vhost --vhost-name=<issued.domain>
    websrvmng --reconfigure-vhost --vhost-name=<issued.domain>

    THIS will repair your domain without any loss of data.

    BTW there is a hotfix for 7.5.4 on SWSoft website. It fixes the issue with login/password requests too.
     
Loading...