1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Mass Exodus from RH9/PSA7.0.x to FC2/PSA7.5.4

Discussion in 'Plesk for Linux - 8.x and Older' started by toygeek, Sep 13, 2005.

  1. toygeek

    toygeek Guest

    0
     
    I have 30 servers to upgrade, and I've been given until 12/1/5 to do it. We're a hosting shop with 31 Plesk servers. I've already done one migration, and it was anything but smooth. We got it done though. We're building mirror servers and migrating via PSA's migration tool, and then putting the new server in place of the old one. Before we do the final migration from old to new, we rsync the /home/ /var/lib/mysql/ and /var/qmail/mailnames/* directory (yes we run everything out of /home/ instead of Plesks default setup)

    Today the server I'm doing seems to work, I've got both servers on the same ethernet switch and so there's no possiblity of a connectivity issue. Its rather rediculous. The migration manager tars and gzips the data on the source server correctly, but when it comes time to copy the data to the destination server that I'm migrating to, it gives this error:

    Unable to create a description for the migrated objects:
    Error during dump retrieval
    Lost connection with the remote host

    I opened a trouble ticket but haven't heard back yet. I'm hoping one of you will have a clue what this means. I looked through the migration log and there were no errors, oddly enough. I'd paste it in but I have no copy of the log, unfortunately.

    So, if anyone has any guidance for this project, I'd appreciate it. The next couple of months are going to pretty rough, I imagine.

    Thanks in advance!
     
  2. toygeek

    toygeek Guest

    0
     
    Here's the last line of the log:
    [17:33:44 13.09.2005 | pid 20376]:Launchpad | Finished (pid 20376)
     
  3. baddogg99

    baddogg99 Guest

    0
     
    Me too.

    I have the same problem.

    Migration manager worked fine in 7.5.3 (in fact, better than fine, suprisingly smooth), until I did the 7.5.4 update. Now I get that same error message.

    Nothing has changed to my knowledge... just the update.

    B
     
  4. Cranky

    Cranky Guest

    0
     
    Ensure you're running the latest build of PMM on the destination server. It may also be worth upgrading the RH9 servers to Plesk 7.5.4 first.
     
  5. Fever

    Fever Guest

    0
     
    7.5.4 and RH9

    Hello all,
    I tried to update one of my RH9 servers from Plesk 7.1.7 to 7.5.4 and it barfed in a big way. In the control panel it says it is still 7.1.7 but when you go to the updater the 7.5.4 section says my base package is up to date and has a date of Jan 18, 2038. Trying to run the update manually gives me an error that the package is already installed. I was told by the data center that since RH9 has been EOL'd for some time that not all the packages are available for 7.5.4. and that I should consider upgrading to RHE. I do have a backup (from before the failed upgrade, but it is useless on a 7.5.4 box that I have because you can't restore from a 7.1.7 to a 7.5.4. I was hoping that maybe PMM would be the saving factor for me to move 72 sites to an upgraded box, but I get the same error as the above posts. none of the solutions I found on this forum worked. The migration.log had the following in it:
    [17:19:00 25.09.2005 | pid 11126]:1; readResponse|handle 1|(13) read 674 bytes
    [17:19:00 25.09.2005 | pid 11126]:1; readResponse|handle 1|(13) data[DBD::mysql::st execute failed: You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'ORDER BY c.id' at line 1 at /migration/c80f6409ddfded68a782d1a6fe948388/PleskX.old line 1286.
    Error: exesute sql: SELECT c.id FROM certificates c, Repository r WHERE c.id=r.component_id AND r.rep_id= ORDER BY c.id
    You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'ORDER BY c.id' at line 1
    Can't call method "rows" without a package or object reference at /migration/c80f6409ddfded68a782d1a6fe948388/PleskX.old line 1184.


    I am kinda backed into a corner....all 72 sites are up but won't be if I dink with the RH9 install of 7.5.4

    Fever
     
  6. Cranky

    Cranky Guest

    0
     
    Plesk 7.5.4 works fine on rh9, they're talking rubbish. You want to forget about the migration at the moment and focus on upgrading Plesk to 7.5.4 correctly. What did the upgrade log say in /tmp? Are all Plesk packages installed? (rpm -qa | grep psa)
     
  7. Fever

    Fever Guest

    0
     
    These are the installed packages:

    psa-locale-base-en-US-7.5.4-rh9.build75050824.12
    psa-qmail-1.03-rh9.build75050824.12
    psa-courier-imap-add-7.5.4-rh9.build75050902.17
    psa-agent-1.3.5-75050902.09
    psa-locale-base-en-7.1.7-rh9.build71050228.12
    psa-pre-keyupdate-7.5.3-rh9.build75050506.13
    psa-boost-1.32.0-6
    psa-key-7.5-rh9.build75050824.12
    psa-7.5.4-rh9.build75050824.12
    psa-imp-4.0.3-rh9.build75050824.12
    psa-proftpd-xinetd-1.2.10-rh9.build75050824.12
    psa-proftpd-1.2.10-rh9.build75050824.12
    frontpage-5.0-72psa.rh9
    perl-MLDBM-2.01-61psa
    mod_webapp-4.1.29-41psa.rh9
    psa-qmail-rblsmtpd-0.70-rh9.build75050824.12
    psa-api-rpc-7.5.4-rh9.build75050902.09
    psa-bu-7.5.4-rh9.build75050824.12
    psa-api-cli-7.5.4-rh9.build75050902.09
    perl-Font-AFM-1.18-61psa
    perl-HTML-Format-1.23-51psa
    psa-api-rpc-protocol-7.5.4-rh9.build75050902.09
    perl-HTML-Tree-3.16-60psa
    psa-hotfix-7.5.3-rh9.build75050607.13
    psa-pre-keyupdate-7.5.4-rh9.build75050824.12
    psa-api-common-7.5.4-rh9.build75050902.09
    psa-horde-3.0.5-rh9.build75050824.12
    psa-logrotate-3.7-rh9.build75050824.12
    psa-autoinstaller-2.0.0-rh9.build75050906.11
    perl-FreezeThaw-0.43-61psa
    perl-MLDBM-Sync-0.30-61psa
    psa-tomcat-configurator-7.5.4-rh9.build75050824.12
    psa-api-rpc-doc-7.5.4-rh9.build75050902.09

    Yes, I see the base is still 7.1.7 but this is the last of the update log:

    Removing glibc-2.3.2-11.9.i386.rpm as designed for older than i686 architecture
    Removing kernel-2.4.20-31.9.i586.rpm as designed for older than i686 architecture
    Removing kernel-2.4.20-31.9.i386.rpm as designed for older than i686 architecture
    Removing kernel-2.4.20-31.9.athlon.rpm as designed for older than i686 architecture
    Removing openssl-0.9.7a-20.2.i386.rpm as designed for older than i686 architecture
    Checking package /PSA_7.5.4/rpm_RedHat_9/opt/java/mod_webapp-4.1.29-41psa.rh9.i586.rpm...not installed, but older package fou
    nd
    Checking package /PSA_7.5.4/rpm_RedHat_9/opt/java/psa-tomcat-configurator-7.5.4-rh9.build75050824.12.noarch.rpm...not install
    ed, but older package found
    Checking package /PSA_7.5.4/rpm_RedHat_9/opt/mail/psa-qmail-rblsmtpd-0.70-rh9.build75050824.12.i586.rpm...not installed, but
    older package found

    After checking for previous installation following packages are sheduled for installing:
    package mod_webapp (file /PSA_7.5.4/rpm_RedHat_9/opt/java/mod_webapp-4.1.29-41psa.rh9.i586.rpm)
    package psa-tomcat-configurator (file /PSA_7.5.4/rpm_RedHat_9/opt/java/psa-tomcat-configurator-7.5.4-rh9.build75050824.12.noa
    rch.rpm)
    package psa-qmail-rblsmtpd (file /PSA_7.5.4/rpm_RedHat_9/opt/mail/psa-qmail-rblsmtpd-0.70-rh9.build75050824.12.i586.rpm)
    ----

    Retrieving Plesk files
    ---
    No key found in the response
    Server response: License key PLSK.000xxxxx.000x is up-to-date

    Preparing for packages installation...
    ----- begin of output -----
    Installing /PSA_7.5.4/rpm_RedHat_9/opt/java/mod_webapp-4.1.29-41psa.rh9.i586.rpm
    Installing /PSA_7.5.4/rpm_RedHat_9/opt/java/psa-tomcat-configurator-7.5.4-rh9.build75050824.12.noarch.rpm
    Installing /PSA_7.5.4/rpm_RedHat_9/opt/mail/psa-qmail-rblsmtpd-0.70-rh9.build75050824.12.i586.rpm
    ===> Updating /etc/psa/psa.conf...


    ===> Reading /etc/tomcat4/tomcat4.conf ...
    ===> Updating /etc/psa/psa.conf...
    ===> Reading /etc/psa/psa.conf ...



    ----- end of output -----
    packages installed successfully.
    ===> Autoinstaller: stopped logging at Sun Sep 18 17:08:29 2005

    _____________________________
    Fever
     
  8. Fever

    Fever Guest

    0
     
    That bad, huh?
     
  9. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    It may sound silly, but have you tried rebooting the system? I had to do that on 2 of my boxes to make the upgrade show.
     
  10. Fever

    Fever Guest

    0
     
    heh

    As usual, when I told it to reboot, it went away and required a DC tech to go power it off and back on again. Plesk was still at 7.1.7...but interestingly enough, the updater now has the proper dates on the packages and says there is an update available. I won't be clicking on the update button, though, as this is what started the whole mess. Something will probably need to be done through the shell.
     
  11. Fever

    Fever Guest

    0
     
    Ok, I re-ran the auto installer and it says everything installed correctly. Plesk control panel says it is 7.1.7. The updater says the base packages for 7.5.4 are up to date.
    The packages installed are:

    [root@serv1 root]# rpm -qa | grep psa
    psa-locale-base-en-US-7.5.4-rh9.build75050824.12
    psa-qmail-1.03-rh9.build75050824.12
    psa-courier-imap-add-7.5.4-rh9.build75050902.17
    psa-agent-1.3.5-75050902.09
    psa-locale-base-en-7.1.7-rh9.build71050228.12
    psa-pre-keyupdate-7.5.3-rh9.build75050506.13
    psa-boost-1.32.0-6
    psa-key-7.5-rh9.build75050824.12
    psa-7.5.4-rh9.build75050824.12
    psa-imp-4.0.3-rh9.build75050824.12
    psa-proftpd-xinetd-1.2.10-rh9.build75050824.12
    psa-proftpd-1.2.10-rh9.build75050824.12
    frontpage-5.0-72psa.rh9
    perl-MLDBM-2.01-61psa
    mod_webapp-4.1.29-41psa.rh9
    psa-qmail-rblsmtpd-0.70-rh9.build75050824.12
    psa-api-rpc-7.5.4-rh9.build75050902.09
    psa-api-cli-7.5.4-rh9.build75050902.09
    perl-Font-AFM-1.18-61psa
    perl-HTML-Format-1.23-51psa
    psa-api-rpc-protocol-7.5.4-rh9.build75050902.09
    psa-hotfix-7.5.4-rh9.build75050926.17
    psa-bu-7.5.4-rh9.build75050926.17
    psa-pre-keyupdate-7.5.4-rh9.build75050824.12
    psa-api-common-7.5.4-rh9.build75050902.09
    psa-horde-3.0.5-rh9.build75050824.12
    psa-logrotate-3.7-rh9.build75050824.12
    psa-autoinstaller-2.0.0-rh9.build75050906.11
    perl-FreezeThaw-0.43-61psa
    perl-MLDBM-Sync-0.30-61psa
    psa-tomcat-configurator-7.5.4-rh9.build75050824.12
    psa-api-rpc-doc-7.5.4-rh9.build75050902.09

    What the hey??



    Fever
     
  12. pcinews

    pcinews Guest

    0
     
    Your Not Alone

    Ok... So this is exactly the senario that I am encountering when trying to upgrade from 7.1.7 to 7.5.4 on my RHE v3 Box... It caused an error with Tomcat toggled in the installation.. so I removed it and tried again and it reinstalled successfully... It came up to a blnk screen origionally so I had to reboot.... Now when I log into Plesk It says I'm running 7.1.7 but in the updater it appears that i'm running up to date packages of 7.5.4 (except Tomcat) there is nothing else left to upgrade....

    The panel looks a little diffrent and even the HORDE interface looks as though it has some vast improvments... So I know something worked...

    What gives ? Anyone got a clue ......

    ------------------------------------------------------------------------------

    rpm -qa | grep psa

    psacct-6.3.2-27
    mod_webapp-4.1.29-24psa.rhel3
    psa-courier-imap-add-7.5.4-rhel3.build75050902.17
    psa-hotfix-7.5.4-rhel3.build75050926.17
    psa-migration-manager-7.5.4-rhel3.build75050902.09
    psa-horde-3.0.5-rhel3.build75050824.12
    perl-MLDBM-Sync-0.30-61psa
    psa-api-rpc-protocol-7.5.4-rhel3.build75050902.09
    psa-turba-2.0.3-rhel3.build75050926.17
    psa-manual-custom-skin-guide-7.5.4-rhel3.build75050824.12

    psa-locale-base-en-7.1.7-rhel3.build71050228.12
    psa-7.1.7-rhel3.build71050228.12

    perl-HTML-Tree-3.16-44psa
    psa-qmail-1.03-rhel3.build75050824.12
    psa-pre-keyupdate-7.5.4-rhel3.build75050824.12
    psa-logrotate-3.7-rhel3.build75050824.12
    psa-boost-1.32.0-6
    frontpage-5.0-72psa.rhel3
    perl-Font-AFM-1.18-61psa
    perl-HTML-Format-1.23-51psa
    psa-spamassassin-7.5.4-rhel3.build75050927.15
    drweb-4.32.2-rh7_psa
    psa-migration-manager-7.5.3-rhel3.build75050506.18

    psa-locale-base-en-US-7.5.4-rhel3.build75050824.12

    psa-agent-1.3.5-75050902.09
    psa-api-common-7.5.4-rhel3.build75050902.09
    psa-api-rpc-7.5.4-rhel3.build75050902.09

    psa-7.5.4-rhel3.build75050824.12

    psa-imp-4.0.3-rhel3.build75050824.12
    perl-FreezeThaw-0.43-61psa
    psa-api-rpc-doc-7.5.4-rhel3.build75050902.09
    psa-autoinstaller-2.0.0-rhel3.build75050906.11
    psa-firewall-1.0.1-rhel3.build75050824.12
    psa-kronolith-2.0.3-rhel3.build75050824.12
    psa-ingo-1.0.1-rhel3.build75050824.12
    psa-passwd-3.0-rhel3.build75050824.12
    psa-tomcat-configurator-7.1.7-rhel3.build71050228.12
    psa-proftpd-xinetd-1.2.10-rhel3.build75050824.12
    psa-key-7.5-rhel3.build75050824.12
    psa-bu-7.5.4-rhel3.build75050926.17
    psa-api-cli-7.5.4-rhel3.build75050902.09
    psa-proftpd-1.2.10-rhel3.build75050824.12
    perl-MLDBM-2.01-61psa
    psa-qmail-rblsmtpd-0.70-rhel3.build75050824.12
    psa-fileserver-1.0.0-rhel3.build75050824.12
    psa-mnemo-2.0.1-rhel3.build75050824.12
     
  13. jamesyeeoc

    jamesyeeoc Guest

    0
     
    In Fever's post, he lists
    I am wondering if having 2 versions of the same package is causing this problem...?
     
  14. pcinews

    pcinews Guest

    0
     
    I think that you might be on to something here.... it appears that my installation has the same results as above.... more searching, i'm in a desperate need to resolve this soon....

    do you think that if I run (rpm -e) on the 7.1.7 packages that it might just work magix... or is this going to cause even more problems
     
  15. Fever

    Fever Guest

    0
     
    Life at Last

    Actually I DID get it fixed, but it was beyond my meager skills. I hired it done (thanks, Cranky) and it was a pretty awful mess. I believe it took way longer to fix than we thought.

    It seems funny that the very update script that was supposed to handle it for you ends up making it worse than you ever could on your own.



    Fever
     
  16. Cranky

    Cranky Guest

    0
     
    Re: Life at Last

    NP. I can't actually remember what the problem was now since I've done so many recently, sorry.
     
  17. Cranky

    Cranky Guest

    0
     
    NO! That will cause you a lot of problems, you don't want to be doing that. I replied to your new thread, best keeping it in there I think.
     
Loading...