My.cnf configuration | Plesk Forum

My.cnf configuration

Discussion in 'Plesk for Linux - 8.x and Older' started by corman420, Sep 12, 2007.

  1. corman420

    corman420 Guest

    0
     
    I have a linux serer running Plesk 8.2.

    I run a large vbulletin community and I am currently having some minor server issues.

    I am running a P4 2.8Ghz with 2GB of RAM.

    I am optimized Vbulletin to the max.

    Ny next step is to edit the my.cnf file. But when I found it in /etc/my.cnf, it only had very few entries.

    Current my.cnf looks like this
    Code:
    [mysqld]
    set-variable=local-infile=0
    datadir=/var/lib/mysql
    socket=/var/lib/mysql/mysql.sock
    set-variable=max_allowed_packet=32M
    # Default to using old password format for compatibility with mysql 3.x
    # clients (those using the mysqlclient10 compatibility package).
    old_passwords=
    
    [mysql.server]
    user=mysql
    basedir=/var/lib
    
    [mysqld_safe]
    err-log=/var/log/mysqld.log
    pid-file=/var/run/mysqld/mysqld.pid
    

    I searched the vbulleitn forums and found the following my.cnf file that I should use. As from what I have read, I am supposed to put "set-variable=" in front of each statement - correct?:
    Code:
    [mysqld]
    set-variable=local-infile=0
    datadir=/var/lib/mysql
    socket=/var/lib/mysql/mysql.sock
    set-variable=max_allowed_packet=32M
    # Default to using old password format for compatibility with mysql 3.x
    # clients (those using the mysqlclient10 compatibility package).
    old_passwords=1
    skip-innodb
    set-variable=max_connections=500
    set-variable=key_buffer=128M
    set-variable=myisam_sort_buffer_size=64M
    set-variable=join_buffer_size=1M
    set-variable=read_buffer_size=1M
    set-variable=sort_buffer_size=2M
    set-variable=table_cache=2000
    set-variable=thread_cache_size=128
    set-variable=wait_timeout=35
    set-variable=connect_timeout=10
    set-variable=tmp_table_size=64M
    set-variable=max_heap_table_size=64M
    set-variable=max_allowed_packet=64M
    set-variable=max_connect_errors=10
    set-variable=thread_concurrency=4
    set-variable=read_rnd_buffer_size=524288
    set-variable=bulk_insert_buffer_size=8M
    set-variable=query_cache_limit=4M
    set-variable=query_cache_size=64M
    set-variable=query_cache_type=1
    set-variable=query_prealloc_size=131072
    set-variable=query_alloc_block_size=65536
    set-variable=default-storage-engine=MyISAM
    
    [mysql.server]
    user=mysql
    basedir=/var/lib
    
    [mysqld_safe]
    nice = -5
    open_files_limit=8192
    err-log=/var/log/mysqld.log
    pid-file=/var/run/mysqld/mysqld.pid
    
    [mysqldump]
    quick
    max_allowed_packet=16M
    
    [myisamchk] 
    set-variable=key_buffer=64M 
    set-variable=sort_buffer=64M
    set-variable=read_buffer=16M
    set-variable=write_buffer=16M
    

    When I edit the my.cnf file, and reboot my server, it doesn't work - and Plesk control panel outputs the following message:
    Code:
    ERROR: PleskMainDBException
    MySQL query failed: Can't find file: 'misc.MYI' (errno: 2)
    
    0: /usr/local/psa/admin/plib/common_func.php3:216
    	db_query(string 'select param, val from misc')
    1: /usr/local/psa/admin/plib/common_func.php3:513
    	get_param(string 'mysql41_compatible')
    2: /usr/local/psa/admin/plib/common_func.php3:410
    	db_set_names()
    3: /usr/local/psa/admin/plib/common_func.php3:389
    	db_connect_real(string 'localhost', string 'admin', string '***********', string 'psa')
    4: /usr/local/psa/admin/plib/common_func.php3:369
    	db_connect()
    5: /usr/local/psa/admin/auto_prepend/auth.php3:87
    

    WhenI restore the old my.cnf, server works fine. I really need to get my my.cnbf file optimized for my server configuration. Any help would be greatly appricated and I can help with something else in return.

    Thanks-you so mucH!
     
  2. breun

    breun Golden Pleskian

    29
     
    Joined:
    Jun 28, 2005
    Messages:
    1,647
    Likes Received:
    0
    Plesk uses InnoDB tables, so 'skip-innodb' is indeed probably going to give you trouble. You might want to read up on what all these settings mean before just copying somebody else's config. If there was one optimal configuration then MySQL wouldn't have a configuration file.
     
  3. corman420

    corman420 Guest

    0
     
    I thought that's why I would use the forums? Isn't this getting help? It would take hours to search all of those individually - not to mention there are not very many Plesk resources on the net.

    This configuration wasn't just something I "found", it was produced during an optimization request from a vbulletin specialtist. I'm not a dumb-***, I know what I'm doing. They must have overlooked that one thing.

    I had already spent a few hours researching, so I figured I'd just make a post - sorry for "disturbing you" then....... I really thought his would of been the right place to look for info :| ?Confused?
     
Loading...