1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Named / Bind doesnt start

Discussion in 'Plesk for Linux - 8.x and Older' started by tamen, Oct 27, 2005.

  1. tamen

    tamen Guest

    0
     
    I have just installed Plesk 7.5.4 on Freebsd 5.4 The only problem I have is named not starting automatically. I have to SHH into the server and do a /usr/sbin/named -c /etc/named.conf -t /usr/local/psa/named/run-root/

    After named have been started I can manage domains, before it gives me and rndc error.

    Whether named is running or not, Plesk shows it to be running in "Serviec Management" clicking stop/reload have no effect. I dontget an error in plesk. If I clcik stop nothing happens, if I click restart I get a message in /var/log/messages: Event manager[1812]: Can't execute /usr/local/psa/admin/bin/modules/watchdog/stop-monit.php: Permission denied
    So I might be having a permission issue. How do I fix it?

    TIA, Nis.
     
  2. tamen

    tamen Guest

    0
     
    Alternativly, can I disable DNS altogether in Plesk? DNS is managed by a different computer anyway. The Plesk machine just serves the website and email.
     
  3. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    Logs are very helpful in determining problems. That being said, it would appear that Watchdog may be causing the problem. It is very buggy - uninstall it and see if that helps.
     
  4. tamen

    tamen Guest

    0
     
    I just removed Watchdog, no difference.
     
  5. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    What does the log tell you after you removed Watcgdog?
     
  6. tamen

    tamen Guest

    0
     
    Nothing really. Nothing is added to /var/log/messages when I try to stop/restart Bind.
     
  7. tamen

    tamen Guest

    0
     
    Named is still running, and havent been restarted.
     
  8. etan

    etan Guest

    0
     
    i had major problems with named on freebsd 5.4
    I opting to go with freebsd 5.3 instead, everything runs perfectly.
     
  9. tamen

    tamen Guest

    0
     
    Oh, well.
    Its not that big a problem anyway. I just need to restart named everytime i try yo change/update/create a new domain.
    Everything seems to run fine when named is not running as DNS is served by five other machines.
     
  10. DCoats

    DCoats Guest

    0
     
    Here are the specific's that I can tell

    PSA for some reason on FREEBSD 5.4 writes to /usr/local/psa/named/run-root/etc/named.conf while the actual named.conf that is in use by named is /usr/local/psa/named/run-root/etc/namedb/named.conf
    ...
    I have tried alot of different ways to solve/work around this issue, It would seem that a simple symlink from /usr/local/psa/named/run-root/etc/namedb/named.conf to /usr/local/psa/named/run-root/etc/named.conf would solve this issue, but when plesk writes a new domain to /usr/local/psa/named/run-root/etc/named.conf the symlink is overwritten by the actual file, therefore the rndc reload doesnt load the ..../etc/named.conf just written by psa it loads the ...../etc/namedb/named.conf that was already in use by named.

    In addition I have also tried linking the other way from ..../etc/named.conf to ...../etc/namedb/named.conf but in this case named will not start, named in a chroot dir will not start using a symlink as specified in /etc/rc.d/named.

    If we simply start named using /usr/sbin/named -c /etc/named.conf -t /usr/local/psa/named/run-root/ all is fine accept the fact that the plesk panel doesnt know that named is running. So you dont have the ability to stop/start/restart from plesk panel.

    So we let plesk start named itself which uses /etc/rc.d/named which in turn starts named using /usr/sbin/named -t /usr/local/psa/named/run-root/ therefore its using the namedb/named.conf

    The best way to fix this issue would simply be to tell psa to write to /usr/local/psa/named/run-root/etc/namedb/named.conf
    and stop writing to /usr/local/psa/named/run-root/etc/named.conf
    or to tell psa to start and stop named with -c /etc/named.conf option instead of using the default /etc/rc.d/named script which assumes named.conf is in /etc/namedb -someone please suggest how to do this or tell me another fix, please.

    Im now at the point that i have just cp /usr/local/psa/named/run-root/etc/named.conf /usr/lcoal/psa/named/run-root/etc/namedb/named.conf whenever a domain is added and rndc relaod.
     
  11. ShadowMan@

    ShadowMan@ Guest

    0
     
    Ah, I thought I was losing my mind, but it's just a double post! I posted this on your other thread as well:

    Check your psa.conf file (not sure where it's located on FreeBSD) for the following line:
    (this is taken from a RedHat Linux system, /etc/psa/psa.conf)

    This tells Plesk where the BIND root directory is, change it to where you would like Plesk to use for bind/named
     
Loading...