1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

"No migration agents found" error

Discussion in 'Plesk 9.x for Windows Issue, Fixes, How-To' started by jorfermo, Jan 13, 2010.

  1. jorfermo

    jorfermo Regular Pleskian

    26
     
    Joined:
    Jun 22, 2005
    Messages:
    102
    Likes Received:
    0
    Hi,

    I'm trying to migrate one server with migration manager and I'm getting this error:

    Before this the error it's:

    Source server is Windows 2003 + Plesk 9.3 and destination Windows 2008 R2 + Plesk 9.3

    Any help would be appreciated
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,242
    Location:
    Novosibirsk, Russia
    Look at this thread. I hope it will help.
     
  3. jorfermo

    jorfermo Regular Pleskian

    26
     
    Joined:
    Jun 22, 2005
    Messages:
    102
    Likes Received:
    0
    I had already seen that post. Unfortunately it didn't help.

    I have installed 9.3 version of migration manager in both hosts.

    This is what I'm getting in the log:
     
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,242
    Location:
    Novosibirsk, Russia
    I have updated already submitted request to developers with problem described by you. Let's wait their answer.
     
  5. jorfermo

    jorfermo Regular Pleskian

    26
     
    Joined:
    Jun 22, 2005
    Messages:
    102
    Likes Received:
    0
    Thanks Igor. I'll stay tuned.
     
  6. jorfermo

    jorfermo Regular Pleskian

    26
     
    Joined:
    Jun 22, 2005
    Messages:
    102
    Likes Received:
    0
    Any news on this issue?
     
  7. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,242
    Location:
    Novosibirsk, Russia
    Problem still under developer's investigation.
     
  8. TheProblemxx

    TheProblemxx Guest

    0
     
    Still no news.....?

    What´s happening on this problem?


    We are in dire need to have a server migrated and need a solution sooner than yesterday...

    What do we do - Igor?
     
  9. jorfermo

    jorfermo Regular Pleskian

    26
     
    Joined:
    Jun 22, 2005
    Messages:
    102
    Likes Received:
    0
    I had to open a support ticket.

    They changed some dlls in the source server. The ticket is still open cause it doesn't work very fine yet.

    I guess problem will be solved in next releases.
     
  10. TheProblemxx

    TheProblemxx Guest

    0
     
    Migrations 9.3 continued...

    Yes - but the problem is that they release such extremely important tools with obvious bugs in them - it was the same in some of the 8.xx releases...

    Furthemore they still use the obsolete PHP 4.4.7 and 5.2.6 versions in their latest 9.3 release - unfortunately it seems as if they are slowing down on their developers, so that even new releases are not really up-to-date on the developments in eg. PHP...

    Hopefully they will come with a very quick solution to this migration problem for Plesk 9.3 as it holds back any of Plesk buyers from migrating anything, causing clients to flee from Plesk owners.

    I hope to hear from Igor at Parallels or anybody else from Parallels very soon about a patch or new PM agent that actually works - we are really, really in problems right now beceuse we can´t migrate from an old server that is about to quit from this life..
     
  11. jorfermo

    jorfermo Regular Pleskian

    26
     
    Joined:
    Jun 22, 2005
    Messages:
    102
    Likes Received:
    0
    Yes... don't tell me. I'm also suffering day by day all those problems

    About php... we just update PHP version manually and it usually works without any flaws.
     
  12. TheProblemxx

    TheProblemxx Guest

    0
     
    Migrations 9.3 continued...

    Sure - but if You update PHP manually You will most likely run into many other problems at a time, as all Plesk interfaces are only validated to the version in the latest Plesk and if You Yourself has updated to a newer PHP than the one in the latest version You will be informed by Parallels that they do not support that version and any problem You might have is on Your own responsibility as You have done the PHP upgrade Yourself...

    Even a support ticket won´t help You then and You will have to downgrade to have it solved - not a good idea.



    The solution You talk about with the dlls are - as I have seen in this forum - when You migrate 9.2.x->9.3 - right?

    That is not my problem.


    I am trying to migrate a 9.3->9.3 with the latest Migration Agent and that is causing a lot of problems as we can´t even partially migrate..

    Still hoping for an ETA from Igor or other Parallels people very soon....
     
  13. jorfermo

    jorfermo Regular Pleskian

    26
     
    Joined:
    Jun 22, 2005
    Messages:
    102
    Likes Received:
    0
    I'm talking about the php used for clients, not the one that rules control panel. I've never had any problem upgrading it and support never told me anything about that. In fact, if I'm not mistaken there's an entry on the KB explaining you how to make this upgrade manually.

    I'm also migrating from 9.3 to 9.3 so the dlls that they changed are not available to download. That's why I said that they'd probably release a new versión with this thing patched.
     
  14. TheProblemxx

    TheProblemxx Guest

    0
     
    Migrations 9.3 continued...

    On each main release of Plesk there is a list saying which versions of eg. mailservers, ftp servers, PHP etc. that version supports.

    If You change to a newer version thatn what that version is listet to support, You are no eligble for support.


    We tried it some time ago, when we had upgraded MailEnable to the newest version at that time, because it had some security flaws - shortly after we ran into a mail related problem and Parallels very soon ruled out that they would do anything at all with the problem as they stated that the version of Plesk did not support that version of Mailenable.

    You could run into similar problems if Your clients suddenly suffers from strange PHP problems, as P won´t even look at it before You downgrade..
     
  15. TheProblemxx

    TheProblemxx Guest

    0
     
    Igor...?

    Igor - do You have any news or update on this problem...??
     
  16. Mydal

    Mydal Guest

    0
     
    Hi all,

    Wondering if there has been any progress on this issue. I am attempting to migrate from win2003 running plesk 9.3.0 to win2008 running plesk 9.3.0 and cant get the Plesk Migration Manager to connect.
     
  17. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,557
    Likes Received:
    1,242
    Location:
    Novosibirsk, Russia
  18. Mydal

    Mydal Guest

    0
     
    yes have tried that workaround.

    I now get this error in plesk:

    Error: pmm utility 'migration_handler' raised an exception. Error code is: 1
    See pmmcli.log to find out detailed information on this

    Here is the bottom section of the pmmcli.log file:

    == STDERR ====================

    Traceback (most recent call last):
    File "C:\Program Files\Parallels\Plesk\admin\share\pmmcli\pmmcli.py", line 1846, in main
    data_action_response, errcode_response, error_message = actions.get(sys.argv[1][2:])(parameters)
    File "C:\Program Files\Parallels\Plesk\admin\share\pmmcli\pmmcli.py", line 1750, in migration_get_objects_list
    return ActionRunner(MigrationGetObjectsListAction, migration_task_description, migration_session_id).doActivity()
    File "C:\Program Files\Parallels\Plesk\admin\share\pmmcli\pmmcli.py", line 75, in doActivity
    result = self.processor.doActivity()
    File "C:\Program Files\Parallels\Plesk\admin\share\pmmcli\pmmcli.py", line 1316, in doActivity
    return pmm_migration_handler.MigrationHandler.migrationGetObjectsList( self.__migration_session_id ,self.__agent_to_use.getValueOf_() )
    File "C:\Program Files\Parallels\Plesk\admin\share\pmmcli\pmm_migration_handler.py", line 201, in migrationGetObjectsList
    return MigrationHandler.callMigrationHandlerWithResponse('--migration-get-objects-list', session_id = migration_session_id, input_str = agent_to_use)
    File "C:\Program Files\Parallels\Plesk\admin\share\pmmcli\pmm_migration_handler.py", line 501, in callMigrationHandlerWithResponse
    raise PMMUtilityException('migration_handler', x)
    PMMUtilityException: was finished with exit code 1

    2144: 2010-02-09 13:10:56,614 INFO Outgoing packet:
    <?xml version="1.0" encoding="UTF-8"?>
    <response>
    <errcode>1000</errcode>
    <errmsg>pmm utility 'migration_handler' raised an exception. Error code is: 1
    See pmmcli.log to find out detailed information on this</errmsg>
    </response>
     
  19. JuanT

    JuanT Guest

    0
     
    Same problem here from 9.3 to 9.3

    No Migration Agents Found and it is running on both.
     
  20. Silence

    Silence Guest

    0
     
    HI There,

    we need this working asap!

    Thanks..
     
Loading...