1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Official support for PHP 5.2.6 or higher

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by NoneN, Dec 27, 2009.

  1. NoneN

    NoneN Guest

    0
     
    When will Plesk "officially" support PHP 5.2.6 or higher? From what I understand the latest version of PHP that is "officially" supported is 5.1.6. There are many people who now need 5.2.x or higher support. (for example, the new vBulletin 4.0 REQUIRES PHP 5.2.x or higher (recommends 5.2.6 or higher)).

    I'd rather not have to migrate my site to cPanel if I don't absolutely need, but unless we can get some official support for a PHP version that is more up-to-date it may be the only option for many.
     
  2. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,564
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Well, If I correctly understood you mean PHP for customer's vhosts? And what do you mean "Official support for PHP 5.2.6 or higher"? According Plesk 9.2.3 release note PHP 5 is already supported and you can use any 5.x version. What is the problem here?
     
  3. NoneN

    NoneN Guest

    0
     
    I have a Server (CentOS) running Plesk 9.2.3 and am told by my provider that PHP 5.1.6 is the highest version of PHP available for Plesk.

    This is what I received from my provider:

     
  4. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,564
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    Well. Let me clarify a little bit. There are two PHP on Plesk server - one for customer's vhosts and one for Plesk admin interface operation. Really, you can't upgrade PHP for Plesk panel interface operation because it will break Plesk. But you can safely upgrade customer's PHP without any problems. You can compile it from source too. Just detect original options for ./configure with usual phpinfo() for default PHP and use it for compiling. A lot of Plesk users have latest PHP version for customers vhosts and it works fine.
     
  5. Roy Boverhof

    Roy Boverhof Basic Pleskian

    23
    23%
    Joined:
    Mar 1, 2009
    Messages:
    27
    Likes Received:
    0
    Upgrade php to 5.2.x on Plesk running inside Virtuozzo / CentOS 5

    I was looking for the solution to this problem and found ART's solution: http://www.atomicorp.com/wiki/index.php/PHP

    This worked great for me, upgraded php to 5.2.12 :)
     
  6. NoneN

    NoneN Guest

    0
     
    I am a customer on a vhost and I need PHP 5.2.6 (with APC), so what you are saying is, my provider could actually upgrade my vhost to PHP 5.2.6 w/APC without breaking Plesk and I would be able to continue to upgrade my Plesk Control Panel in my vhost as new versions of Plesk come out without any problems???
     
  7. IgorG

    IgorG Forums Analyst Staff Member

    49
    24%
    Joined:
    Oct 27, 2009
    Messages:
    24,564
    Likes Received:
    1,243
    Location:
    Novosibirsk, Russia
    If you are not Plesk server administrator, that upgrade PHP and Plesk can perform only your provider (Plesk server administrator).
     
Loading...