1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Outlook messages have From/To/Subject blank with SPF checking on

Discussion in 'Plesk 9.x for Linux Issues, Fixes, How-To' started by Reggie Thomson, Dec 13, 2008.

  1. Reggie Thomson

    Reggie Thomson Guest

    0
     
    With Plesk 9.0.0 and psa-qmail 1.03-fc7.build90081117.17:

    If spf checking is switched on, qmail appears to put an extra line after the SPF line in the mail header. This means that the remaining parts of the header appear in the body of the email as the message, and the email appears on Outlook to have come From (blank), going to (blank) with subject (blank).

    To solve this, under "Mail Server Settings", ensure the "Switch on SPF spam protection" box is unchecked.

    I assume we have to wait for a solution from Qmail or swsoft before I can re-enable spam protection, unless someone can give me an alternative solution.
     
  2. Brujo

    Brujo Regular Pleskian

    28
    57%
    Joined:
    Mar 4, 2006
    Messages:
    278
    Likes Received:
    2
    Location:
    Germany
  3. 105547111

    105547111 Silver Pleskian

    32
    30%
    Joined:
    Jul 13, 2006
    Messages:
    643
    Likes Received:
    2
    I doubt spf works anyway on incoming. Have a close look /var/qmail/control

    With plesk 8.6 used to be a file called spfbehavior which contained a number corresponding to the level you got turned on.

    Why now with Plesk 9.0 it does not exist?
     
  4. Brujo

    Brujo Regular Pleskian

    28
    57%
    Joined:
    Mar 4, 2006
    Messages:
    278
    Likes Received:
    2
    Location:
    Germany
    i still have the issue and logentrys in my mail log
    in /etc/psa/spf/spfguess i have this enry: a/24 mx/24 ptr

    any hint whats wrong
     
  5. Reggie Thomson

    Reggie Thomson Guest

    0
     
    Hi Brujo,

    Thanks for the link.

    Given that SPF is not really a good solution to spam (see http://david.woodhou.se/why-not-spf.html) I think I will just disable it for the moment. I may try again when Plesk 9.0.1 indicates that it has solved these problems.

    I currently have a more serious problem of a non-functioning Qmail server, possibly due to an incorrect command in the watchdog - but I'm still investigating.
     
  6. Reggie Thomson

    Reggie Thomson Guest

    0
     
    I switched off the Watchdog for "IMAP/POP3 Server (Courier-IMAP)" and also for "SMTP Server (QMail)".

    After a while, I received some emails on my account. I then noticed that I was able to restart the Qmail in "Services Management". When I went to look at the watchdog settings, I see that "SMTP Server (QMail)" is now being checked (i.e. green arrow). However, returning to "Services Management" and Qmail now has a red X.

    It appears to be working, though - I've just sent myself a test message. Fingers crossed that it won't crash again.

    Something here is decidedly ropey.
     
  7. WiReDWolF

    WiReDWolF Guest

    0
     
    This worked great - thanks for the tip.
     
Loading...