1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

Permission denied when add DNS record

Discussion in 'Plesk for Windows - 8.x and Older' started by mrbean, Oct 20, 2008.

  1. mrbean

    mrbean Guest

    0
     
    This happen during addition of dns record via plesk api.

    Let's assume the site to add MX record is testing1.com

    [domain] => SimpleXMLElement Object
    (
    [get] => SimpleXMLElement Object
    (
    [result] => SimpleXMLElement Object
    (
    [status] => ok
    [filter-id] => testing1.com
    [id] => 53
    [data] => SimpleXMLElement Object
    (
    [gen_info] => SimpleXMLElement Object
    (
    [cr_date] => 2008-10-20
    [name] => testing1.com


    From above, I will know the for testing1.com, id=53.


    Sample code:

    $xmldoc= '
    <?xml version="1.0" encoding="UTF-8"?>
    <packet version="1.5.0.0">

    <dns>

    <add_rec>
    <domain_id>53</domain_id>
    <type>MX</type>
    <host>testing1.com.</host>
    <value>ASPMX2.GOOGLEMAIL.COM.</value>
    <opt>10</opt>
    </add_rec>

    </dns>

    </packet>
    ';

    return $xmldoc;



    But final result is permission denied. See below.


    [dns] => SimpleXMLElement Object
    (
    [add_rec] => SimpleXMLElement Object
    (
    [result] => SimpleXMLElement Object
    (
    [status] => error
    [errcode] => 1006
    [errtext] => Permission denied.
    )

    )

    )



    Any idea? It looks like hard to find any support via plesk. Guys, please help me.
     
  2. prince

    prince Regular Pleskian

    24
    53%
    Joined:
    Aug 16, 2006
    Messages:
    166
    Likes Received:
    0
    Try doing a permissions check for the domain
     
Loading...