1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

php 5.1.6 to 5.2

Discussion in 'Plesk for Linux - 8.x and Older' started by fishface, Aug 14, 2007.

  1. fishface

    fishface Guest

    0
     
    Currently have php 5.1.6

    When trying to use yum update php (which shows 5.2.3 is available) i get these errors:
    Error: Missing Dependency: php < 5.2.0 is needed by package php-sqlite
    Error: Missing Dependency: php-common = 5.1.6-3.5.fc6 is needed by package php-imap
    Error: Missing Dependency: php-common = 5.1.6-3.5.fc6 is needed by package php-xml
    Error: Missing Dependency: php-common = 5.1.6-3.5.fc6 is needed by package php-mysql


    Anyone help?

    thanks
     
  2. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
  3. mcalthrop

    mcalthrop Guest

    0
     
    Same here...

    Hi,

    I'm running FC6 64-bit, with Plesk 8.6.0 (and I just did all the latest upgrades on the Plesk control panel).

    Am trying to upgrade from PHP 5.1.6 to 5.2.6 using yum - and am having similar trouble to fishface: I do a 'yum update php', and I get a whole load of dependency checking, and it bails out like this:

    Error: Missing Dependency: php < 5.2.0 is needed by package php-sqlite

    And returns 1 to the shell (that's the only error message I get, btw).

    I had a look at the link atomicturtle posted, and could not find the solution to the above problem; specifically, I followed the instructions on this page:

    http://www.atomicorp.com/wiki/index.php/PHP

    But as you can see from the error displayed above, this did not work.

    Help, please!

    thanks in advance,

    Matt

    PS - I just realised the original thread had been posted in "Plesk 8.1 for Linux", so have duplicated the content of this post in the correct forum... sorry for cross-posting!
     
Loading...