1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

PHP 5.1 or newer for Plesk 8.0

Discussion in 'Plesk for Linux - 8.x and Older' started by akat1, Jul 19, 2007.

  1. akat1

    akat1 Guest

    0
     
    I am a self managed VPS and an application I have requires PHP 5.1 or greater

    I am on a Fedora Core 4.1 with the following

    PHP 5.0.4-10.5.1.swsoft
    MySQL 4.1.14-1.FC4.1

    psa v8.0.0_build80060505.15 os_FedoraCore 4

    Is there a PHP 5.1 build that works with plesk or are there modifications I need to do without crashing Plesk

    I am a newbie to installing linux packages so any detail helpful thanks
     
  2. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
  3. akat1

    akat1 Guest

    0
     
    sorry for maybe sounding stupid but I excute the above command in an ssh session and type that string and it will install PHP5.2 and all libraries and will work with Plesk 8.0

    also where is the php.ini file by default in a VPS can't seem to find it
     
  4. akat1

    akat1 Guest

    0
     
    I ran below from ssh session as root and did not see the updated version of php in plesk not sure if it is installed or not, I rebooted the VPS and still no changes please help Thank You.



    yum update php
    2772/2772
    Added 2772 new packages, deleted 0 old in 42.10 seconds
    Resolving Dependencies
    --> Populating transaction set with selected packages. Please wait.
    ---> Downloading header for php to pack into transaction set.
    php-5.2.3-1.fc4.art.i386. 100% |=========================| 13 kB 00:00
    ---> Package php.i386 0:5.2.3-1.fc4.art set to be updated
    --> Running transaction check
    --> Processing Dependency: php-common = 5.2.3-1.fc4.art for package: php
    --> Processing Dependency: php = 5.0.4-10.5.1.swsoft for package: php-imap
    --> Processing Dependency: php-cli = 5.2.3-1.fc4.art for package: php
    --> Processing Dependency: php = 5.0.4-10.5.1.swsoft for package: php-snmp
    --> Processing Dependency: php = 5.0.4-10.5.1.swsoft for package: php-ncurses
    --> Processing Dependency: php = 5.0.4-10.5.1.swsoft for package: php-xml
    --> Processing Dependency: php = 5.0.4-10.5.1.swsoft for package: php-mbstring
    --> Processing Dependency: php = 5.0.4-10.5.1.swsoft for package: php-mysql
    --> Processing Dependency: /usr/bin/php for package: psa-turba
    --> Processing Dependency: php = 5.0.4-10.5.1.swsoft for package: php-gd
    --> Processing Dependency: php = 5.0.4-10.5.1.swsoft for package: php-xmlrpc
    --> Processing Dependency: php = 5.0.4-10.5.1.swsoft for package: php-bcmath
    --> Processing Dependency: /usr/bin/php for package: psa-kronolith
    --> Processing Dependency: php = 5.0.4-10.5.1.swsoft for package: php-odbc
    --> Processing Dependency: php = 5.0.4-10.5.1.swsoft for package: php-dba
    --> Processing Dependency: php = 5.0.4-10.5.1.swsoft for package: php-pear
    --> Processing Dependency: /usr/bin/php for package: psa-mnemo
    --> Processing Dependency: php = 5.0.4-10.5.1.swsoft for package: php-devel
    --> Processing Dependency: php = 5.0.4-10.5.1.swsoft for package: php-soap
    --> Processing Dependency: php = 5.0.4-10.5.1.swsoft for package: php-ldap
    --> Processing Dependency: php = 5.0.4-10.5.1.swsoft for package: php-pgsql
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    ---> Downloading header for php-imap to pack into transaction set.
    php-imap-5.2.3-1.fc4.art. 100% |=========================| 12 kB 00:00
    ---> Package php-imap.i386 0:5.2.3-1.fc4.art set to be updated
    ---> Downloading header for php-xmlrpc to pack into transaction set.
    php-xmlrpc-5.2.3-1.fc4.ar 100% |=========================| 12 kB 00:00
    ---> Package php-xmlrpc.i386 0:5.2.3-1.fc4.art set to be updated
    ---> Downloading header for php-xml to pack into transaction set.
    php-xml-5.2.3-1.fc4.art.i 100% |=========================| 13 kB 00:00
    ---> Package php-xml.i386 0:5.2.3-1.fc4.art set to be updated
    ---> Downloading header for php-mbstring to pack into transaction set.
    php-mbstring-5.2.3-1.fc4. 100% |=========================| 12 kB 00:00
    ---> Package php-mbstring.i386 0:5.2.3-1.fc4.art set to be updated
    ---> Downloading header for php-bcmath to pack into transaction set.
    php-bcmath-5.2.3-1.fc4.ar 100% |=========================| 12 kB 00:00
    ---> Package php-bcmath.i386 0:5.2.3-1.fc4.art set to be updated
    ---> Downloading header for php-devel to pack into transaction set.
    php-devel-5.2.3-1.fc4.art 100% |=========================| 42 kB 00:00
    ---> Package php-devel.i386 0:5.2.3-1.fc4.art set to be updated
    ---> Downloading header for php-pear to pack into transaction set.
    php-pear-1.5.0-5.fc4.art. 100% |=========================| 27 kB 00:00
    ---> Package php-pear.noarch 1:1.5.0-5.fc4.art set to be updated
    ---> Downloading header for php-ldap to pack into transaction set.
    php-ldap-5.2.3-1.fc4.art. 100% |=========================| 12 kB 00:00
    ---> Package php-ldap.i386 0:5.2.3-1.fc4.art set to be updated
    ---> Downloading header for php-odbc to pack into transaction set.
    php-odbc-5.2.3-1.fc4.art. 100% |=========================| 12 kB 00:00
    ---> Package php-odbc.i386 0:5.2.3-1.fc4.art set to be updated
    ---> Downloading header for php-pgsql to pack into transaction set.
    php-pgsql-5.2.3-1.fc4.art 100% |=========================| 12 kB 00:00
    ---> Package php-pgsql.i386 0:5.2.3-1.fc4.art set to be updated
    ---> Downloading header for php-common to pack into transaction set.
    php-common-5.2.3-1.fc4.ar 100% |=========================| 16 kB 00:00
    ---> Package php-common.i386 0:5.2.3-1.fc4.art set to be updated
    ---> Downloading header for php-ncurses to pack into transaction set.
    php-ncurses-5.2.3-1.fc4.a 100% |=========================| 12 kB 00:00
    ---> Package php-ncurses.i386 0:5.2.3-1.fc4.art set to be updated
    ---> Downloading header for php-gd to pack into transaction set.
    php-gd-5.2.3-1.fc4.art.i3 100% |=========================| 12 kB 00:00
    ---> Package php-gd.i386 0:5.2.3-1.fc4.art set to be updated
    ---> Downloading header for php-mysql to pack into transaction set.
    php-mysql-5.2.3-1.fc4.art 100% |=========================| 13 kB 00:00
    ---> Package php-mysql.i386 0:5.2.3-1.fc4.art set to be updated
    ---> Downloading header for php-dba to pack into transaction set.
    php-dba-5.2.3-1.fc4.art.i 100% |=========================| 12 kB 00:00
    ---> Package php-dba.i386 0:5.2.3-1.fc4.art set to be updated
    ---> Downloading header for php-cli to pack into transaction set.
    php-cli-5.2.3-1.fc4.art.i 100% |=========================| 13 kB 00:00
    ---> Package php-cli.i386 0:5.2.3-1.fc4.art set to be updated
    ---> Downloading header for php-snmp to pack into transaction set.
    php-snmp-5.2.3-1.fc4.art. 100% |=========================| 12 kB 00:00
    ---> Package php-snmp.i386 0:5.2.3-1.fc4.art set to be updated
    ---> Downloading header for php-soap to pack into transaction set.
    php-soap-5.2.3-1.fc4.art. 100% |=========================| 12 kB 00:00
    ---> Package php-soap.i386 0:5.2.3-1.fc4.art set to be updated
    --> Running transaction check
    --> Processing Dependency: libpq.so.4 for package: php-pgsql
    --> Processing Dependency: php-pdo for package: php-odbc
    --> Processing Dependency: php-pdo for package: php-mysql
    --> Processing Dependency: php-pdo for package: php-pgsql
    --> Processing Dependency: libmysqlclient.so.15(libmysqlclient_15) for package: php-mysql
    --> Processing Dependency: libmysqlclient.so.15 for package: php-mysql
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    ---> Downloading header for mysql to pack into transaction set.
    mysql-5.0.27-1.fc4.art.i3 100% |=========================| 35 kB 00:00
    ---> Package mysql.i386 0:5.0.27-1.fc4.art set to be updated
    ---> Downloading header for php-pdo to pack into transaction set.
    php-pdo-5.2.3-1.fc4.art.i 100% |=========================| 12 kB 00:00
    ---> Package php-pdo.i386 0:5.2.3-1.fc4.art set to be updated
    ---> Downloading header for postgresql-libs to pack into transaction set.
    postgresql-libs-8.0.8-1.F 100% |=========================| 14 kB 00:00
    ---> Package postgresql-libs.i386 0:8.0.8-1.FC4.1 set to be updated
    --> Running transaction check
    --> Processing Conflict: mysql conflicts psa < 8.1
    --> Processing Dependency: mysql = 4.1.14-1.FC4.1 for package: mysql-bench
    --> Processing Dependency: libmysqlclient_r.so.14 for package: mysql-server
    --> Processing Dependency: libmysqlclient.so.14 for package: perl-DBD-MySQL
    --> Processing Dependency: libmysqlclient.so.14 for package: mysql-server
    --> Processing Dependency: mysql = 4.1.14-1.FC4.1 for package: mysql-devel
    --> Processing Dependency: mysql = 4.1.14-1.FC4.1 for package: mysql-server
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    ---> Downloading header for mysql-bench to pack into transaction set.
    mysql-bench-5.0.27-1.fc4. 100% |=========================| 33 kB 00:00
    ---> Package mysql-bench.i386 0:5.0.27-1.fc4.art set to be updated
    ---> Downloading header for mysqlclient14 to pack into transaction set.
    mysqlclient14-4.1.22-2.fc 100% |=========================| 5.0 kB 00:00
    ---> Package mysqlclient14.i386 0:4.1.22-2.fc4.art set to be updated
    ---> Downloading header for mysql-server to pack into transaction set.
    mysql-server-5.0.27-1.fc4 100% |=========================| 33 kB 00:00
    ---> Package mysql-server.i386 0:5.0.27-1.fc4.art set to be updated
    ---> Downloading header for mysql-devel to pack into transaction set.
    mysql-devel-5.0.27-1.fc4. 100% |=========================| 28 kB 00:00
    ---> Package mysql-devel.i386 0:5.0.27-1.fc4.art set to be updated
    --> Running transaction check
    --> Processing Conflict: mysql conflicts psa < 8.1
    --> Finished Dependency Resolution
    Error: mysql conflicts with psa < 8.1
     
  5. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    Yeah thats a safety check, PSA 8.0 does not co-exist with mysql 5. You'll need to upgrade to PSA 8.1 to do that. Otherwise I believe with some hacking you could use my php packages in that environment. I know other people have done that by using the Mysql5 client library,
     
  6. akat1

    akat1 Guest

    0
     
    Thank You for all your help with my situation, I upgraded the plesk to 8.1.1 and the yum update went smooth, I was able to update to 5.2 php and 5.0.21 Mysql .
     
  7. ukhost4u

    ukhost4u New Pleskian

    22
    23%
    Joined:
    Feb 15, 2002
    Messages:
    8
    Likes Received:
    0
    Is there currently an issue with this script.

    I am getting:

    Error: mysql conflicts with psa < 8.1

    The only problem is that I have just installed 8.2.0 on this server using a new install on a new VPS server.

    Any suggestions?
     
  8. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    any possibility that both the psa 8.0 and 8.2 rpms are installed? You can check with: rpm -q psa
     
Loading...