1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

php applications

Discussion in 'Plesk for Linux - 8.x and Older' started by thonuz, May 10, 2006.

  1. thonuz

    thonuz Guest

    0
     
    I have fedora core 4 installed. And have noticed that none of my applications, in the application vault install anymore. It seems all but one needs php4 and fedora core has php5.
    I really need these apps and would like to know if downgrading php5 to php4 is safe to do, also will I miss any advantages of php5?
    My other option is to install suse 9.3 which has php4 I think.
    Does anyone have a suggestion for this.
    Plesk 8 is supposed to work with fedora core 4, but there was no warning that the site applications wont install. 20 new apps advertized, but I am down to the couple that use php4 ;*(

    Thanks in advance
     
  2. timgdixon

    timgdixon Guest

    0
     
    I am having similar troubles and was told this:

    Specs:
    Plesk version psa v8.0.0_build80060331.13 os_FedoraCore 4
    Operating system Linux 2.6.11-1.1369_FC4smp

    """
    Those requirements were taken from products' websites, but you can work them around with the following changes in /usr/local/psa/var/cgitory/$appname$/info:

    <REQUIREMENTS>
    <VERSION name="PHP" value="4.0.0" rel="ge">
    </REQUIREMENTS>

    Note, that $appname$ is the name of application needed to be installed. Also, please, note that we didn't test the application with your php version.
    """

    When I open that file and look, this is what I see:


    <REQUIREMENTS>
    <APACHE_VHOST name="PHP" value="on" />
    <DATABASE type="mysql" name="" username="" passwd="" host="localhost" port="4564" description="DATABASE.CAPTION" />
    </REQUIREMENTS>
    ********************************************
    Do you think I could just change this value:
    <APACHE_VHOST name="PHP" value="on" />
    To this:
    <APACHE_VHOST name="PHP" value="4.0.0" rel="ge"/>

    Any help is surely appreciated.
     
  3. thonuz

    thonuz Guest

    0
     
    Hi timgdixon,

    I also recieved these instructions and it did not work for me. There are also other problems if this is the initial 1and1 fedora core 4 server.
    I was told to re-image the server as it has the fixed newer kernel.
    If you look using ssh, php3.4.5 is all there. The kernel is the culprit.
    One other proble is if you have the wrong language link to 1and1. Then you know, its kernel upgrade time.
     
  4. timgdixon

    timgdixon Guest

    0
     
    Hello thonuz,

    Its frustrating to say the least that this was a purchased package that came with the 100 domain license and the only thing that sort of works is SpamAssassin, but then again you have to disable Dr.Web.

    I'll keep you posted as to what I discover.
     
  5. thonuz

    thonuz Guest

    0
     
    1and1 were aware of the problem and patched the kernel or something. I am having other issues. Now my domain users cannot log in to the control panel. Iv e gone through all the steps in plesk over again. I wonder if suse 9.3 is any better?
    Anyway I am re-imaging this evening, hopefully all this will go away.
     
  6. thonuz

    thonuz Guest

    0
     
    I have to manualy edit the info file for each so:
    Do this in the info file. I had to figure out this myself.

    <APACHE_VHOST name="PHP" value="on" />
    <DATABASE type="mysql" name="" username="" passwd="" host="localhost" />
    <VERSION name="PHP" value="4.1.0" rel="ge" />


    As you can see the value needs to be 4.1, Swsoft said it should be 4.0. This is incorrect....
    I tested this in for advancedpoll. Works fine.
    Still no clue as to why I should have to do this on a clean re-image of Fedora Core 4
     
  7. timgdixon

    timgdixon Guest

    0
     
    Thank you thonuz. So far I have pretty successfully installed 3 packages at random. They are listed below.

    Working
    /usr/local/psa/var/cgitory/$appname$/info
    *info.xml*
    <APACHE_VHOST name="PHP" value="on" />
    <DATABASE type="mysql" name="" username="" passwd="" host="localhost" />
    <VERSION name="PHP" value="4.1.0" rel="ge" />

    The previous suggestion was to use this:

    Not Working
    <REQUIREMENTS>
    <VERSION name="PHP" value="4.0.0" rel="ge">
    </REQUIREMENTS>

    Packages installed:
    AdvancedPoll 2.03 - works fine
    osCommerce 2.2ms2 - buggy, images are not appearing
    PostNuke 0.761a - seems to be fine

    Hopefully this will help others.
     
  8. uagent

    uagent Guest

    0
     
    Thanks timgdixon. Your suggestion worked for WebCalendar as well.
     
  9. ray201

    ray201 Guest

    0
     
    Gents,

    The thread worked for my 100 domain license on FC4 as well. However after an successful install i only get a blank page.

    Check www.westvik.net/blog which should have been b2evolution. Any ideas on this?

    Same also seem to go for apps which dossnt have the php bug.
     
  10. timgdixon

    timgdixon Guest

    0
     
    Ray201,

    Not sure if you have got something working after your post, but I see the opening page:

    Welcome to b2evolution.....\
    blah
    blah
    blah
     
  11. ray201

    ray201 Guest

    0
     
    I did mate,

    I upgraded to Plesk 8.0.1 and poff. they all worked.

    Cheers for your reply

    Ray
     
  12. timgdixon

    timgdixon Guest

    0
     
    No bother at all. I have a problem in that the packages seems to have broken image links all over the place (you know the red X) and I suppose its a path problem of some sort. Just haven't had the time to track it down.
     
Loading...