1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

php.ini path changed by zend upgrade

Discussion in 'Plesk for Linux - 8.x and Older' started by gavinf, Aug 23, 2005.

  1. gavinf

    gavinf Guest

    0
     
    Hi,

    Updgrade zend and it sym linked my /etc/php.ini file to /usr/local/Zend/etc/php.ini which is fine . . . everything works.

    However, I want to make changes to the php.ini file to the include_path. When I uses vi editor to look at the file I discover there's no setting for the inlcude_path, yet phpinfo() lists it as being .:/usr/share/pear.

    Is their a default setting for include_path if it isn't set? Is it set elsewhere? Or am I just looking at the wrong php.ini file?

    Thanks!
     
  2. eilko

    eilko Regular Pleskian

    28
    73%
    Joined:
    Aug 1, 2001
    Messages:
    468
    Likes Received:
    4
    Location:
    Enschede, Netherlands
    where is your phpinfo.php located?
     
  3. gavinf

    gavinf Guest

    0
     
  4. eilko

    eilko Regular Pleskian

    28
    73%
    Joined:
    Aug 1, 2001
    Messages:
    468
    Likes Received:
    4
    Location:
    Enschede, Netherlands
    this one looks a lot like mine 4.3.10. It seems the pear path is default. My php.ini has the default_path statement commented out.
     
  5. gavinf

    gavinf Guest

    0
     
    Thanks! Really appreciate your help. So is the default_path in the php.ini file or somewhere else? My php.ini doesn't seem to have a default_path setting.

    Thanks for any further input you can provide :)
     
  6. eilko

    eilko Regular Pleskian

    28
    73%
    Joined:
    Aug 1, 2001
    Messages:
    468
    Likes Received:
    4
    Location:
    Enschede, Netherlands
    you can find or add this directive to php.ini as serverwide setting. You probably can also add it to a .htaccess file to enable it on a specific subdir.


    check the manual to see how you can use this directive: http://nl3.php.net/ini
     
Loading...