1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice
  3. Dear Pleskians, I really hope that you will share your opinion in this Special topic for chatter about Plesk in the Clouds. Thank you!
    Dismiss Notice

PHP5 und PHP4

Discussion in 'Plesk for Linux - 8.x and Older' started by key323, Jan 13, 2007.

  1. key323

    key323 Guest

    0
     
    Hallo,
    ich habe immoment plesk8.1 auf einem debian system installiert und würde gerne zwischen php4 und php5 wählen können.. wie kann ich jetzt noch php5 installieren?
     
  2. CryoGenID

    CryoGenID Regular Pleskian

    25
    90%
    Joined:
    Apr 14, 2004
    Messages:
    150
    Likes Received:
    0
    Hey!

    Also ich glaub da kannst Du nur manuell PHP5 kompilieren und dann genauso manuell für jede Domain einzeln in's Konfig-File reinschreiben dass er deine selbstkompilierte PHP5-Version nehmen soll...
    Nur unter Windows gibt's die Möglichkeit von Plesk aus zu wählen ob Du PHP4 oder PHP5 nehmen willst (warum auch immer das bei Plesk für Linux nicht geht...)
     
  3. timtrott

    timtrott Guest

    0
     
    php4 AND php5?

    Can someone translate this thread to English? I think it might be about the problem I am having --

    I updated to PSA 8.1 and it SAYS (in the upgrade information) that it now has php4 AND php5, but when I tried to install a php5 program it stopped and said I have php4.4 installed and not php5. I was expecting some kind of selector in the setup screen but it's not there. Do I need to install php5? Will it break my older php4 functions?
     
  4. Highland

    Highland Guest

    0
     
  5. timtrott

    timtrott Guest

    0
     
    That didn't help much.......

    Hey! There thus I believe can you PHP5 only manually compile and then for each Domain in's Konfig file write in individually just as manually that it your compiled PHP5-Version to take is... Only under Windows gibt's the possibility of Plesk from to select whether you PHP4 or PHP5 take want (why also always with Plesk for Linux does not go...)


    (I put it in the 'fish and that's what came out)
     
  6. CryoGenID

    CryoGenID Regular Pleskian

    25
    90%
    Joined:
    Apr 14, 2004
    Messages:
    150
    Likes Received:
    0
    Hey ;-)

    Funny translation :p

    What i was saying in my german post was, that you can compile PHP5 manually and then have to add/edit the apache config-files manually to use the compiled php5-version.
    Only the Windows-Version of Plesk (I don't know why they only did that feature for windows) can switch between PHP4 and PHP5 from within Plesk.

    Hope that helped you a little bit ;-)
     
  7. timtrott

    timtrott Guest

    0
     
    Ahhhhh!!!! That's what I needed to know.

    I had not noticed the distinction for Windows vs Linux in the Plesk press release (we are Linux). I either need to tread very carefully or forget about PHP5 for a while.

    I know very well about those "funny" translations -- My wife is from Holland.

    I thank you very much for your prompt and informative response.
     
  8. CryoGenID

    CryoGenID Regular Pleskian

    25
    90%
    Joined:
    Apr 14, 2004
    Messages:
    150
    Likes Received:
    0
    Sure, you're welcome ;)
     
Loading...