1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

Plesk 7.5.4 and Mysql 4

Discussion in 'Plesk for Linux - 8.x and Older' started by LordRayden, Nov 15, 2005.

  1. LordRayden

    LordRayden Guest

    0
     
    Hi Folks,

    I have one Question.
    I have a FC2 Server with Plesk 7.5.4 and Mysql 4.0.24-Max.
    Everything works fine except the update.

    When I try to Update (there are a few Horde Updates and so on) I get

    Preparing for packages installation...
    ----- begin of output -----
    Installing mysql-server-3.23.58-16.FC2.1.i386.rpm
    Installing mysql-3.23.58-16.FC2.1.i386.rpm
    warning: /root/psa/PSA_7.5.4/FC2_std.updates/mysql-server-3.23.58-16.FC2.1.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
    error: Failed dependencies:
    MySQL-server >= 4.0 is needed by (installed) MySQL-Max-4.0.24-0

    ----- end of output -----
    ===> Autoinstaller: stopped

    How can I tell the Autoinstaller not to install mysql3?

    Thanks

    LordRayden
     
  2. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    Try installing mysql 4/4.1 from the packages on my site, they should resolve this problem.
     
  3. LordRayden

    LordRayden Guest

    0
     
    can you give me a link?

    OK, I think I found it but how do I update?
    rpm -Uhv is not working and Im not sure if I should use --force

    Thanks

    LordRayden
     
  4. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
  5. LordRayden

    LordRayden Guest

    0
     
  6. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    It will be fine. It's probably just loading either headers or needed packages for dependancies.
     
  7. LordRayden

    LordRayden Guest

    0
     
    OK I tried this:

    [base]
    name=Atomic Rocket Turtle - $releasever - Base OS RPMS mirror
    baseurl=http://3es.atomicrocketturtle.com/3rd-party/base/$releasever/

    [updates]
    name=Atomic Rocket Turtle - $releasever - OS Update RPMS mirror
    baseurl=http://3es.atomicrocketturtle.com/3rd-party/updates/$releasever/

    and this

    [atomic]
    name=Atomic Rocket Turtle - $releasever - Atomic PSA-Compatible RPMS
    baseurl=http://3es.atomicrocketturtle.com/atomic/art/$releasever/
    baseurl=http://www.atomicrocketturtle.com/atomic/art/$releasever/

    and on both I get

    Cannot find any package matching mysql available to be updated.
    No actions to take

    Where is my mistake?

    Thanks

    LordRayden
     
  8. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    From ART's yum page

    Then run up2date:

    #up2date -update mysql

    Also, check out the bottom of:

    http://www.atomicrocketturtle.com/atomic/psa-7.5/3/RPMS/

    for other options on using ART's repos
     
  9. LordRayden

    LordRayden Guest

    0
     
    Thanks I did that, now i get this:

    up2date --update mysql

    Fetching Obsoletes list for channel: atomic...

    Fetching rpm headers...
    ########################################

    Name Version Rel
    ----------------------------------------------------------
    mysql 4.1.15 1.rhfc2.art i386


    Testing package set / solving RPM inter-dependencies...
    There was a package dependency problem. The message was:

    Unresolvable chain of dependencies:
    MySQL-Max-4.0.24-0 requires MySQL-server >= 4.0

    If I say up2date --update mysql-server i get the same.

    How to solve this one?

    Thank you

    LordRayden
     
  10. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    Try:

    up2date -i mysql-server
     
  11. LordRayden

    LordRayden Guest

    0
     
    I get

    Unresolvable chain of dependencies:
    MySQL-Max-4.0.24-0 requires MySQL-server >= 4.0

    I could use rpm -i --force but I don't know what could happen....

    Thanks

    LordRayden
     
  12. phoenixisp

    phoenixisp Silver Pleskian

    27
    57%
    Joined:
    Feb 2, 2002
    Messages:
    840
    Likes Received:
    0
    Did you do this?

    Also, remove any entries in /etc/sysconfig/rhn/sources other than ART's and try that.
     
  13. LordRayden

    LordRayden Guest

    0
     
    I did this with the same result.

    Thanks LordRayden
     
  14. atomicturtle

    atomicturtle Golden Pleskian

    29
     
    Joined:
    Nov 20, 2002
    Messages:
    2,110
    Likes Received:
    7
    Location:
    Washington, DC
    That sounds to me like you've got the mysql.com rpms on your system try running:

    yum update

    That should resolve the problem
     
Loading...