1. Please take a little time for this simple survey! Thank you for participating!
    Dismiss Notice
  2. Dear Pleskians, please read this carefully! New attachments and other rules Thank you!
    Dismiss Notice

Plesk 7.5.4 released!

Discussion in 'Plesk for Linux - 8.x and Older' started by eilko, Aug 24, 2005.

  1. eilko

    eilko Regular Pleskian

    28
    73%
    Joined:
    Aug 1, 2001
    Messages:
    468
    Likes Received:
    4
    Location:
    Enschede, Netherlands
    What's new in Plesk v.7.5.4 build 75050824.12
    ==============================================
    [+] 1. User interface rewritten in PHP5
    [+] 2. Spamassassin 3.0 is now supported
    [+] 3. Plesk Migration Manager can migrate resellers and user templates from Confixx platforms,
    [+] 4. Fourth level subdomains can now be created and served by Plesk.
    [+] 5. Ability to manage access to the control panel for Plesk clients (separate permission manageable through the control panel).
    [+] 6. Plesk Migration Manager can now migrate skeletons,
    [+] 7. Plesk Migration Manager can now migrate domain templates,
    [+] 8. Plesk Migration Manager can now migrate domains along with domain templates,
    [+] 9. Plesk Migration Manager can now migrate Spamassassin settings
    [+] 10. Plesk Migration Manager can now migrate custom buttons
    [+] 11. Plesk Migration Manager can now migrate Tomcat applications
    [+] 12. Command Line Interface includes a new utility for managing domain templates
    [+] 13. Command Line Interface includes a new utility for managing Tomcat applications
    [+] 14. Command Line Interface includes a new utility for managing mailserver
    [+] 15. Ability to change site application properties through API RPC
    [+] 16. Ability to retrieve the content of client accounts/domains by login name through API RPC
    [+] 17. AE integration with API RPC is now supported
    [+] 18. Plesk supports Coldfusion 7.0
    [+] 19. API to change hostname
    [+] 20. Support for long (up to 63 characters) database names
    [+] 21. Enhanced disk usage information
    [+] 22. Multivolume backups
    [+] 23. Improved statistics
    [*] 24. Shell access permission management simplified
    [+] 25. Skeletons support new archive types: tar, tar.gz, tgz
    [-] 26. Domain template names can now be unique
    [*] 27. Cosmetic changes in Session settings
    [*] 28. The same login name can be used for authorization of Client and Domain Administrator without any collisions.
    [*] 29. Optimization of memory usage by Psadump utility
    [+] 30. PHP with additionally compiled modules in Standard builds
    [+] 31. You can specify which domains to skip during backup
    [+] 32. Plesk Clients can have access to API RPC for managing/reselling domains
    [*] 33. Spamassassin Trainer improved
    [*] 34. Site Applications can be installed to the document root
    [+] 35. System Monitoring Module is shipped with Plesk
    [+] 36. Battlefield 1942 Game Server Module is shipped with Plesk
    [-] 37. API-RPC related issues resolved: API-RPC returns the domain status correctly, and Apache ASP and custom error documents are now handled properly.
    [+] 38. New operating systems supported: RedHat EL 4, Fedora Core 3, SuSE Linux 9.3, SuSE Linux 9.3 (AMD64), Ubuntu Linux 5.04
    [+] 39. On fresh installations of Plesk, virtual hosts will reside in /var/www directory in compliance with the Filesystem Hierarchy Standard.
     
  2. Flexis Hosting

    Flexis Hosting Guest

    0
     
    Frontpage not updated yet, but here is the page already with a "smaller" changelog. BTW, some nice improvement's, now let's hope the update is gonna be smooth. Anyone installed it already?
     
  3. Pagemakers

    Pagemakers Silver Pleskian

    31
    80%
    Joined:
    Dec 19, 2007
    Messages:
    664
    Likes Received:
    7
    Upgraded from 7.53 on 2 servers

    So far, so good.
     
  4. phatPhrog

    phatPhrog Guest

    0
     
    C.P. Updater

    Anyone have results on using a Plesk 7.5.3 Server | Updater for the 7.5.4 updates?

    I know the base packages need to be installed first and separate from all the rest, but will it matter which updates are applied after the base packages?

    Just want to be sure to get it right the first time. :)

    Thanks for any input.
     
  5. Pagemakers

    Pagemakers Silver Pleskian

    31
    80%
    Joined:
    Dec 19, 2007
    Messages:
    664
    Likes Received:
    7
    Worked perfectly for us from the CP.
     
  6. phatPhrog

    phatPhrog Guest

    0
     
    Updater

    Sounds great, but... after the base packages does it matter what order the remainder of Plesk packages are installed?

    Thanks for the heads up.
     
  7. k.satirli

    k.satirli Guest

    0
     
    wow.

    this update took me all of 10 minutes. and it didnt break anything. awesome job.
     
  8. mian

    mian Guest

    0
     
    few conflicts so had to remove qmail-scanner to get it installed.. all installed now but adding DNS records in the CP doesnt work anymore, clicking ok just keeps showing the form over and over without adding the record.

    edit: the problem was chk_ip_address_and_mask() javascript function was complaining about not being found, went to /javascript/chk.js.php which must have invalidated cache or something now it works.
     
  9. Pagemakers

    Pagemakers Silver Pleskian

    31
    80%
    Joined:
    Dec 19, 2007
    Messages:
    664
    Likes Received:
    7
    Re: Updater

    I installed via the CP so you don't have to worry about that.
     
  10. GlobalServe

    GlobalServe Basic Pleskian

    24
    23%
    Joined:
    Aug 15, 2005
    Messages:
    89
    Likes Received:
    0
    Everything OK after update...

    But why no MySQL 4.1. in the new package? :(
     
  11. lvalics

    lvalics Silver Pleskian Plesk Guru

    36
    43%
    Joined:
    Jun 20, 2003
    Messages:
    962
    Likes Received:
    31
    Location:
    Romania
    Preparing for packages installation...
    ----- begin of output -----
    Installing /PSA_7.5.4/rpm_FedoraCore_2/base/psa-courier-imap-add-7.5.4-fc2.build75050824.12.i586.rpm
    Installing /PSA_7.5.4/rpm_FedoraCore_2/base/courier-imap-3.0.8-fc2.build75050824.12.i586.rpm
    file /usr/bin/deliverquota from install of courier-imap-3.0.8-fc2.build75050824.12 conflicts with file from package maildrop-1.8.1-1.rhfc2.art
    file /usr/bin/maildirmake from install of courier-imap-3.0.8-fc2.build75050824.12 conflicts with file from package maildrop-1.8.1-1.rhfc2.art

    ----- end of output -----
    ===> Autoinstaller: stopped logging at Thu Aug 25 13:11:44 2005


    But can be resolved with a yum remove maildrop :D
     
  12. lvalics

    lvalics Silver Pleskian Plesk Guru

    36
    43%
    Joined:
    Jun 20, 2003
    Messages:
    962
    Likes Received:
    31
    Location:
    Romania
    first major problem :-((
    and is on BOTH servrs which I upgraded.


    The SMTP server returned an error. Account: 'domain.com', Server: 'www.domain.com', Protocol: SMTP, Server Response: 'rblsmtpd: 213.157.167.13 pid 20894: 451 Your mail has been rejected because the server you are sending to is misconfigured', Port: 25, Secure(SSL): No, Error Number: 0x800CCC60

    I disabled Enable MAPS spam protection and work now, BUT :-(((
     
  13. jamesyeeoc

    jamesyeeoc Guest

    0
     
    Check your /etc/xinetd.d/smtp_psa file, check the ServerArgs line. Make sure it has spaces instead of ';' characters separating the arguments. This was an early bug which was supposed to have been resolved, but there has been at least one other post about 7.5.4 saying the bug still exists... Example:

    service smtp
    {
    socket_type = stream
    protocol = tcp
    wait = no
    disable = no
    user = root
    instances = UNLIMITED
    server = /var/qmail/bin/tcp-env
    server_args = -Rt0 /usr/sbin/rblsmtpd -r sbl-xbl.spamhaus.org /var/qmail/bin/relaylock /var/qmail/bin/qmail-smtpd /var/qmail/bin/smtp_auth /var/qmail/bin/true /var/qmail/bin/cmd5checkpw /var/qmail/bin/true
    }

    And if you have multiple MAPS servers, there should be a ' -r ' between each one (AFAIR)
     
  14. lvalics

    lvalics Silver Pleskian Plesk Guru

    36
    43%
    Joined:
    Jun 20, 2003
    Messages:
    962
    Likes Received:
    31
    Location:
    Romania
    I cannot from PLESK use space when I use multiple MPAS, only ; is allowed.
     
  15. jamesyeeoc

    jamesyeeoc Guest

    0
     
    You would have to SSH into the server and manually edit the smtp_psa file. This is related to the previous bug which was supposed to have been fixed by now...
     
  16. phatPhrog

    phatPhrog Guest

    0
     
    Update Successful

    WOW is right. The updater is fantastic!

    Only had one error alert during backup.

    I have ARTs mysql 4.0.25 installed. Not sure if it is the reason for the error. Doubtful.

    I had to restart mysql via ssh.

    No obvious mysql errors in the logs so it was probably just a glitch.

    Absolutely no complaints here!

    So far it seems everything is working exceptionally well.

    Still have to check the Plesk BU feature. Works fine from ssh, but haven't used it from Plesk yet.
     
  17. Joe Beharriell

    Joe Beharriell Guest

    0
     
    Well, all seemed to go well. That is, until I went back to Updater.

    Now I get..

    Service Unavailable

    Service is not available now, probably your Plesk is misconfigured. Contact Your provider for details.

    Internal Plesk error occurred: AutoInstallerManager::getAutoInstaller() failed: AutoInstallerManager::_autoInstallerCall() failed: autoinstaller failed: Auto-installer does not work inside Virtuozzo environment. Refer to your service provider in order to obtain Plesk updates.

    Well, ain't that nifty. I've been inside a VPS this whole time, and have used Updater without problems many times before. Now, i'm stuck.. any ideas, folks?
     
  18. hegebutt

    hegebutt Guest

    0
     
    I installed through the Updater and after it completed, I could no longer access Plesk.

    Instead, I get:

    The file auth.php3 is part of Plesk distribution. It cannot be run outside of Plesk environment.

    I contacted my ISP and they said SW-Soft knows about the issue and is working on a fix.

    In the meantime, I have no access to my control panel. :(
     
  19. phatPhrog

    phatPhrog Guest

    0
     
    There are those that will agree with me. :)

    "I'm no expert"

    but the only difference I know of is that perhaps you aren't using (ART) http://atomicrocketturtle.com and Scott's YUM update channels.

    Like said in other posts, the only issue I had was having to restart mysql and psa-spamassassin from shell.

    Wish I could help more.
     
  20. jamesyeeoc

    jamesyeeoc Guest

    0
     
    As the message states, contact your Hosting provider :)
     
Loading...